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Welcome to Beatware® Mobile Designer™, an 
innovative new product that sets the standard for 
creating interactive SVG content for mobile and 
desktop devices. Whether you’re an experienced SVG 
coder or new to graphic design, Mobile Designer 
places the power to create professional-quality results 
at your fingertips.

Mobile Designer gives you unmatched power when 
creating SVG content without the requiring any 
knowledge of SVG or experience in hand coding. 
Mobile Designer comes with a comprehensive set of 
drawing and design tools as well as friendly dialogs that 
allow you to add interactivity to your designs with a few 
simple clicks of the mouse. You can even preview your 
designs with a quick click of the mouse and export both 
compressed and “human readable” SVG, both of which 
are perfect for display on a wide variety of mobile and 
desktop devices.

System requirements
Mobile Designer requires the following hardware and 
software:

• Pentium II-compatible CPU or better
• Windows 2000 or Windows XP
• 128MB of RAM (more recommended)
• 20MB of available hard disk space
• 800 by 600 resolution (higher recommended)
• CD-ROM or DVD-ROM drive if installing from 

CD.

Installing Mobile Designer
The Mobile Designer installer includes all of the files 
required to run Mobile Designer. Please refer to the 
ReadMe.html file in the installation folder before 
installing Mobile Designer for any last minute 
installation notes.

1. Insert the Beatware Mobile Designer CD into your 
CD-ROM or DVD-ROM drive.

2. If you have AutoPlay enabled, the Mobile Designer 
installer will run automatically after a few seconds. 
If it does not, open My Computer, right-click on 
the CD-ROM drive icon, and choose AutoPlay.

3. Follow the installer instructions that appear on 
your screen.

4. Double-click on the Beatware Mobile Designer 
icon to launch Mobile Designer from the 
installation folder.

SVG Player download

In order to preview your Mobile Designer content in 
SVG, you must have an SVG-enabled browser. The 
most popular SVG viewer is freely available for 
download from Adobe®, Inc. It can be downloaded 
from the Adobe web site, http://www.adobe.com.
Chapter 1: Introduction
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Registering Mobile Designer
The first time you launch Mobile Designer, you are 
given the opportunity to register the program online.

If you skip that option, you may register at any time by 
selecting Help/Registration.

Setting preferences
Mobile Designer includes several preferences that 
allow you to tailor your work environment to your 
preferred working style. 

To open the Preferences dialog:

Choose Edit > Preferences

General tab

The General tab specifies Mobile Designer’s behavior 
when you first launch the application.

To change the default action at launch

Select one of the following options:

• To open the Movie Creator dialog, choose Create 
New Document from the Launch Time Settings 
menu.

• To open the Open file dialog, choose Open File 
dialog from the Launch Time Settings menu.

• To open Mobile Designer and have it await your 
specific directives, choose Do Nothing from the 
Launch Time Settings menu.

Overscan tab

The Overscan tab specifies how your objects appear 
when the fall outside of the canvas in the overscan (off 
stage) area.

To change how objects appear in the overscan area:

Check or uncheck the Show overscan as half opacity 
box.

Online tab

The Online tab specifies your basic E-mail 
information. This information is used by Mobile 
Designer’s built-in feedback mechanism, which is 
accessible by choosing Help > Feedback.

The SMTP Server and e-Mail Account text entry 
fields are provided for you to enter your outgoing mail 
server and E-mail address information, respectively.

The Include a System Profile box automatically 
includes basic system information such as CPU 
performance and available RAM as part of any 
feedback message you send. 

Tooltips tab

The Tooltips tab specifies whether or not you want 
helpful tooltips to appear when you rest your mouse 
over buttons and other widgets in Mobile Designer.

To hide or show tooltips:

Toggle the Enable Tooltips box.

Miscellaneous tab

The Miscellaneous tab specifies how many levels of 
undo are available. In addition, you can reactivate 
Mobile Designer’s warning messages if they have been 
turned off.

To set the number of available undo levels:

Select one of the following options:

• For Unlimited Undo, choose Unlimited. 
Practically speaking, with this option the number 
of undo levels available to you is limited by your 
computer memory.
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• For a specific number of undo levels, choose 
Limited to n Levels and specify a value for n.

Note: Mobile Designer maintains a separate undo list for each 
component and scene. When using the undo feature, the actions 
that are undone are for the current scene or component only.

To display all of Mobile Designer’s warning messages:

Press the Reactivate Warning Messages button.

For more information
Numerous sources of information are available to 
answer questions and provide more information on 
Mobile Designer. 

Beatware Mobile Designer User Guide

The Beatware Mobile Designer User Guide (this 
document) contains a comprehensive description of 
each of the features available in Mobile Designer. It is 
organized functionally to provide readily accessible 
information on topics of current interest. This guide is 
also available in PDF format from the Help menu.

Beatware Mobile Designer Tutorial

The Beatware Mobile Designer Tutorial provides a 
hands on description of how to use Mobile Designer to 
build a fully functional, interactive web site that can be 
viewed on a variety of modern mobile devices.

The Beatware Mobile Designer Tutorial is an ideal 
place to start learning about how to design content in 
Mobile Designer.

Mobile Designer web site

The Beatware Mobile Designer web site, located at 
http://www.beatware.com/products/mobiledesigner/
index.htm, contains the latest information available on 

Mobile Designer including numerous sample banners, 
documentation and other information.

Beatware Customer Support

Licensed Mobile Designer users are entitled to free 
customer support via e-mail. The Beatware support 
staff strives to respond to all customer support 
questions within one business day. Please send your 
customer support inquiries as well as feature 
suggestions to support@beatware.com.
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Beatware Mobile Designer is a powerful application for designing interactive content destined for both mobile 
devices and the World Wide Web. Using Mobile Designer, you can create everything from simple animations to 
complete web sites and output that content in SVG Tiny, SVG Basic and full SVG as well as in a variety of non-
interactive formats.

This User Guide is designed as a reference to provide quick and easy explanations of how to use Mobile Designer 
and get the most out of its powerful tools and capabilities. After reading this chapter, you should be able to use the 
Table of Contents and Index to look up particular topics of interest. For a comprehensive tutorial on how to use 
Mobile Designer, please see the Beatware Mobile Designer 1.0 Tutorial Guide.
Chapter 2: An Overview of 
Beatware Mobile Designer
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A high level overview of Mobile Designer

Mobile Designer is, in many ways, like any other graphic design application. There are tools for drawing, color 
samples for setting and changing colors, and inspector panels for changing the various attributes of the tools you 
use and the objects you draw on the canvas.

Integrated in with this is a powerful animation system. Through the Animation panel you control the animation 
of your objects (i.e. rectangles) as well their fundamental building blocks (i.e. their fill color, opacity, etc.) in a 
straightforward point and click fashion. 

Most importantly though, Mobile Designer includes support for components - powerful, self-encapsulated little 
applications unto themselves. You use components (buttons, navigation bars, etc.) to add interactivity to your 
Mobile Designer movies. You do not, however, need to write even a single line of SVG code to make it all work. A 
few clicks are you are ready to export your movie to SVG and view it on the display device of your choosing.
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Types of graphic content
When creating an interactive movie, you will likely use both static shapes such as text and rectangles as well as 
interactive elements such as buttons and navigation bars. For example, in the interactive movie shown below, the 
weather information is composed of text, an animation (the sun is animated, but it is difficult to see in this static 
doc!), and two buttons to navigate to various additional screens of content. 

The simple shapes (such as the text above) that you draw in Mobile Designer are called primitives. The tools for 
creating primitives are displayed in the upper third of the Toolbox. All of the rows of tools from text and lines to 
charts and legends, inclusive, are primitives.

The more powerful objects (such as the buttons and animation above) you create in Mobile Designer are called 
components. The tools for creating components are found just below the primitives in the Toolbox. There are four 
component drawing tools: buttons, animation clips, books and navigation bars.
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The table below lists all of the primitives and components (collectively called objects) that are supported.

There are numerous fundamental differences between primitives and components, not the least of which are how 
these two different types of objects are created and used.

Primitives are simple objects that you draw or import. Primitives cannot be 
decomposed into more basic objects; each is an atomic unit.

Components are more complex and powerful entities that have three 
significant differentiating properties:

• They are designed using primitives in a special editing mode called the 
Component Designer, but outside of the Component Designer they 
are treated as a single entity. See “Creating components and the component designer” on page 20 for more 
information on the Component Designer.

• They include a behavior that allows them to be interactive, animated or both.
• They each have their own timeline (i.e. they operate independently from other primitives and components in 

your movie). For example, you can have an animation clip start playing every time a button is pushed no matter 
what the rest of the movie is doing.

Primitives Components
Text Buttons
Paragraph Text Menu Buttons (derived from buttons)
Text on Curve Animation Clips
3D Text Interactive Books
Lines Navigation Bars
Polylines
Rectangles
Rounded Rectangles
Circles
Bezier Curves
Freehand Curves
Paint Bucket Fills
Charts
Legends
Imported Raster Images
Imported 3D Models

Text, Shapes, charts and 
Bitmaps are Primitives

Home=Home +

Buttons can be built with text 
and shape primitives.



19Beatware Mobile Designer
User Guide
Movie elements
Your Mobile Designer movie (i.e. saved file with a “.md” extension) is composed of many parts, including scenes, 
primitives and components. Working together, these movie elements provide everything you need to create 
engaging, interactive content.

In order to help convey how all of these elements interact, a hierarchical chart followed by a brief description of each 
movie element or element type is provided below.

The chart is read from left to right. At the highest level is the movie. A movie contains scenes. Scenes can contain 
primitives, animations, buttons, menu buttons, nav bars and books. And so forth.

Scenes

A movie is composed of one or more scenes, only one of which is visible at any given time. A scene is roughly 
equivalent to a web page on the internet. It is within your scenes that you add primitives and components to create 
a unique and engaging user experience. 

Animation Clips

Animation clips are non-interactive graphics that play within a scene. Strictly speaking, animation clips are not 
required to be animated. Each animation clip has its own timeline, so it can be played independent of other 
elements in your Mobile Designer movie.

Animation clips are built using primitives.

Buttons

Buttons are interactive graphics that can be either animated or static. You can assign one or more actions to a button 
such as playing an animation clip or displaying a new web page. Each button has its own timeline, which is used 
when the button is animated.

Buttons are built using primitives.

Menu Buttons

Menu Buttons are buttons that display a special menu (a “popup menu”) that is only shown when the menu button 
is activated. Menu buttons provide an easy way to include numerous available options or actions without having 
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them take up valuable screen space at all times. Popup menus can have either a horizontal or vertical orientation. 
Each button within a popup menu responds its own set of actions.

Menu buttons and popup menus are built using button components.

Navigation Bars

Navigation bars, or “nav bars,” are a collection of buttons of a given type. They provide a quick and easy way to add 
a series of buttons to your movie, all of which have the same look and are spaced evenly. Nav bars can have either 
a horizontal or vertical orientation. Each button within a nav bar responds its own set of actions.

Nav bars are built using button components.

Interactive Books

Interactive books, or “books,” are like mini-scenes that you can embed right within your Mobile Designer movie. 
A book is composed of an always visible background and foreground, plus any number of “pages” of content 
sandwiched in between. When working with books, you display one page at a time (the others are hidden). You 
switch between pages using buttons. Books are a convenient way to change the content shown in a section of your 
scene without changing the entire scene.

Books are built using primitives, animation clips and buttons.

Primitives

As mentioned above, primitives are basic shapes that can be drawn directly onto scenes and form the basic building 
blocks for components.

Creating components and the component designer
Creating even a simple movie involves a number of different activities, including: 

• Drawing primitives
• Drawing components
• Formatting primitives and components
• Assigning actions to components

The first two activities, drawing primitives and drawing components, are virtually identical in Mobile Designer. 
Both involve object creation using primitives. For more information on creating primitives, see “Drawing 
Primitives” on page 37.

But how do you know whether the primitive you draw is part of a scene versus part of a component? It boils down 
to what you are doing at the time.



21Beatware Mobile Designer
User Guide
When you create a component, you draw the primitives that make up the component in a special mode called the 
Component Designer. You also use the component designer whenever you edit the primitives in a component. 
Throughout this documentation, when working with a particular component, the designer for that component is 
referred to by name. Thus, when working in the component designer for a button, the term “button designer” is 
used.

The component designer is used exclusively to draw and align those primitives that make up the component. 
Everything else you do in Mobile Designer (i.e. bullets 1, 3 and 4 above) is performed while working in the scene.

You can determine whether you are in a component designer or not with a quick glance at either the Locator bar 
or the Animation panel.

The Locator bar provides a simple indicator of what you are editing at any given time. At a minimum it lists the 
current scene. If you edit the primitives that make up a button within a scene (i.e. you are in the button designer), 
it will list both of these items. Likewise, if you are editing a button in a book in a scene, it will show all three items.

The Navigation menu in the upper left of the Animation panel is used for both navigation and provides a constant 
indicator of what you are working on.

When working in the component designer, the Navigation menu always displays the name of the component you 
are editing as well as the icon for that component (i.e. a button icon). Below this, the list of objects that make up 
the given component are shown.

When you are not working in the component designer, the Navigation menu displays the name of the current scene. 
Below this, the list of objects in your scene are shown - excluding those objects that make up the components 
themselves.

Navigation Menu

Objects in the
Component

Objects in
the Scene

Up One Level
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Opening the Component Designer

During the course of creating your movie, you will move into the component designer and back to the scene 
frequently. Three common ways to enter the component designer are:

• Creating a new component using one of the component tools in the Toolbox.
• Double-clicking on an existing component while in a scene.
• Right-clicking on an existing component and choosing Edit Component.

Exiting the Component Designer

To exit the component designer, click the Up One Level button adjacent to the Navigation menu (see above 
graphic).
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The Mobile Designer work area
At first glance, the Mobile Designer work area looks like that of other graphic applications. Upon closer 
examination though you notice many unique features. These are connected to the unique capabilities of Mobile 
Designer. 

The image below highlights the major functional areas of Mobile Designer. Each of these is described in the 
sections that follow.

Document Window

Toolbox

Inspector PanelsAnimation Panel

Tool bars

Menu bar
Locator bar



Chapter 2:24
The Toolbox
The Toolbox contains tools used to draw and manipulate objects on the canvas (for more information on the can-
vas, see “The Document window” on page 26).

Some tools, such as the text tools, are stacked one on top of another. To display a popup window where you can 
select the hidden tools, either press the Hidden Tool Selector triangle below the top tool in a stack or click and hold 
on a tool until the popup window appears.

Within the Toolbox, the tools are grouped by function.

Selection tools

The selection tools are used to select objects and areas. The selection tools include:

• The Arrow and Transformation tools are used to select, move, resize and rotate objects. When resizing an 
object, the transformation tool allows the free transformation of an object (i.e. it warps the shape of the object).

• The Rectangular Marquee, Elliptical Marquee, Lasso and Magic Wand tools are used to select a region on the 
canvas. Note that the marquee tools operate on raster images and regions, not directly on primitives and 
components.

Arrow

Text

Rectangle

Paint Bucket

Single Value Chart

Button

Book

Pan

Shape Outline Color

Shape Fill Color

Text Outline Color

Text Fill Color

Rectangular Marquee

Line

Bezier (Pen)

Eye Dropper

Legend

Animation Clip

Navigation Bar

Zoom

Swap Shape Colors

Save as Defaults

Swap Text Colors

Save as Defaults

Transformation

Line

Line

Magic Wand

3D Text

Ellipse

Multiple Series Chart

Lasso

Elliptical Marquee

Text on Curve

Paragraph Text

Rounded Rectangle

Single Series Chart
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Primitive tools

The primitive tools are used to draw primitives in scenes or components. The primitive tools are:

• The Text and Paragraph Text tools are used to enter single or multi-line 2D text. Text created with the text tool 
will adjust in size to resizing operations. Text created with the paragraph text tool will reformat in response to 
resizing operations.

• The Text on Curve tool is used to enter text on a previously drawn shape. Text on curve is always added to an 
existing shape.

• The 3D Text tool is used to enter 3D text.
• The Line and Polyline tools are used to draw lines. Each click on the canvas with the polyline tool adds a corner. 

Double-clicking or pressing Esc ends the shape.
• The Rectangle, Rounded Rectangle and Ellipse tools are used to draw those shapes. 
• The Pencil and Bezier (Pen) tools are used to draw free form curves. Mobile Designer automatically converts 

curves drawn by the pencil tool into Bezier curves. For a more in-depth discussion of drawing and editing 
curves, see “Curves” on page 40.

• The Paint Bucket tool is used to fill an area enclosed by objects or a selection marquee.
• The Eye Dropper is used to select colors from objects on the canvas. If no object is selected, the color goes into 

the designated color well. If an object is selected, the selected color is applied to the object. The eye dropper is 
used to select colors as follows:
• The Fill color is selected by default.
• The Stroke color is selected by holding down Shift.
• The 3D Text Side color is selected by holding down Ctrl-Shift.
• The 3D Text Face color is selected by holding down Ctrl.

• The Single Value, Single Series and Multiple Series Chart tools are used to add charts capable of display one 
value, a single series of values, or multiple series of values in chart form in an image. Each chart initially contains 
sample data which is replaced by real data either through the XML inspector tab. For more information on 
using charts, see “Charts and legends” on page 42.

• The Legend tool is used to add and associate a legend with a chart. For more information on using legends, see 
“Charts and legends” on page 42.

Component tools

The component tools are used to draw components. The components are described above in “Movie elements” on 
page 19.

Viewing tools

The viewing tools are used to change the view of the document window. The viewing tools include:

• The Pan (Hand) tool is used to reposition the canvas by dragging it around.
• The Zoom tool is used to change the magnification of the canvas.
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Color samples

The color samples are used to set the stroke (outline) colors for text and shapes. For more information on applying 
colors to objects, see “Applying Color” on page 68.

The Document window
The Document Window is where you create your movie by drawing and animating shapes and components. At any 
given time, the document window displays the contents of one scene in your movie.

The Canvas is that portion of the document window that is shown when you output your movie.

The Overscan Area is everything that falls outside of the canvas. Graphics you place in the overscan area will not 
appear in your final movie. However, you can use this area to “stage” graphics that you want to move into or out of 
your movie (such as during an animation). All of the gray area around the canvas comprises the overscan area.

You can view the document window using any of 10 different magnification levels. The Zoom Out button adjusts 
the magnification to the next lower level. The Zoom In button adjusts the magnification to the next higher level. 
The Zoom Menu allows you to select from any of the predefined magnification levels.

The Overscan Button toggles between showing and hiding the contents of the overscan area. The default setting 
for the overscan button is to show the objects in the overscan area.

For more information on drawing in the document window, see “Drawing Primitives” on page 37.

Canvas

Overscan Area

Overscan Area

Zoom In
Zoom Out Overscan button

Zoom Menu
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The Inspector panels
The right side of the application window contains the Inspector Panels. You use the inspector panels to control 
many different aspects of your movie.

When more than one inspector panel is shown, they are stacked one on top of the other (two are shown above). 
Each panel contains tabs you use to display a different set of attributes and options. When you click a tab, the panel 
name changes to match the name of the tab. 

You can change the tabs shown in a panel using the Panel Menu. The panel menu contains a list of available tabs. 
Checked items are displayed in the current panel. Regular text items are displayed in a different panel. Bold items 
are not currently displayed anywhere. If you select an item that is visible in the current panel, that tab is hidden, 
otherwise the tab is displayed in this panel.

Each inspector panel has a Splitter at the bottom. Drag the splitter up or down to change the size of the panel.

Panel Menu Icon

Splitter

Panel Menu
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Most tabs apply to more than one tool or object. The tabs are:

• 3D - For more information on using the 3D tab, see “3D Attributes” on page 87.
• 3D Text - For more information on using the 3D Text tab, see “The 3D Text tab” on page 86.
• Alignment - For more information on using the Alignment tab, see “Aligning objects with each other” on 

page 111.
• Catalog - For more information on using the Catalog tab, see “Drawing Components” on page 43.
• Chart - For more information on using the Chart tab, see “The Chart tab” on page 88.
• Chart Axis - For more information on using the Axis tab, see “The Axis tab” on page 100.
• Chart Curves - For more information on using the Curves tab, see “The Curves tab” on page 105.
• Chart Labels - For more information on using the Labels tab, see “The Labels tab” on page 103.
• Chart Walls - For more information on using the Walls tab, see “The Walls tab” on page 104.
• Component - For more information on using the Component tab, see “Components and XML” on page 107.
• Effects - For more information on using the Effects tab, see “The Effects tab” on page 80.
• Filters - For more information on using the Filters tab, see “The Filters tab” on page 80.
• Info - For more information on using the Info tab, see “The Info tab” on page 81.
• Object - For more information on using the Object tab, see “The Object tab” on page 77.
• Paragraph - For more information on using the Paragraph tab, see “The Paragraph tab” on page 85.
• Sharing - For more information on using the Sharing tab, see “Drawing Components” on page 43.
• Stroke - For more information on using the Stroke tab, see “The Stroke tab” on page 79.
• Text - For more information on using the Text tab, see “The Text tab” on page 82.
• Text Effects - For more information on using the Text Effects tab, see “The Text Effect tab” on page 85.
• XML Data Association - For more information on using the XML tab, see “Components and XML” on 

page 107.

The Animation panel
Animation is simply a change in an object over time. The Animation panel is the primary mechanism through 
which you control the way objects in your movie move about or change over time. In Mobile Designer, you can 
animate components, primitives in both components and scenes, and the attributes that make up primitives. For 
more information on the different objects and how you can animate them, see “Animating Objects” on page 120.
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The Animation panel itself has several different parts, each of which is described below.

Navigation menu

The Navigation menu and its associated arrow buttons are used to switch between the scenes and components in 
your movie. 

The Navigation menu always displays either the current scene name or the name of the component you are currently 
editing. If a component name is shown, then you are in the component designer for that component.

The left and right arrow buttons adjacent to the Navigation menu serve two different functions. If you are currently 
viewing a scene (working at the scene level), they allow you quickly switch to the Previous Scene or Next Scene in 
your movie. If you are currently editing a book (working in the book designer), they allow you to quickly switch to 
the Previous Page or Next Page of the book.

The Up One Level button moves you up one level in the current object hierarchy. For example, if you are in the 
button designer, clicking the Up One Level button will exit the button designer and move you to the scene that 
contains the button.

Playback controls

The Playback Controls are used to control how the current animation is played and displayed.They operate 
analogously to the controls on your VCR. 

Navigation Menu Playback Controls Frame Controls

Animation
Panel Buttons

Timeline

Object List Animation Grid

Navigation Menu

Previous
Scene or

Page

Next 
Scene or 
Page

Up One Level

Last FrameFirst Frame

Back a Frame

Play/Pause

Ahead a Frame

Stop
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The First Frame button rewinds the current animation back to the beginning. The Back a Frame button rewinds 
the animation a single frame. The Play/Pause button plays the animation from the current frame, or if already 
playing, pauses the animation. The Stop button stops a playing animation. The Ahead a Frame button advances the 
animation to the next frame. The Last Frame button advances the animation to its last frame.

Frame Controls

The frame controls provide information on the timing, current frame and total frames in the current animation.

The Frame Slider shows you where in the animation you are relative to its total length. The text fields adjacent to 
this provide the Current Frame number where the playback head is located, and the Time Index where that frame 
starts. You can edit the values in either of these fields or drag the frame slider to change the frame that is currently 
displayed.

The Frame Rate text indicates the frame rate in Frames per Second (fps) used in your movie. For more information 
on changing the frame rate, see “The Movie Properties dialog” on page 135. 

The Total field shows the total number of frames in this animation. To change the total frames, type a new number 
into this field and press Enter.

Animation panel buttons

The Animation panel buttons provide you with convenient access to several panel functions and features.

The Show Animated button toggles between showing all properties and showing only animated properties for 
those objects whose properties are displayed. The Expand All button shows all of the properties for every object 
currently listed in the Animation panel (filtered by the Show Animated button). The Collapse All button hides all 
of the properties for all of the objects listed in the Animation panel.

The Magnify button toggles between showing a normal view and a condensed view of the frames in the timeline 
and animation grid.

The Animation Wizard button launches the Animation Wizard. The Animation Wizard is used to make macro 
level changes to the current animation. For more information on the Animation Wizard see “Using the Animation 
Wizard” on page 124.

Frame Slider

Current Frame Time Index

Frame Rate Hide Animation Panel

Show Animated Delete Key

Expand All

Collapse All

Add Key

Animation Wizard

Magnify Frames
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The Add Key button allows you to add keys to any property shown in the animation grid. For more information 
on using the Add Key button, see “Adding keys to an object” on page 126.

The Delete Key button removes the currently selected key or keys from the animation grid. Attempting to delete 
the last key from a property will fail since every property must contain at least one key.

Timeline

The Timeline shows the currently selected frame in the animation.

You can change the current frame by clicking on one of the frame numbers. When you do this, the Frame Controls 
adjust to display the specifics for the new frame.

Object list

The Object List displays all of the objects in the current animation.

The first column in the Object List displays the edit status of each object. If a lock is present, the object cannot be 
edited. If no lock is shown, the object is editable. By default, all objects are editable.

The second column in the Object List displays the visibility of each object. If the “slash eye” icon is present the 
object is invisible. If no icon is shown, the object is visible. By default, all objects are visible.

The small triangle adjacent to the visibility icon is the properties toggle. This allows you to display and hide the 
animatable properties of the object. The properties displayed are filtered by the Show Animated button (described 
above).

Animated properties display the Tweening Wizard button. Clicking the Tweening Wizard button or the adjacent 
property opens the Tweening Wizard for creating non-linear animations. For more information on the Tweening 
Wizard, see “The Tweening Wizard” on page 128.

Current Frame Indicator

Lock Object

Show Properties

Object Visibility

Tweening Wizard
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Animation grid

The Animation Grid displays the keys recorded for each object at every frame. 

Both objects and properties can have keys. Keys in the row of an object name indicate that at least one property key 
is set in that frame. Keys in the row of an object property indicate that the property itself was changed in that frame.

When an object has two or more keys, the first and last animated frame for the object have an adjacent animation 
range handle. These range handles can be dragged to proportionally resize the object’s animation. 

When a property has two or more keys, a line joins the keys. This line shows where the property is automatically 
interpolated or “tweened.” Mobile Designer only records keys (thereby creating key frames) when a property in an 
object changes.

You can select and drag keys from one frame to another. This changes the number of frames over which the 
animation takes place. If you drag an object level key (i.e. a key displayed in the same row as an object name), all of 
the properties for that object in that column are moved. If you drag a property key, only that key is impacted.

An entire chapter of this user guide is devoted to methods of animating objects and properties. For more 
information on animating and using the Animation panel see, “The Animation panel” on page 119.

The Locator bar
The Locator bar provides an “at a glance” view of which scene or component you are currently editing. The locator 
bar always lists the current scene first followed by any component designers you have open. 

In the first image above, only a scene is shown. This indicates that work is being done at the scene level and no 
component designers are open.

In the middle image above, a scene followed by a button is shown. This indicates that the current scene is Scene 1, 
and within Scene 1, Button 1 is being edited (the animation clip designer is open).

Animation Range Handle Animation Range Handle
Tweened Frames
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In the last image above, a scene, book, page and button are all shown. This indicates that the current scene is Scene 
1, the designer for Book 1 is open with Page 2 active, and on that page Button 1 is being edited (the button designer 
is open).

The Toolbars
The toolbar is actually a collection of multiple adjacent small toolbars, each of which contains buttons that act as 
shortcuts to many Mobile Designer functions. A brief description of each toolbar is provided below.

Standard toolbar

The Standard Toolbar contains shortcuts to many common Windows activities including saving, copying, and 
pasting.

Profile toolbar

The Profile Toolbar contains a drop down menu used to select which target output format you are designing for, if 
any. 

Designing for a particular target output format restricts you to the subset of features relevant to that output format. 
You can change profiles at any time. However, doing so may change the look and behavior of your movie. The 
profile choices are:

• Normal (default). Select this profile if you want all of the features in Mobile Designer available to use.
• SVG Basic. Select this profile if you want to restrict the Mobile Designer feature set to only those features 

supported by SVG Basic.
• SVG Tiny 1.1. Select this profile if you want to restrict the Mobile Designer feature set to only those features 

supported by SVG Tiny 1.1.
• SVG Tiny 1.2. Select this profile if you want to restrict the Mobile Designer feature set to only those features 

supported by SVG Tiny 1.2.
• Custom Profile. Select a custom profile if you want to define the feature set that Mobile Designer makes 

available.

For more information on defining and using profiles, see “Working with Profiles” on page 58.
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Format toolbar

The Format Toolbar contains menus for selecting the file format and viewer to use when previewing your movie 
as well as shortcut buttons for exporting your movie.

The Format menu is used to select the output file format used when previewing your movie or using the adjacent 
Export Movie button. The contents of this menu are identical to those you have when you choose File > Export 
from the main menu. For more information on the preview/export formats, see “File formats” on page 218.

The Viewer menu is used to select the preferred viewer when previewing your movie in the specified format. The 
Preview Movie button builds a preview of your movie and displays it in the specified viewer. You can also specify 
any preferred preview settings by clicking on the Preview Settings button.

Inspector toolbar

The Inspector Toolbar contains shortcuts for inspector specific actions.

Click the Show/Hide Inspectors button to either show or hide the inspector panel. This is the same as pressing F5. 
When the Inspector panel is hidden, the document window and Animation panel are extended to occupy this space. 

Click the Add Inspector button to add another inspector to the panel. You can have multiple inspectors with 
multiple tabs within each inspector, allowing you to organize your inspector tabs to best suit your work habits.

The Menu bar
The Menu bar provides access to the numerous commands available in Mobile Designer. 

The File and Edit menus as well as the View, Window and Help menus all contain commands common in most 
Windows applications. The Movie, Scene, Object, Selection and Animation menus are Mobile Designer 
specific. The menu items are described throughout this manual as they are used.

Export Movie Preview Movie

Preview Settings
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Drawing primitives and components (collectively 
called objects) and subsequently manipulating them is 
a core capability of Mobile Designer. Unlike with some 
applications, with Mobile Designer you have complete 
control of how your objects look and behave at all 
times.

This chapter describes both how to initially draw 
primitives and create components as well as how to edit 
them later.

Selecting Tools
The Toolbox contains the complete set of tools 
available in Mobile Designer. This includes various 
selection tools, text tools, shape tools, charting tools 
and component creation tools. In addition, the Toolbox 
contains separate color samples for setting the stroke 
(outline) and fill of both shapes and text. These are 
described in “Understanding Color” on page 67.

In order to make wise use of space, related tools are 
often stacked one on top of another in the Toolbox, 
with only the most recently used tool shown. When 
multiple related tools are stacked on top of each other, 

a small triangle is used to indicate that additional, 
hidden tools are available.

To select the currently visible tool:

Click on the tool in the Toolbox.

To select a hidden tool:

1. Do one of the following:

• Click and hold on a related tool until the Hidden 
Tools popup window appears.

• Click on the Hidden Tools indicator icon below the 
currently visible tool.

2. Click on a tool in the Hidden Tools popup window.

Drawing Primitives
Mobile Designer is a typical graphics application when 
it comes to drawing using the built-in tools. Insofar as 
primitives go, a click and drag on the canvas will more 
than likely produce the results you would expect (a 
shape drawn on the canvas). Primitives are described 

Hidden Tools Indicator
Chapter 3: Working with Objects
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below, and components are described in the next 
section.

Text
When using text, you can either set the text attributes 
(i.e. font, etc.) before drawing or any time thereafter. 
For more information on setting the various text 
attributes, see “Text attributes” on page 82.

Four different types of text tools are available:

• Regular text is composed of one or more lines of 
text with a new line started each time the Enter key 
is pressed. There are no predetermined margins 
when using regular text.

• Paragraph text is composed of one or more lines of 
text that is typed within a specified bounding box. 
Paragraph text automatically wraps when it reaches 
the edge of the bounding box or when the Enter 
key is pressed.

• Text on a curve is composed of a single line of text 
that is drawn on and follows the contours of any 
primitive shape on your canvas. Text on a curve will 
wrap around a closed shape such as an ellipse and 
extend in a straight line past the end of an open 
shape such as a Bezier curve that is not closed.

• 3D text is composed of a single line of text drawn in 
a straight line that has both a face and depth. 3D 
text can be rotated and animated in all three 

dimensions using either the mouse or the 3D tab. 
See “3D Attributes” on page 87 for more 
information on using the 3D tab.

To draw text:

1. Do one of the following:

• For regular text, click on the canvas and start 
typing. An I-beam is displayed showing where the 
next character will appear.

• For paragraph text, click and drag a rectangle of the 
desired width for your paragraph text on the 
canvas, then type your text.

• For text on a curve, click on an existing shape and 
start typing. An I-beam is displayed showing where 
the next character will appear.

• For 3D text, click on the canvas and start typing. A 
small X/Y axis is displayed showing where the 3D 
text object starts.

2. To finish a text object, do one of the following:

• Click on the Arrow tool. Your text is automatically 
selected as indicated by a red bounding box.
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• Press the ESC key. Your text object is shown with 
a thin blue box. This indicates that the text tool 
remains selected so that you can click and enter 
additional text objects without reselecting the text 
tool.

• Click on another tool. 

To edit an existing text object:

1. Select the text object.

2. Do one of the following to enter text edit mode:

• Double-click on it to display an I-beam at the spot 
where you double-click.

• Press the Enter key. With the exception of 3D text, 
this highlights the text for editing. For 3D text, this 
places the insertion point at the end of the text.

For a complete description of the different ways you 
can change the look of your text, see “3D Attributes” 
on page 87.

To rotate 3D text using the mouse:

1. Select the 3D text object.

2. Enter edit mode by doing one of the following:

• Press Enter.

• Double-click on the object.

3. Rotate the object by doing one of the following:

• For free rotation, click and drag the mouse pointer. 

• To constrain movement along the x-axis, hold 
down the Alt key and click and drag the mouse.

• To constrain movement along the y-axis, hold 
down the Ctrl key and click and drag the mouse.

• To constrain movement along the z-axis, hold 
down the Shift key and click and drag the mouse.

Note: You can also rotate 3D text using the 3D tab. See “3D 
Attributes” on page 87 for more information.

Shapes
Mobile Designer includes four predefined geometric 
shape tools (line, rectangle, rounded rectangle and 
ellipse) as well as one more complex geometric shape 
tool (polyline). Using these, you can create a 
tremendous variety of vector content in very little time.

To draw using one of the basic shape tools:

1. Click on a tool in the Toolbox.

2. Click and drag on the canvas. A blue outline of the 
shape you are drawing is shown as long as the 
mouse button is pressed.

3. Release the mouse button to finish the shape. Once 
you release the button, the fill for the shape is 
applied, if any.

To draw using the polyline tool:

1. Click on the polyline tool in the Toolbox.

2. Click on the canvas to create the first point in the 
polyline.

3. Click again on the canvas for each addition point 
you wish to add. Each point is connected to the 
previous point with a straight line.

4. To finish the polyline, do one of the following:

• Press ESC.

• Press Enter.

• Double-click on the canvas.
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∗When drawing a polyline, the mouse pointer 
changes from a “+” shape to a closed shape 
pointer (like a hollow compass) whenever adding 
a point at that location will result in a closed 
shape.

To edit an existing polyline object:

1. Select the polyline object.

2. Do one of the following to enter polyline edit mode 
and display the points in the polyline:

• Double-click on it.

• Press the Enter key. 

3. Click and drag any of the points to reposition them.

4. Do one of the following to exit polyline edit mode:

• Press ESC.

• Press Enter.

• Click away from the object on the canvas.

Curves
The pencil and Bezier (pen) tools provide two different 
ways to draw Bezier curves, mathematically based lines or 

shapes that can include straight lines, smooth curves, and 
sharp corners. 

While the curve that results from drawing using these 
tools is the same (a Bezier curve), the pencil tool offers 
a relatively natural though somewhat imprecise 
approach to drawing, whereas the Bezier tool provides 
greater initial precision when drawing a given shape.

Regular text can also be converted into Bezier curves 
and manipulated as if drawn using the pencil or Bezier 
tools. The method of converting text to Beziers is also 
described below.

About Bezier curves

Like polylines, Beziers can be both selected (as 
indicated by the standard red bounding box) and 
edited. When in Bezier edit mode, you see not only the 
points that define the curve, but also the direction lines 
and direction points used to change the angle and 
length of the curve segments.

Each point within a curve has two direction lines. By 
default, the direction lines have the following 
attributes:

• The direction lines are of equal length initially.

• Each direction line can be sized independently.

• The size of the direction lines determine the scale 
of the curve around that point.

Closed Shape Pointer

PointsDirection Lines
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• Each pair of direction lines forms a straight line 
going through the point.

• Rotating one direction line automatically rotates 
the other direction line maintaining a smooth curve 
at the point.

• Direction lines at a sharp point are stacked on top 
of another (i.e. you don’t see a direction line passing 
through the point).

End points on an open curve only have one direction 
line (effectively there is only one side to the curve at 
that point).

By pressing the Alt key and clicking on one of the 
direction points, you uncouple the direction lines. This 
allows you to move one line without changing the 
other. Thus you can create two smooth curves that 
change direction at the point where the meet.

To restore the direction lines to their original straight 
configuration, press the Alt key and click on one of the 
direction points.

To draw using the Bezier tool:

1. Start your curve by doing one of the following:

• Click and release on the canvas to create an anchor 
point for your object without a direction line (i.e. it 
will be stacked on the point)

• Click and drag on the canvas to create an anchor 
point with a single-sided direction line at that 
point. Release the mouse button when the 
direction line is of the desired length

2. Move the mouse pointer to a new position and do 
one of the following:

• Click and release to create a corner point (i.e. one 
with stacked direction points).

• Click and drag to create a smooth curve around 
that point (i.e one with defined direction lines). 
The father you drag, the bigger the curve at that 
point.

3. Repeat step 2 to add additional points to your 
curve.

4. Finish the curve by doing one of the following:

• Press ESC to finalize the curve at the last position 
you clicked.

• Double-click on the canvas to create one last point 
and finish the curve there.

As with polylines, the mouse pointer changes from a 
“+” shape to a hollow compass whenever adding a point 
at that location will result in a closed curve.

To draw using the pencil tool:

Click and drag on the canvas just as if you were writing 
using a pencil. When you release the mouse button, the 
curve is finished and it is automatically converted into 
a Bezier for you.

To convert text into Beziers:

1. Select the regular text on the canvas.
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2. From the main menu, choose Object > Convert 
Text to Bezier.

To edit an existing curve:

1. Select the curve.

2. Do one of the following to display the points:

• Press Enter.

• Double-click on the selected object.

3. Position the mouse pointer over a point you want to 
adjust. The mouse pointer changes to a “+” when 
you are over a point.

4. Do one of the following:

• To move the point, drag it.

• To reshape the curve at the point without 
uncoupling the direction lines, drag the direction 
points. Both the length and angle of the direction 
lines can be adjusted.

• To reshape one side of the curve at the point 
without changing the other side, press Alt and click 
on one of the direction points. Each direction point 
now moves independently.

• To change a corner point to a smooth point, click 
on the point once, then click again and drag each 
stacked direction point away from the point.

• To delete a point, click on it and press the Delete 
key.

5. To finish editing the curve, do one of the following:

• Press ESC.

• Click on the canvas away from the object.

Charts and legends
Charts and legends are unique in Mobile Designer 
because they are the only objects that do not display 

their true look until preview/export time. This is 
because these objects rely on external XML data files as 
their data source. For more information using charts 
with external data files, see “Associating XML data 
with charts” on page 198.

There are three fundamentally different types of charts 
available in Mobile Designer:

• Single value charts. These charts display a single 
value at a time. An example of a single value chart 
is a thermometer.

• Single series charts. These charts display a single 
set of related data. An example of a single series 
chart is a pie chart.

• Multiple series charts. These charts display 
multiple series’ of related data. An example of a 
multiple series chart is a 3D bar chart.

No matter what type of chart is used, you always have 
the option of associating a legend with a chart. The 

Single 
Value 
Chart

Single 
Series 
Chart

Multiple 
Series 
Chart
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legend provides the end user with additional 
information about what is shown in a chart.

To draw a chart:

1. Click on one of the chart tools.

2. Do one of the following:

• Click and release on the canvas to draw a default 
sized chart.

• Click and drag on the canvas to custom sized chart. 
A blue outline appears showing you the size of the 
chart as you drag. Release the mouse button to 
finish the chart. 

To draw a legend:

1. Click on the legend tool.

2. Do one of the following:

• Click and release on the canvas to draw a default 
sized legend.

• Click and drag on the canvas to custom sized 
legend. 

The ultimate size of the legend is dependent on the 
number of items in the legend and their size. You are 
simply specifying the size of the legend bounding box 
when you draw a legend.

About charts and legends

Charts and legends are possibly the most customizable 
and powerful primitives in Mobile Designer. There are 

six inspector tabs dedicated to charts, with others such 
as the Text tab also effecting how chart and legend data 
is displayed.

• The Chart tab is used to specify the type of chart 
displayed as well as general characteristics that 
apply to that type of chart. It is also in a similar 
capacity for legends.

• The Axis tab is used to specify the attributes of any 
axes associated with the selected chart including 
axis color and value range information.

• The Labels tab is used specify information 
associated with the axis labels such as prepending a 
“$” to labels representing dollar values.

• The Walls tab is used to specify add color or texture 
to the planes formed by the intersection of the axes 
(i.e. graph background colors or patterns).

• The Curves tab is used to specify the look of the 
various curves plotted on the chart including curve 
colors and markers.

• The XML tab controls how an external XML file 
maps its data to data in a chart as well as other 
Mobile Designer objects. The XML tab is also 
used for data replication. For more information on 
using the XML tab, see “Associating XML data 
with objects” on page 177.

A comprehensive description of how to work with the 
various chart tabs is provided in “Chart and Legend 
attributes” on page 88.

Drawing Components
Components are a mainstay of any interactive design. 
Using components you can respond to user activities 
(i.e. device key presses or mouse clicks), hide and show 
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portions of your movie, and even call external 
JavaScript routines.

There are five different component types in Mobile 
Designer:

• Buttons are interactive components that can 
respond to user activities. Buttons are built using 
primitives.

• Menu Buttons are buttons that display a popup 
menu when activated. Any button can be 
designated as a menu button after it has been 
created. Menu buttons are built using buttons.

• Animation clips are non-interactive components. 
Animation clips are built using primitives.

• Navigation bars are evenly spaced sets of buttons. 
Navigation bars are built using buttons.

• Books provide a means of changing the content 
shown on a portion of the canvas (the “page”) 
without impacting what else is displayed. Books are 
built using primitives, buttons, menu buttons and 
animation clips.

Components are visually differentiated from primitives 
by the color of their bounding box. Components have 
a green bounding box while primitives have a red 
bounding box.

Components also have a dedicated drawing mode 
where you design the look of your component. This 
dedicated drawing mode is called the “component 
designer.” When you are in the component designer, 
you can only draw and edit those objects that are part of 
the component, not primitives drawn on the scene or in 
other components.

Books are a special case. Each page in a book can 
contain primitives, buttons and animation clips. 
Primitives are drawn directly on a book page Buttons 

and animation clips are drawn in a component designer 
accessible from the book page (vs. the scene)

∗ If you are ever confused as to whether you are 
in a scene or in a component designer, look at the 
Locator bar or the Navigation menu. If you are in 
a component designer, these will show the 
component name. Otherwise, they will show the 
scene name.

You can create components using one of four different 
methods: 

• From scratch.

• From the Catalog, a library of provided 
components.

• From Sharing, a list of components already in your 
movie.

• From existing primitives. 

With the exception of the last method, clicking the 
hidden component indicator beneath each component 
tool opens a dialog where you determine which method 
to use when creating your component. Each 
component tool remembers the last method selected; 
the default is to create from scratch.

To create a component from scratch:

Note: if the last component you created of this type was from 
scratch, the first two steps may be skipped.

1. Click on the Hidden Component indicator 
beneath the component you wish to create.

2. Select the Design a New Component radio button 
and click OK.

3. Click and release on the canvas to create your new 
component.
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When you create a component from scratch, you are 
automatically placed in the component designer for 
that component, allowing you to draw the primitives 
that make up the component immediately.

When you have finished drawing the elements that 
make up your component, press the Up One Level 
button in the Navigation toolbar.

To create a component from the Catalog:

Note: if you plan to create multiple copies of the same Catalog 
component, create one from the Catalog and the rest from Shar-
ing - it is more memory efficient.

1. Click on the hidden component indicator beneath 
the component you wish to create.

2. Select the Create a Component from the Catalog 
radio button.

3. Select the component you wish to create from the 
list of available components and click OK.

4. Do one of the following:

• Click and release on the canvas to create the 
selected component at its default size.

• Click and drag a rectangle on the canvas to create 
the component at the size you specify.

Alternatively, you can do the following:

1. Click on the Catalog tab.

2. Click and drag the component you wish to create 
from the Catalog tab onto the canvas.

When you create a component from the Catalog, a 
duplicate of the Catalog item is added to your movie. 
Subsequent changes you make to this duplicate have no 
impact on the original item in the Catalog.

When you create a component from the Catalog, you 
are not placed in the component designer for that 
object as you are when you create from scratch.

To create a component from Sharing:

1. Click on the hidden component indicator beneath 
the component you wish to create.

2. Select the Create a Component from the Sharing 
radio button.

3. Select the component you wish to create from the 
list of available components and click OK.

4. Do one of the following:

• Click and release on the canvas to create the 
selected component at its default size.

• Click and drag a rectangle on the canvas to create 
the component at the size you specify.

Alternatively, you can do the following:
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1. Click on the Sharing tab.

2. Click and drag the component you wish to create 
from the Sharing tab onto the canvas.

When you create a component from Sharing, a symbol 
of the Sharing item is added to your movie. Symbols 
are more memory efficient at export time than 
components created from scratch or the Catalog 
because whenever possible the definition of the 
component is reused.

Note: in SVG Tiny, buttons do not offer any memory advan-
tages when created from Sharing whereas animations do. 
However, in SVG Basic and full SVG, style sheets, which are 
not supported by SVG Tiny, are used to hold button defini-
tions. Thus, buttons created from Sharing in SVG Basic and 
full SVG do offer memory savings.

When you create a component from Sharing, you are 
not placed in the component designer for that object as 
you are when you create from scratch.

Converting primitives into components

Many designers and artists prefer to sketch out the look 
of a movie without worrying about whether a particular 
item or group of items is destined to become a button 

or animation clip. Others add primitives that they later 
decide should be put into one of these components. 

Mobile Designer includes a conversion feature that 
turns primitives into buttons or animation clips with a 
single mouse click. This affords you greater flexibility 
in how you go about designing your movies.

To create a component from existing primitives:

1. Select one or more primitives on the canvas (hold 
down Shift to select multiple items).

2. Do one of the following:

• In the main menu choose Object > Convert to > 
Button or Animation.

• Right-click on one of the primitives and in the 
popup menu choose Object > Convert to > Button 
or Animation.

Editing existing components

The objects that make up a component can be edited at 
any time in Mobile Designer. It doesn’t matter whether 
you created the component from scratch or through 
one of the other methods available.

To edit an existing component:

1. Do one of the following to open the component 
designer for a particular component:

• Double-click on the component.

• Right-click on the component and choose Edit 
Component from the popup menu.

• Right-click on the component in the Animation 
panel and choose Edit Component from the popup 
menu.

2. Make the desired changes to the objects that make 
up the component.
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3. Click the Up One Level button in the Navigation 
toolbar to exit the component designer when you 
are finished.

Instances created from Sharing are the only component 
type that require any special treatment. When you edit 
an instance, you must decide whether to edit only that 
particular instance or all instances of that component in 
your movie. 

If you only change the selected instance, you lose the 
memory advantages inherent in sharing. The 
component becomes a new item in the Sharing list as if 
you created it from scratch or the Catalog.

If you elect to change all of the related instances in the 
movie, any changes you make to that instance are 
reflected in every other instance in the move and the 
memory advantages of sharing still apply.

Common object 
manipulations
In addition to drawing primitives and components, 
there are many other manipulations that you can 
perform (and in most cases, animate) on existing 
objects. These are detailed in the sections that follow.

Selecting
Objects must be selected before they can be 
manipulated. 

To select one or more objects, do one of the following:

• Click on them on the canvas. Hold down the Shift 
key while clicking to select multiple objects.

• Click on the object name in the Animation panel 
(applies to single objects only).

• Use one of the arrow tools to drag a selection box 
completely around those objects you want to select.

Moving
Objects can be moved and movement can be animated 
(“translation”) with pixel level precision. For 
information on animating movement, see “Animating 
between points” on page 120.

To move one or more objects:

1. Select the objects you want to move.

2. Do one of the following:

• Click on one of objects and drag it with the mouse.

• Press the arrow keys on your keyboard. Each time a 
key is pressed the object is moved one pixel. Hold 
down the Shift key in combination with the arrow 
keys to increase the distance moved to 8 pixels per 
key press.

• Change the X or Y coordinate in the Object tab 
(applies to single objects only). See “The Object 
tab” on page 77 for more information on the 
Object tab.

• Use one of the alignment options described in 
“Aligning objects with each other” on page 111.

Resizing
Objects can be resized and resizing can be animated 
(“scaling”) with pixel level precision. 

To resize an object:

1. Select an object.

2. Do one of the following:



Chapter 3:48
• Click and drag any of the resizing handles on the 
bounding box for the object. Corner resizing 
handles provide for scaling both adjoining edges 
simultaneously; Edge resizing handles provide for 
scaling along the selected edge. Holding down the 
Shift key while resizing maintains the proportions 
of the object.

• Hold down the Ctrl key and:

• Press the up arrow key to decrease the object 
height by 1 pixel.

• Press the down arrow key to increase the object 
height by 1 pixel.

• Press the left arrow key to decrease the object 
width by 1 pixel.

• Press the right arrow key to increase the object 
width by 1 pixel.

• Hold down the Shift key in combination with the 
above to multiply the scaling by a factor of 8.

• Change the W(idth) and H(eight) values in the 
Object tab. See “The Object tab” on page 77 for 
more information on the Object tab.

• Press the “\” key to symmetrically reduce the object 
size by 20%. Hold down the Shift key in 
combination with the “\” key to increase the object 
size by 20%

Rotating
Objects can be rotated and rotation can be animated 
with sub-degree level precision. In addition, all objects 
have a rotation center, the point around which each 
object will be rotated. By default, the rotation center is 
in the center of the bounding box, but this can be 
moved anywhere on the canvas. For example, by 
moving the rotation center of a circle outside its 
bounding box, the circle can then be animated to 
appear to orbit around this point.

To rotate an object:

1. Select an object.

2. Do one of the following:

• Click on the object’s bounding box anywhere 
between the resizing handles and drag.

• Change the Rotation value in the Object tab. See 
“The Object tab” on page 77 for more information.

To change an object’s rotation center:

1. Select an object.

2. Click on the rotation center for the object and drag.

Hiding and Showing
Objects can be hidden and visibility can be animated. 

To hide a visible object or show a hidden object:

1. Select an object.

2. Do one of the following to toggle the object’s 
visibility.:

• Click on the Visibility icon in the Animation panel.

• Right-click on the object name in the Animation 
panel and choose Visibility in the popup menu.
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Renaming
Each object in Mobile Designer must have a unique 
name. Each object you create is given a unique name 
which appears in the Animation panel. You can change 
the name of any object while you are editing your 
movie. Object names however are not exposed to the 
view in the SVG output file.

To change the name of an object:

Do one of the following:

• Right-click on the object name in the Animation 
panel and choose Rename in the popup menu.

• Ctrl-click on the object name in the animation 
panel.

You type the new object name directly into the 
Animation panel.

Deleting
Deleting an object removes it from your movie 
everywhere it appears. Deleting is an edit time only 
feature; it cannot be animated (deleted objects do not 
appear in the SVG export file). 

To delete one or more objects:

1. Select the objects.

2. Do one of the following:

• Press the Delete key.

• Right-click on the objects on the canvas and choose 
Delete from the popup menu.

• Right-click on an object in the Animation panel 
and choose Delete from the popup menu (applies 
to single objects only).

Grouping and Ungrouping
Two or more primitives can be grouped together at edit 
time. This can make working with them easier since 
grouped objects are treated as a single element for most 
manipulations.

To group one or more objects:

1. Select the objects.

2. Do one of the following:

• In the main menu, choose Object > Group.

• Right-click on the objects and choose Group in the 
popup menu.

To ungroup previously objects:

1. Select the grouped objects.

2. Do one of the following:

• In the main menu, choose Object > Ungroup.

• Right-click on the grouped objects and choose 
Ungroup in the popup menu.

When you ungroup objects, you must decide between 
restoring the objects to the state they were in before 
being grouped, or to apply any transformations/
animations you have made to the group to each object 
in the group. 

Ordering
Objects in Mobile Designer can be stacked one on top 
of another. When objects overlap, the top object 
obscures those objects below it (or partially obscures 
underlying objects if partially transparent). Primitives 
can be stacked on top of components and vice versa.

To change the stacking order of one or more objects:

1. Select the objects.
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2. Do one of the following:

• From the main menu, choose Object > Arrange 
and one of the following submenu items:

• Bring to Front to bring the object(s) to the top of 
the stacking order.

• Bring Forward to bring the object(s) up one spot 
in the stacking order.

• Send Backward to send the object(s) down one 
spot in the stacking order.

• Send to Back to send the object(s) to the bottom 
of the stacking order.

• Click on the object name in the Animation panel 
and drag it up or down in the list to move it up or 
down in the stacking order, respectively.

Locking and unlocking
Individual objects can be locked at edit time to prevent 
you from inadvertently selecting, editing or deleting 
them. Later these same objects can be unlocked 
allowing you to edit them.

To lock or unlock an object:

1. Select the object.

2. Do one of the following to toggle its locked state:

• In the main menu, choose Object > Lock.

• In the Animation panel, click the lock icon 
adjacent to the object name.

• In the Animation panel, right-click on the object 
name and choose Lock in the popup menu.

Setting opacity
The opacity of every object or group of objects can be 
set and can be animated on an individual basis. 
Furthermore, any opacity you set for the stroke or fill of 
an object will multiply by the opacity of the object itself 
to produce the final opacity for the object. See 
“Understanding Color” on page 67 for more 
information on setting the stroke and fill of objects.

You can create objects that range from completely 
opaque to completely transparent.

To set the opacity of an object:

1. Select the object.

2. In the Object tab, change the opacity value by 
typing in a new value or adjusting the slider.

Masking
Masks allow you to use one primitive as a sort of stencil 
for another primitive. The classic example of a mask is 
to use text as a mask on a digital photograph to create 
the familiar postcard effect of a picture of a city peeing 
through its own name.

When working with masks, the opacity of the masked 
object is applied to the mask underneath. In other 
words, if the masked object is partially transparent, the 
mask will appear to be partially transparent as well. 
Masks can be animated.

To create a mask:

1. Select the primitive you want to use as the masked 
object (the text in the example above).

2. Do one of the following to open the Mask Object 
dialog:

• In the main menu, choose Object > Mask.
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• Right-click on the primitive on the canvas and 
choose Mask Object.

3. In the Mask Object dialog, select the primitive to 
be used as the mask (the digital photo in the 
example above) and click OK.

The two objects are united into one. By default, the 
masked object is listed in the Animation panel with the 
adjacent icon changed to indicate that it is a mask. The 
mask is no longer listed.

The mask is not gone or even inaccessible, however. 
Using the menus, you can switch back and forth 
between the masked object and the mask, editing 
whichever one is currently shown (you may need to 
unlock the mask before editing). The icon adjacent to 
the mask, when it is shown, is that of a normal 
primitive.

To switch between showing a mask and a masked 
object:

If the mask is currently shown, do one of the following:

• In the main menu, choose Object > Modify 
Masked Object.

• Right-click on the masked object and choose 
Modify Masked Object in the popup menu.

If the masked object is currently shown, do one of the 
following:

• In the main menu, choose Object > Modify Mask.

• Right-click on the masked object and choose 
Modify Mask in the popup menu.

To remove a mask:

1. Select the masked object.

2. Do one of the following:

• In the main menu, choose Object > Remove Mask.

• Right-click on the masked object and in the popup 
menu choose Remove Mask.

The mask and the masked object disassociate from 
each other and become two separate objects again.
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Chapter 4: Working with Profiles
Mobile Designer provides a comprehensive set of 
tools, features and capabilities that make it perfect for 
designing content for a wide variety of applications. 
However, many existing file standards such as SVG 
and its variants support fewer features than Mobile 
Designer. Thus, unless you are very familiar with a 
particular target output format, you run the risk of 
using features available in Mobile Designer, but not 
available on your target platform.

About Profiles
In order to make it easier for you to create content for 
a particular output file format, Mobile Designer 
includes the ability to disable certain features within 
the product so that you do not accidentally use them in 
your designs. This is done using Profiles.

Mobile Designer includes several predefined profiles 
that, when selected, allow you to work with confidence 
knowing that your design will operate the same in both 
Mobile Designer and your target device. Mobile 
Designer also gives you the option of creating your own 
profiles, which can be derived from any of the 
predefined profiles or created from scratch.

Available Profiles
Mobile Designer provides four standard profiles 
targeted towards slightly different output formats. 
These are:

• Normal (default) supports all of the Mobile 
Designer features. It is the appropriate profile to 
use when you do not want any restrictions on the 
features available in Mobile Designer (i.e. when 
designing for any of the bitmap formats such as 
animated GIF).

• SVG Basic provides access to only those features 
that are part of the SVG Basic protocol as defined 
by the World Wide Web Consortium (W3C). It is 
intended for more powerful mobile devices such as 
pads.

• SVG Tiny 1.1 provides access to only those features 
that are part of the SVG Tiny 1.1 specification as 
defined by the W3C. It is intended for less 
powerful mobile devices such as cell phones.

• SVG Tiny 1.2 provides access to only those 
features that are part of the SVG Tiny 1.2 
specification as defined by the W3C. It is intended 
for more powerful cell phones.



Chapter 4:56
Profiles compared
The following table provides a side by side comparison 
of the features supported in each profile.

Feature Normal
SVG
Basic

SVG 
Tiny 1.1

SVG 
Tiny 1.2

Gradient Fill (Vector)
Shapes
Text

X
X

X
X

X
X

Pattern Fill (Vector)
Shapes
Text

X
X

X
X

Stroke Lines
Button Caps
Round Caps
Square Caps
Arrow Caps
Other Caps
Different End Caps
No Joins
Miter Joins
Round Joins
Bevel Joins
Dashed Stroke
Resize Proportionally
Resized Uniformly

X
X
X
X
X
X
X
X
X
X
X

X

X
X
X
X

X
X
X
X
X

X
X
X
X

X
X
X
X
X

X
X
X
X

X
X
X
X
X

Text
Text Effects
Text on Curve
Text Includes Stroke

X
X
X

X
X
X

X X

Masking
Supported X X

Effects
Supported X X

Image Composition
Opacity Control
Transparent Backgnd

SVG Support
Scripting
Mouse Event
CSS
Linked Image Files
Embedded Image Files
Linked Audio Files

X
X
X
X

X

X
X
X
X

X

X

X
X

X
X

X
X

Feature Normal
SVG
Basic

SVG 
Tiny 1.1

SVG 
Tiny 1.2

Filters
Oilify
Blur
Motion Blur
Balance
Brightness
Color Limit
Contrast
Convert to Grayscale
Hue Saturation
Replace Color
Replace Background
Rotate Zoom
Vortex
Wave
Invert
Minimum
Maximum
Dilate
Erode
Noise
Mosaic
Sharpen
Edge Detection
Solarize
Wind

X
X
X
X
X
X
X
X
X
X
X
X
X
X
X
X
X
X
X
X
X
X
X
X
X

X
X
X
X
X
X

X
X

X
X
X
X
X
X

X

Composite Methods
Normal
Multiply
Screen
Erase
Add
Subtract
Darkest
Lightest
Difference
Average
Invert
Dissolve
Replace Hue
Replace Saturation
Replace Luminosity
Replace Color
XOR Mask
Alpha Mask

X
X
X
X
X
X
X
X
X
X
X
X
X
X
X
X
X
X

X
X
X
X
X

X
X

X
X

X
X

X

X X
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Changing Profiles
Besides setting your preferred profile when you create 
a new document, you can change the profile at any 
time in two different ways.

The Profiles toolbar

The Profile toolbar provides a quick and easy way to 
change the current profile. Simply select a profile from 
this toolbar and Mobile Designer adjusts the editing 
features as needed. For more information on the Pro-
file toolbar, see “Profile toolbar” on page 33.

The Profiles dialog

Selecting Edit > Profiles from the main menu displays 
the Profiles dialog. This dialog provides a more 
detailed account of each of the available profiles.

You can select any profile in the Profile menu and view 
which features are supported (Mobile Designer fea-
tures that are not listed are supported by all profiles).

• A green check mark indicates that the feature or 
feature group is enabled.

• A red “X” indicates that the feature or feature group 
is disabled.

• A yellow square indicates that some members of 
this item's sub-group are enabled and some are 
disabled.

• A green radio button indicates that only one item 
in the list can be selected at any one time. One item 
must always be selected.

• A gray radio button indicates that there are 
underlying radio buttons for this item. 

The Profiles dialog also contains a number of buttons 
you can use to manage your profiles.

To create a new, custom profile:

1. Click the New Profile button.

2. Customize the profile settings in the Create New 
Profile dialog.

To activate/deactivate any of the features listed in the 
Create New Profile dialog, click on them.

To copy the current profile:

Click the Copy Profile button.

To edit the current profile:

1. Click the Edit Profile button.

2. Customize the profile settings in the Edit Profile 
dialog.

To activate/deactivate any of the features listed in the 
Create New Profile dialog, click on them. Only cus-
tom profiles can be edited.

Copy Delete Import

New Edit ExportDefault
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To delete the current profile:

Click the Delete Profile button.

Only custom profiles can be deleted.

To set the current profile as the default when creating 
a new movie:

Click the Set Profile as Default button.

To load a previously saved profile:

1. Click the Import Profile button.

2. Navigate to the desired profile in the Windows 
Open dialog and click OK.

Profiles are stored as XML files.

To save a profile as an external file:

1. Click the Export Profile button.

2. Name the profile in the Windows Save As dialog 
and click OK.

Profiles are stored as XML files.

Working with Profiles
Profiles you create through the Profiles dialog are per-
sistent. That is, they are available for use in future 
Mobile Designer sessions. These profiles are stored as 
XML files in your application folder. In addition, 
whenever you save your movie, the selected profile is 
saved along with the movie.

When you load a Mobile Designer movie (i.e. one 
transferred from another machine), one of several 
actions may be taken:

• If the profile name and contents are identical 
between the saved file and those available in 
Mobile Designer, the file loads as normal.

• If the profile name does not match any of the 
profile names in Mobile Designer, then a new 
profile is added to the profile list in Mobile 
Designer and the file loads as normal.

• If the profile name matches one of the profile 
names in Mobile Designer, but the profiles 
themselves are not identical, you are queried for the 
proper action before the file is loaded.

Customizable Features
You can customize the list of supported features for 
any profile that you create (the predefined profiles are 
not available for editing, but they can be copied). This 
is done through the Edit Profile dialog.

Inside the Edit Profile dialog, you can activate or 
deactivate any of the features listed. Deactivating a 
feature effectively disables that feature in Mobile 
Designer. It also eliminates it at export time.

Design elements created in one profile are not lost 
when you change to a profile that does not support 
them. They are retained and will be restored when a 
new profile with the appropriate support is selected. 
When changing profiles, Mobile Designer attempts to 
use the available information to produce a satisfactory 
looking replacement. You should always confirm that 
your design has not been negatively impacted when 
changing profiles.

The sections below provide a detailed description of all 
of the profile options.

Gradient and Pattern Fills

Gradient and pattern fills are not supported in all 
export formats. In Mobile Designer you can choose to 
treat gradient patterns and fills as:
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• Vectors. Objects with vector fills are exported 
entirely as vectors which reduces file size and 
results in a sharper looking image.

• Bitmaps. Objects with bitmap fills are exported as 
bitmap objects.

• Non-exportable. Objects with this setting replace 
the gradient or pattern fill with a solid color.

In Mobile Designer, text and shapes are treated as two 
different categories of objects. You set the gradient 
and pattern fill options separately for text and shapes.

Stroke properties - Caps

Caps define the shape used at the end of open shapes. 
In Mobile Designer you have nine different caps to 
choose from, as follows.

The first three caps in the list, Button, Square and 
Round caps, each merit their own profile items. The 
middle three caps are grouped under the category of 
Arrow caps. The final three caps are more unusual and 
grouped under the name Other caps.

One additional item involving caps is the ability to 
specify whether both ends of a shape have the same or 
different caps. Many formats, including SVG, only 
support having the same caps at each end. The profile 
option that dictates how the ends of a shape are 
handled is Allow Different Caps On Both Ends.

Stroke properties - Dash

The outline or stroke of a shape can drawn using 
either a solid line (the default) or using different line 
patterns (dashes). 

When the Stroke Dash item is enabled, the line pattern 
chosen will be exported for the stroke. Otherwise, a 
solid line is used for the stroke.

Stroke properties - Joins

The corners of a paths and geometric shapes can 
drawn using one of four different shapes (joins). Each 
is independently supported.

Stroke properties - Resize Behavior

Different standard file formats treat objects differently 
when they are scaled or resized. Certain applications, 
such as SVG, scale the size of an object’s stroke as the 
object is resized. Thus, the entire object appears to 
grow proportionally. Other formats treat the stroke as 
a fixed size. In this case, the stroke remains at its orig-
inal width no matter what the scaling.

Mobile Designer offers three resize behaviors in order 
to accommodate the different options:

• Fixed sets the stroke to remain at a constant width 
when objects are resized.

• Proportional scales the stroke in proportion to how 
the width and height of the object are resized. This 
behavior is currently not available in Mobile 
Designer. When Proportional is selected, the 
Uniform behavior is shown in Mobile Designer.

• Uniform scales the stroke symmetrically as the 
object is resized.

No Joins
Miter Joins
Round Joins
Bevel Joins
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Text

While virtually all file formats support text in its 
standard form (i.e. single line and paragraph text), the 
more restrictive file formats do not always handle more 
advanced forms of text. You can individually control 
the following text formats in Mobile Designer:

• Text Effects. These are pre-programmed special 
animations made specifically for use with regular 
text. 

• Text On Curve. This is text that follows the path of 
a previously drawn shape.

• Text with Stroke. This is text with a separate 
outline drawn around each text character.

Composition

The composition options dictate how objects interact 
visually with other objects and the scene. Because the 
look of a movie depends so much on the interaction of 
the various objects, enabling and disabling certain 
composition options may have a significant impact on 
your movie.

The composition options are:

• Transparent Background. Both the movie and the 
scenes in the movie use a background color. If a 
transparent background is used and then this 
feature is disabled, the alpha channel setting of the 
background color is ignored producing a solid color 
background.

• Opacity. The opacity property interacts with the 
alpha of the fill and stroke color of an object to 
determine the final opacity for that object. The 
opacity for an object can vary between completely 
opaque and completely transparent. When the 
opacity profile option is disabled, the object 
remains completely opaque.

• Allow Opacity Above 100%. When determining 
the final opacity of an object, the object’s opacity 
and the object’s alpha color values are multiplied. 
By allowing an opacity value greater than 100%, it 
is possible to take an object with alpha values less 
than 100% and make it completely opaque.

• Composite Methods. Mobile Designer offers a 
variety of optical composition methods which 
combine the selected object with its background in 
different ways. Each of these methods is 
customizable. If a method is applied on an object 
and the profile no longer supports this method, 
then this method will not be applied anymore.

Effects

Mobile Designer offers five special effects, all of which 
are derivatives of the outer shadow concept. The 
effects are globally represented. So, disabling this fea-
ture will remove all the effects applied in your movie. 

Filters

Filters change the appearance of objects using a com-
plex mathematical formula. Filter support varies 
widely between output formats, with some such as 
SVG Tiny not supporting any filters, and others such 
as SVG Basic supporting some filters.

Filters can be enabled on an individual basis. When a 
filter is disabled, it is no longer applied to the object.

Mask

Masks allow you to select one object in Mobile 
Designer to serve as the outline of a 1-bit mask, where 
everything on the inside of the outline is allowed to 
show through, and everything on the outside is 
masked out (not seen).
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Disabling the mask support results in both all objects 
associated with the mask being visible. For SVG 
export, the object used as a mask is not be exported at 
all.

SVG

Unlike the other profile sections, the SVG section 
applies only to SVG export, not the individual features 
supported within Mobile Designer or the target out-
put format.

SVG - Scripting

SVG movies can be enhanced with embedded calls to 
JavaScript functions (scripts). These calls can be 
included both at the movie level from the Movie Prop-
erties dialog and at the event level when assigning 
actions to events. 

When enabled, the scripting profile option includes 
calls to any external JavaScript functions that you 
include in your movie.

SVG - Mouse events

SVG supports mouse events, such as Mouse Clicks. 
These events make intuitive sense on standard com-
puters, and are automatically mapped to activate and 
focus events on other devices, as follows:

• Mouse Click becomes Activate
• Mouse Up becomes Activate
• Mouse Over becomes Focus In
• Mouse Out becomes Focus Out

However, not all devices support mouse events. When 
the Mouse Events profile option is disabled, all mouse 
events are exported from your exported movie.

SVG - CSS

Cascading Style Sheets (CSS) are a simple mechanism 
for adding style (e.g. fonts, colors, spacing) to Web 
documents. For more information on cascading style 
sheets, see http://www.w3.org/TR/REC-CSS2/.

When the CSS profile option is enabled in SVG 
export, the style for every object is stored in a style 
sheet and then referenced in the SVG export file.

Creating buttons with the same style, for example, will 
save you space since this information is recorded only 
once. Also, if one day you decide to change the fill 
color of your buttons, you will easily be able to do so 
by directly changing the fill color in your button style 
definition.

SVG - Multimedia Handling

Images and sounds can be included in any Mobile 
Designer movie. Generally speaking, these external 
files can be either embedded in your SVG export file 
(images only) or saved in separate files with references 
included in the SVG export file (images and sounds).

You can specify your preference in the Profiles dialog as 
follows:

• Export in a Subfolder stores your image and sound 
files in a folder that is local to where you save your 
SVG file. The name of this folder is that of your 
SVG file with “.files” appended to it. Within this 
folder are subfolders named “images” and “sounds.”

• Export Locally stores all of your image and sounds 
files in the same folder as your saved SVG file.

• Embed includes an encoded version of your 
imported images directly in your SVG export file. 
This has the advantage that the image is always 
available even if the SVG file is moved to a 
different machine or displayed on a cell phone. 
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However, the SVG file size may increase 
substantially depending on the number and size of 
the images embedded. 
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Color is an integral part of any artwork no matter what 
the medium. You draw attention to particular image 
elements or convey information more subtly all 
through the color choices you make.

In Mobile Designer, colors can be applied to tools 
before drawing or to an existing object at any time.

Understanding Color
Mobile Designer provides a wide range of color setting 
options, all of which are available via the color samples 
in the Toolbox.

There are four color samples in the Toolbox, two for 
setting the stroke (outline) and fill for shapes, and two 
for setting the stroke and fill for text.

Shapes
Shapes include any object you draw on the screen with 
the exception of text.

Not all shapes have both a stroke and a fill. Lines, for 
example, have only a stroke. Changing the stroke or fill 
of an object that does not inherently support one of 
these has no effect.

Text
Two fundamentally different types of text are 
supported: normal text (which includes plain text, 
paragraph text, and text on a curve) and 3D text. The 
text color icons vary depending on the type of text 
selected.

Normal text displays the icons shown above. When 
working with normal text, the stroke and fill colors are 
used to change the stroke and fill colors for the text as 
you would expect.

3D text displays slightly different color icons. The 
stroke icon is replaced by the side color icon, and the fill 
icon is replaced by the front color icon. For 3D text, the 
side color is the color shown for the sides or depth of 
each letter. The front color is the color shown when the 
text is viewed head on.
Chapter 5: Applying Colors
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Applying Color
The method used to select a color is the same whether 
you are working with shapes or text, or solid colors, 
gradients or patterns.

To change the color of an object or tool:

1. Select an object or tool.

2. Do one of the following:

• Click the appropriate color sample or the small 
triangle adjacent to it to open the Color dialog (see 
“Using the Color dialog” on page 68 below).

• Click the Swap Colors icon to swap the fill and 
stroke colors for shapes or text.

• Click the Restore Default Colors icon to replace 
the current stroke and fill with those colors saved as 
the defaults.

Using the Color dialog
You use the Color dialog to apply a color to a tool or 
object’s stroke or fill. Within the Color dialog you have 
numerous options. These include mixing and storing 
your own colors, creating gradients and patterns, 
sampling existing colors, and setting different opacity 
levels.

To use the Color dialog:

Do one of the following:

• Click on the No Color button to remove the stroke 
or fill.

• Click the Color button to apply a solid stroke or 
fill. See “Selecting and storing solid colors” below 
for more information on selecting solid colors.

• Click on the Gradient button to apply a gradient 
stroke or fill. See “Creating and Editing Gradients” 
on page 70 for more information on building 
gradients.

• Click on the Pattern button to apply a pattern 
stroke or fill. See “Using Patterns” on page 72 for 
more information on applying patterns. 

Selecting and storing solid colors
The solid color picker includes two different sections. 
The top section provides tabs used to select the color 
model used, while the bottom section provides an eye 
dropper for sampling colors and space to store up to 18 
custom colors.

Each of the color models and features are described in 
the sections that follow.

Selecting colors using RGB

In the RGB color model you mix different levels of red, 
green and blue to achieve your final color. Independent 
from this, you can also set an alpha opacity for this 
color.
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The red, green, blue and alpha components are set 
either by dragging the knob on the color slider or by 
specifying a value in the adjacent number field. 

Each component has a range of 0 to 255. When all 
components are set to 0, the resulting color is black. 
When all components are set to 255, the resulting color 
is white. In between, you have a broad spectrum of 
visible colors to work with.

Selecting colors using HSB

In the HSB color model you set the hue, saturation and 
brightness levels to achieve your final color. 
Independent from this, you can also set an alpha 
opacity for this color. 

The hue, saturation, and brightness values are set either 
by dragging the knob on the color slider or by 
specifying a value in the adjacent number field.

The hue has a range of 0 to 359, which corresponds to 
the degree measurement on a color wheel. The 
saturation and brightness both have a range of 0 to 100.

The HSB tab also includes red, green and blue sliders, 
which are described in “Selecting colors using RGB” 
above.

Selecting colors using the Color Wheel

Using the Color Wheel, you set the hue and saturation 
levels for your color in the wheel, and the brightness 

level using the adjacent vertical slider. Independent 
from these, you can also set an alpha opacity for this 
color.

Click and drag anywhere on the wheel to select a color, 
and drag the knob on the brightness slider to specify 
the brightness level.

Selecting colors using CMYK

In the CMYK color model you mix different levels of 
cyan, magenta, yellow and black (K) to achieve your 
final color. Independent from this, you can also set an 
alpha opacity for this color.

The cyan, magenta, yellow, and black components are 
set either by dragging the knob on the color slider or by 
specifying a value in the adjacent number field. 

Each component has a range of 0 to 255. When all 
components are set to 0, the resulting color is white. 
When all components are set to 255, the resulting color 
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is black. In between, you have a broad spectrum of 
visible colors to work with.

Selecting colors using the Web Palette

The Web Palette provides a grid of color swatches for 
each of the 216 web safe colors (some of the more 
popular colors are duplicated in the top row) as well as 
a text field for entering hexadecimal color values.

Click on a swatch to select a color. The selected color is 
displayed in the larger rectangular color swatch, and 
the hexadecimal value is updated with the current color 
value. 

You can enter your own custom color values into the 
hexadecimal value field. These do not have to match 
any of the color swatches. The first two hexadecimal 
numbers encode the red, the middle two the green, and 
the last two the blue.

Selecting colors using the Eye Dropper

The eye dropper tool allows you to take a sampling of 
any color on the canvas or in the overscan area. 

Click on the eye dropper then click anywhere in the 
document window to select the color directly below the 

mouse pointer. This color is displayed in the current 
color sample below the eye dropper where it can be 
refined using any of the color models or stored for later 
use.

Storing and using Custom Colors

The Custom Colors section of the Color dialog 
provides a convenient location to store up to 16 custom 
colors for later use (see image above). These custom 
colors are persistent and will be available later for use in 
this movie and in other movies.

To add a color to the Custom Colors section, do one of 
the following:

• Drag the color from the current color sample and 
drop it in any of the custom color swatches.

• Select a custom color swatch, select a color, and 
click the Add to Custom Colors button. The new 
color is saved in the selected swatch.

Creating and Editing Gradients
A gradient is a smooth blend between two or more 
colors. You use the gradient builder in the Color dialog 
to create new gradients and edit existing gradients.

Eye Dropper
Current Color

Add to Custom
Colors

Gradient Bar
Color Box

Gradient Shape
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The look of your gradient is determined by a number of 
factors, including the number of colors in the gradient, 
their placement, their relative concentrations, and the 
shape of the gradient. 

The easiest way to see how a gradient will ultimately 
look is to apply it to an object. However, the Color 
dialog also displays a preview of each supported 
gradient to give you an idea of the result.

To modify the colors in a gradient:

1. Click on one of the gradient color boxes.

2. Select a new color in the slide out color picker. For 
information on selecting colors in the slide out 
color picker, see “Selecting and storing solid colors” 
on page 68.

To add colors to a gradient:

1. Click on the gradient bar to select it.

2. Do one of the following:

• Select one of the splitting options from the 
Gradient Selection menu.

• Click on the Gradient bar and drag the mouse 
pointer down until it is level with the other color 
samples and release the mouse button.

To remove colors from a gradient:

1. Click on one of the gradient color boxes.

2. Click the Delete Selection button.

Note: The color boxes on either end of the gradient bar cannot 
be deleted.

To change the positions of colors in a gradient:

1. Click on one of the gradient color boxes.

2. Drag it left or right to change the gradient on either 
side of the color box.

Note: The positions of the color boxes on either end of the gra-
dient bar cannot be changed.

To change the distribution of colors in a gradient:

1. Click on the gradient bar to select it.

2. Select one of the following distribution options in 
the Interpolate menu:

• Linear results in an even transition between the two 
color boxes.

• Curved results in a more rapid color change near 
the two color boxes than in the middle of the 
gradient.

• Sinusoidal results in a more rapid color change near 
the middle of the gradient than near the two color 
boxes.

• Circular (decreasing) results in a rapid color change 
near the left color box with a slow color change near 
the right color box.

• Circular (increasing) results in a rapid color change 
near the right color box with a slow color change 
near the left color box.

To change the shape of the gradient:

Do one of the following:

• Click on the linear gradient radio button and adjust 
the angle of the gradient using the adjacent angle 
value field or circular slider.

• Click on the radial gradient radio button.
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Using Patterns
A pattern is an external image file that you use to paint 
the stroke or fill for an object.

Offset X and Offset Y are used to move an image to the 
right and down, respectively. The distance moved is a 
percentage of the image width (Offset X) or height 
(Offset Y). With both offset values set to 0 (the 
default), the upper right corner of the image is aligned 
with the upper right corner of the object’s bounding 
box.

To load a pattern:

Click on the Open File button and navigate to the 
desired image file. 

To view the file properties for a pattern:

Click on the File Properties button.

To change the offset for a pattern:

Do one of the following:

• Enter a new value between 0 and 400% into the 
Scale X or Scale Y text box.

• Click on the Scale X or Scale Y slider and drag it to 
a new position.

Open File
File Properties
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The previous two chapters describe how to create 
objects and set many of their attributes via the menus 
and the animation panel. While you can accomplish a 
lot by working at this level, Mobile Designer offers 
many more options than those described thus far.

In this chapter, you learn how to use the Inspector 
panels to exercise greater control over the look and feel 
of the objects in your movie.

Overview
The Inspector panels offer a comprehensive set of 
options for setting everything from fonts and font sizes 
to 3D object rotations. Related information is grouped 
under tabs in the Inspector panels making it easy to 
make changes to any object in your movie with a couple 
of mouse clicks.

Working with Inspector panels
Before describing the contents of each tab, it is helpful 
to know how to use and customize the Inspector 
panels.

To select an Inspector panel tab:

Click on the tab in the Inspector panel.

To expand/contract an Inspector panel:

Panel Menu Icon

Splitter

Panel Menu

Expand Inspector
Chapter 6: Setting Attributes
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Do one of the following:

• Click the Expand Inspector/Contract Inspector 
button.

• Drag the splitter up or down to change the amount 
of space allocated to the Inspector panel.

To remove a tab from an Inspector panel:

1. Click on the Inspector menu button to open the 
Inspector menu.

2. Select the name of the tab that you wish to remove 
from the Inspector panel.

A check mark adjacent to an item in the Inspector 
menu indicates that tab is currently visible in the 
current Inspector. Items shown in plain text are 
currently visible in another Inspector panel. Items 
shown in bold face are currently not displayed in any 
Inspector panel.

To add a tab to an Inspector panel:

1. Click on the Inspector menu button to open the 
Inspector menu.

2. Select the name of the tab that you wish to add.

You can add any tab to an Inspector panel at any time. 
If it is being displayed in another Inspector panel, it 
will be moved from that panel to the current panel.

To close an Inspector panel and hide all of its tabs:

Click on the close button for the Inspector panel.

To open a new Inspector panel:

Do one of the following:

• From the main menu select Window > Add 
Inspector Panel.

• Click on the Add Inspector button in the Inspector 
toolbar.

To toggle between hiding and showing the Inspector 
panels:

Do one of the following:

• From the main menu select Window > Show/Hide 
Inspectors (F5).

• Click the Show or Hide Inspectors button in the 
Inspector toolbar.

Setting and Changing Attributes
Because Mobile Designer maintains each and every 
object as a distinct entity, you have complete flexibility 
in how you design your primitives and components. 
You can either set the attributes of the drawing tool 
before you draw a primitives, or you can change the 
attributes of existing objects at any time.

To set the attributes of a tool before you draw:

1. Select a tool.

2. Set its attributes in the Inspector panels or apply 
colors to it in the Toolbox.

3. Draw on the canvas.

To change the attributes of an existing object:

1. Select the object.

2. Change its attributes in the Inspector panels or 
apply colors to it in the Toolbox.

Note: all forms of text, polylines and Bezier curves also have a 
special editing mode for changing the text or adjusting the 
points on the curve.These operations are different from chang-
ing the attributes of the object. For more information on using 
these editing modes, see “Shapes” on page 39.
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General attributes
Many of the Inspector panel tabs contain attributes and 
settings that apply to the vast majority of primitives 
and components. These are detailed below.

The Object tab
The Object tab provides a way to view and edit the 
position, dimensions, rotation and opacity of an object. 
Changes you make to these values in the Object tab are 
immediately reflected on the canvas. Likewise, changes 
you make directly to the object on the canvas are 
immediately reflected in the Object tab.

If you change any of the values in the Object tab from 
one frame to another, you animate that object. For 
more information on animating objects, see 
“Animating Objects” on page 120.

To change the position (coordinates) of an object:

1. Select the object.

2. In the Object tab, select a corner of the bounding 
box or the rotation center to use as the Reference 
Point. The reference point, shown in red, is the 
point on the object’s bounding box that will be 

placed at the new coordinates. By default, the 
upper left corner of the bounding box is used as the 
reference point.

3. Enter the new coordinates for the object in the X 
and Y value fields.

Coordinates are specified in pixels. 

To change the dimensions of an object:

1. Select the object.

2. Enter new width and height values for the object in 
the W and H fields, respectively.

Dimensions are specified in pixels.

To change the rotation of an object:

1. Select the object.

2. Do one of the following:

• Type a new value into the Rotation field.

• Click on the Rotation slider and drag its thumb to 
the desired setting.

Rotation is specified in degrees.

To change the opacity of an object:

1. Select the object.

2. Do one of the following:

• Type a new value into the Opacity field.

• Click on the Opacity slider and drag its thumb to 
the desired setting.

For an individual object, an opacity of zero makes it 
completely transparent, and an opacity of 100 makes it 
opaque. 

Opacity levels greater than 100 are useful with certain 
composite methods (i.e multiply) that mathematically 
combine the opacity levels of overlapping objects. For 



Chapter 6:78
more information on composite methods, see “The 
Object tab” on page 77.

To change the composite method of an object:

1. Select the object.

2. Select a new composite method from the Mode 
menu.

To remove a composite method from an object:

1. Select the object.

2. Select Normal in the Mode menu.

The available composite methods are:

• Normal - No composite is method applied.
• Multiply - The RGB values of the object and 

underlying object(s) are multiplied together for 
each of the three color channels.

• Screen - The selected object “burns through” 
underlying objects to reveal the background color.

• Erase - The opacity of the object is used to “erase” 
the underlying objects. If the object’s opacity is set 
to less than 100%, then the objects below show 
through.

• Add - The RGB values of the object and 
underlying object(s) are added for each of the three 
color channels.

• Subtract - The RGB values of the underlying 
object(s) are subtracted from the object’s values for 
each of the three color channels.

• Darkest - The lower of the two RGB values is used 
for each of the three color channels.

• Lightest - The higher of the two RGB values is 
used for each of the three color channels.

• Difference - The difference between the object’s 
and the underlying object(s) RGB values is used for 
each of the three color channels.

• Average - The average of the object’s and the 
underlying object(s) RGB values is used for each of 
the three color channels.

• Invert - The object’s alpha level is used to invert the 
underlying objects.

• Dissolve - A random pattern is created based on 
the opacity of each pixel.

• Replace Hue - The hue of the object is used on 
underlying objects.

• Replace Saturation - The saturation of the object is 
used on underlying objects.

• Replace Luminosity - The luminosity of the object 
is used on underlying objects.

• Replace Color - The hue and saturation of the 
object is used on underlying objects.

• XOR Mask - The difference between the object 
and underlying object(s) opacities is computed, the 
absolute value is determined, and the dominant 
color shows through.

• Alpha Mask - The inverse of an erase. The 
composite object shape is used to mask out all lower 
objects.

Composite methods cannot be animated.

To set an object to be drawn aliased (when supported):

1. Select the object.

2. Check the Fast Rendering box.

Not all display devices support aliased rendering (all 
support anti-aliasing), and on those devices where 
aliasing is supported, there is no guarantee that it will 
be faster than anti-aliasing. Use this option at your own 
discretion.

To include an object’s name in exported SVG movies:

1. Select the object.

2. Check the Export ID box.
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An object name is required when referring to that 
object from an external JavaScript function. It is not 
required by other SVG movies.

The Stroke tab
The Stroke tab provides a way to change the width and 
overall look of the stroke of an object. Most primitives 
have a stroke, the exceptions being paint bucket 
objects, charts and legends. Components do not have a 
stroke, though the primitives that compose them may.

To change width of the stroke for an object:

1. Select the object.

2. Do one of the following:

• Type a new value into the Width field.

• Click on the Width slider and drag its thumb to the 
desired rotation setting.

To change the pattern (dash) of the stroke for an 
object:

1. Select the object.

2. Choose a new pattern from the Dash menu.

To change the shape (caps) drawn at the ends of an 
open object:

1. Select the object.

2. Do one of the following:

• To set the shape drawn at the point on the object 
where you first clicked and started drawing, choose 
a new shape from the Begin menu.

• To set the shape drawn at the point on the object 
where you finished drawing, choose a new shape 
from the End menu.

To change the shape of the corners (joins) of an object:

1. Select the object.

2. Choose a new shape for the corners from the Join 
menu.

To change the shape (radius) of the corners of a 
rounded rectangle:

1. Select the object.

2. Do one of the following:

• To set the X component of the radius, type a 
number between 0 and 100 into the X value field or 
adjust the adjacent slider.

• To set the Y component of the radius, type a 
number between 0 and 100 into the Y value field or 
adjust the adjacent slider.

The greater the X and Y radius values, the greater the 
curvature. In other words, if X and Y are zero, the 
object is a rectangle. If X and Y are both 100, the object 
is an ellipse.

If you change any of the radius value from one frame to 
another, the radius of a rounded rectangle is animated. 
For more information on how to animate objects, see 
“Animating between points” on page 120.
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The Filters tab
The Filters tab provides a way to add, change and 
delete the filters associated with an object. 

Filters change the appearance of objects using a 
complex mathematical formula. Certain filters, such as 
wind and wave, produce striking results that are 
immediately obvious. Other filters, such as vortex and 
mosaic only reveal their power when animated or on 
objects with gradient or pattern fills. 

Multiple filters can be applied to an object. The order 
that filters are applied determines how they interact 
with the object and with each other.

If you change a filter’s properties from one frame to 
another, you animate that filter. For more information 
on animating filters, see “Animating filters and effects” 
on page 122.

To add a filter to an object:

1. Select the object.

2. Click the Add Filter button and choose a filter 
from the popup menu.

3. Customize the settings for the filter in the specific 
filter dialog.

To edit an existing filter applied to an object:

1. Select the object.

2. Do one of the following:

• Click the Filter Properties button.

• Double-click on the filter name in the list of 
applied filters.

3. Change the settings for the filter in the specific 
filter dialog.

To change the order in which multiple filters are 
applied to an object:

1. Select the object.

2. Select the filter you want to move in the filters list.

3. Do one of the following:

• To move the filter to the beginning of the filters 
list, click the Move to Top button.

• To move the filter one level higher in the filters list, 
click the Move Up button.

• To move the filter one level lower in the filters list, 
click the Move Down button.

• To move the filter to the end of the filters list, click 
the Move to Bottom button.

To delete a filter from an object:

1. Select the object.

2. Select the filter in the filters list.

3. Click the Delete Filter button.

The Effects tab
The Effects tab provides a way to add, change and 
delete special effects associated with an object. The 
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available special effects include inner and outer 
shadows, glows, and bevels, as well as a full emboss.

Effects are created using slight variations on the drop-
shadow concept. When you add an effect to an object, 
Mobile Designer creates a copy of the object, gives it a 
solid fill, blurs and/or changes the opacity of the copy 
and/or offsets it from the original, and masks the copy 
with the original (or vice-versa).

Multiple effects can be applied to an object. The order 
that the effects are applied determines how they 
interact with the object and with each other.

If you change an effect’s properties from one frame to 
another, you animate that effect. For more information 
on animating effects, see “Animating filters and effects” 
on page 122.

To add an effect to an object:

1. Select the object.

2. Click the Add Effect button and choose an effect 
from the popup menu.

3. Customize the settings for the effect in the specific 
effect dialog.

To edit an existing effect applied to an object:

1. Select the object.

2. Do one of the following:

• Click the Effect Properties button.

• Double-click on the effect name in the list of 
applied effects.

3. Change the settings for the effect in the specific 
effects dialog.

To delete an effect from an object:

1. Select the object.

2. Select the effect in the effects list.

3. Click the Delete Effect button.

The Alignment tab
The Alignment tab provides a way to align one or more 
objects with each other or on the canvas. 

The Alignment tab and other methods of aligning 
objects are discussed in “Aligning Objects” on 
page 111.

The Info tab
The Info tab provides real time feedback on the color 
the mouse pointer is over, its coordinates, and when 
drawing or dragging, the difference between the 
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current pointer location and the point where the 
dragging or drawing was initiated.

The Red, Green, Blue and Alpha values show you color 
values for any object visible in the document window, 
but not the canvas color or overscan area color. The 
colors components shown are true whether you are on 
the canvas or in the overscan area. 

If you want to select a color on the canvas, the easiest 
way to do so is to use the Eye Dropper tool. For more 
information on using the eye dropper tool, see 
“Selecting colors using the Eye Dropper” on page 70.

The Info tab is the only tab that does not allow you to 
enter or edit attributes; it is for informational purposes 
only. 

Text attributes
Text of all varieties, whether it is drawn using one of 
the text tools or it appears as part of a chart or legend, 
is customized using one or more of the text handling 
tabs.

Four tabs are dedicated to handling the various nuances 
of text. The Text tab provides a means of setting 
general text properties. The Paragraph tab deals 
specifically with paragraph related properties. The Text 
Effects tab allows you to enhance text using built-in 

text effects, and the 3D tab covers 3D text specific 
features. Each tab is described in detail below.

The Text tab
The Text tab is used to set common text attributes 
including font face, style, text size, character spread, 
and shearing. In addition, the Text tab provides 
controls for specifying how text behaves when it is 
dynamically replaced using external applications or 
XML.

Customization options

When customizing text using the text tab, you can edit 
items on an object by object basis, or you can edit 
portions of a single text object as you would in a word 
processor. 

To edit an entire text object:

1. Select the text object.

2. Edit it using the controls in the Text tab.

To edit only a portion of a text object:

1. Select the text object.

2. Do one of the following to enter text edit mode:

• Double-click on the selected object.

• Press the Enter key.
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3. Highlight the portion of the text you wish to edit.

4. Edit the text using the controls in the Text tab.

The remaining sections describe how to use particular 
Text tab controls. You can use these to edit either entire 
objects or characters within an object using one of the 
selection methods described above.

To change the font:

1. Select the text object.

2. Do one of the following:

• Click on the Font popup menu and choose a new 
font from the font list.

• Click on the Cycle Fonts button adjacent to the 
Font popup menu to display the next font in the 
font list.

To change the style:

1. Select the text object.

2. Click on the Style popup menu and choose a new 
style from the style list.

To change the font size:

1. Select the text object.

2. Do one of the following:

• To resize text using the same font height and 
width, click on the padlock icon until it appears 
locked and do one of the following:

• Type a new number into the Font Height value 
field.

• Click on the Font Height slider and drag its 
thumb to the desired setting.

• To resize the font height and width separately, click 
on the padlock icon until it appears unlocked and 
do one of the following:

• Type a new number into the Font Height or Font 
Width value field.

• Click on the Font Height or Font Width slider 
and drag its thumb to the desired setting.

You can also change the font height and font width of 
regular text, text on curve and 3D text by dragging the 
corners and edges of the object’s bounding box. 

When the padlock icon is locked, resizing is 
proportional. When the padlock is unlocked, the font 
height and width resize independently. If you press the 
Shift key while resizing, the font height and width 
resize proportionally.

To change the distance (tracking) between characters:

1. Select the object.

2. Do one of the following:

• Type a new number into the Tracking value field.

• Click on the Tracking slider and drag its thumb to 
the desired setting.

To change the shearing:

1. Select the object.

2. Do one of the following:

• Type a new number into the Shearing value field.

• Click on the Shearing slider and drag its thumb to 
the desired setting.

Bounding box options

The Bounding Box section of the Text tab comes into 
play whenever you are using either XML or an external 
application such as Beatware Live Assets to replace the 
contents of a text object with a new string of text.
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For example, say your movie calls for you to 
dynamically replace: 

score text

with a daily basketball score such as:

Cardinal 103, Golden Bears 55

As you can see, the replacement text is much longer 
than the original placeholder text. Thus, when the 
placeholder text is replaced, the bounding box for the 
text (and thus the text object) will need to grow 
horizontally.

Depending on your design, you may want the text to 
expand symmetrically, or only from one end or the 
other. By selecting the appropriate bounding box 
behavior, it is easy to generate the correct results. 

In the illustration that follows, you see the generic 
Mobile Designer layout followed by the first 3 
bounding box options, align left, center and align right. 
Obviously the align left option works the best in this 

situation because the placeholder text was placed near 
the left edge of the surrounding rectangle.

The Bounding Box information can also be animated. 
Thus, if you have text bouncing around your movie, 
you can rest assured that even text you dynamically 
replace will behave as expected regardless of its size.

To set the Bounding Box for dynamically replaced text:

1. Select the object.

2. Do one of the following:

Original Design

Align Left in Bounding Box

Center in Bounding Box

Align Right in Bounding Box
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• For text that resizes only to the right (i.e. the left 
edge remains fixed), click the Align Left in 
Bounding Box button.

• For text that resizes symmetrically, click the Center 
in Bounding Box button.

• For text that resizes only to the left (i.e. the right 
edge remains fixed), click the Align Right in 
Bounding Box button.

• To keep the bounding box size the same and have 
the font size adjust so that the replacement text fits 
in the space available, click the Keep Bounding Box 
button.

The Paragraph tab
The Paragraph tab provides a way to control the 
alignment, indentation and line spacing for multiline 
text. Multiline text can be created using both the 
regular text tool and the paragraph text tool.

To change the alignment of multiline text:

1. Select the object.

2. Do one of the following:

• For left justified text, click the Left Justify button. 

• For centered text, click the Center Justify button.

• For right justified text, click the Right Justify 
button.

To change the indentation of paragraph text:

1. Select the object.

2. Do one of the following:

• Type a new number into the Indent value field.

• Click on the Indent slider and drag its thumb to the 
desired setting.

Indentation is measured in pixels.

To change the spacing between lines in multiline text:

1. Select the object.

2. Do one of the following:

• Type a new number into the Line Spacing value 
field.

• Click on the Line Spacing slider and drag its 
thumb to the desired setting.

The distance between lines depends on the font size. A 
value of 1 represents single spaced lines, 2 represents 
double spaced lines, etc.

The Text Effect tab
The Text Effect tab provides a way to add one or more 
text effects to text objects. Text effects can be added to 
regular text, paragraph text or text on curve.

Text effects are actually short animations that are 
created through a text effect dialog instead of using 
conventional animation techniques. Because they are 
created using mathematical computations, they 
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produce dramatic results in SVG without adding 
significantly to the export file size.

Each text effect has a different set of customizable 
parameters you can set. These parameters allow you to 
precisely determine how each text effect behaves and 
looks.

The one parameter that is common to all text effects is 
the duration. The duration is the number of frames 
over which the text effect takes place. When you add a 
text effect, if there are not enough frames in your 
animation beyond the current frame to accommodate 
the text effect, additional frames are added for you as 
needed.

To add a text effect:

1. Select the text object.

2. Click the Add button and choose an effect from the 
popup menu.

3. Customize the settings for the text effect in the 
specific text effect dialog.

To edit a text effect:

1. Select the text object.

2. Do one of the following:

• Click the Edit button.

• Double-click on the text effect name in the list of 
applied text effects.

3. Change the settings for the text effect in the 
specific text effect dialog.

To delete a text effect:

1. Select the text object.

2. Select the text effect in the list of applied text 
effects.

3. Click the Delete button.

The 3D Text tab
The 3D Text tab provides controls for changing the 
text, proportions (akin to the height and with of regular 
text) and extrusion (visual depth) for 3D text. 

The front and side colors for 3D text are set directly in 
the Toolbox. The 3D rotation and lighting attributes 
are set in the 3D tab. For more information on setting 
3D attributes, see “3D Attributes” on page 87.

To edit 3D text:

1. Select the 3D text object.

2. Change the text string in the Text field.

Unlike other forms of text, 3D text can only be 
changed via the 3D Text tab after creation.

To change the 3D text proportions:

1. Select the 3D text object.

2. Do one of the following:

• Type a new number into the Proportion value field.

• Click on the Proportion slider and drag its thumb 
to the desired setting.

To change the 3D text extrusion:

1. Select the 3D text object.

2. Do one of the following:

• Type a new number into the Extrusion value field.

• Click on the Extrusion slider and drag its thumb to 
the desired setting.
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3D Attributes
The rotation and lighting for 3D text created in Mobile 
Designer and 3D models imported into Mobile 
Designer are controlled through the 3D tab. 

In addition to translating 3D objects like you do any 
other object, you can animate the object to rotate in 3 
dimensions as it translates. You can also specify the 
color and positioning of the light sources and animate 
those, too.

For more information on animating objects, see 
“Animating 3D objects” on page 123.

To rotate an object in 3D:

1. Select the 3D object.

2. Do one of the following:

• To rotate the object around the x-axis, change the 
number in the Rx value field or click on the Rx 
slider and drag its thumb to the desired setting.

• To rotate the object around the y-axis, change the 
number in the Ry value field or click on the Ry 
slider and drag its thumb to the desired setting.

• To rotate the object around the z-axis, change the 
number in the Rz value field or click on the Rz 
slider and drag its thumb to the desired setting.

The Rx, Ry and Rz rotation settings are all measured in 
degrees.

You can also change the rotation of a 3D object by 
dragging it on the canvas in edit mode.

About Lighting

There are two different types of light you can 
manipulate when working with 3D objects: ambient 
light and point light.

Ambient light is the light that illuminates an object 
from all directions. Point light is actually two light 
sources located on opposite sides of a 3D object. They 
produce the objects highlights. You can set the color for 
both ambient light and point light.

To change the ambient color or light color:

1. Select the 3D object.

2. Do one of the following:

• Click on the Ambient Color sample or the small 
triangle adjacent to it to open the Color dialog 
where you can select a new ambient color. 

• Click on the Light Color sample or the small 
triangle adjacent to it to open the Color dialog 
where you can select a new light color. 

For more information using the Color dialog, see 
“Using the Color dialog” on page 68.

To change the position of the light sources:

1. Select the 3D object.

2. Do one of the following:

• To rotate the light sources around the x-axis, 
change the number in the Rx value field or click on 
the Rx slider and drag its thumb to the desired 
setting.
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• To rotate the light sources around the y-axis, 
change the number in the Ry value field or click on 
the Ry slider and drag its thumb to the desired 
setting.

• To rotate the light sources around the z-axis, 
change the number in the Rz value field or click on 
the Rz slider and drag its thumb to the desired 
setting.

The Rx, Ry and Rz rotation settings are all measured in 
degrees.

Each 3D object has its own light source.

About Perspective

Perspective controls the perspective effect for 3D 
objects. It increases (smaller values) or decreases (larger 
values) the apparent depth of 3D objects.

To change the perspective:

1. Select the 3D object.

2. Do one of the following:

• Type a new number into the Perspective value field.

• Click on the Perspective slider and drag its thumb 
to the desired setting.

Chart and Legend attributes
Mobile Designer provides a comprehensive set of tools 
for creating business charts and graphs. Using these 
built-in tools, you can create everything from simple 
dashboards that graphically display a single value to 
complex 3D bar charts packed full of data.

Working with the charting tabs

The Chart tab is the first of five inspector tabs devoted 
exclusively to creating and manipulating charts, graphs 
and legends.

Each charting tab deals with a specific chart facet:

• The Chart tab is used to select the type of chart 
used.

• The Axis tab is used to set the units and colors 
associated with each axis in the chart.

• The Labels tab is used to specify the type of labels, 
if any, that are used on the chart axes.

• The Walls tab is used to specify what is shown 
extending up as a plane from each axis.

• The Curves tab is used to specify the colors and 
markers displayed for each data point and series.

External data

One of the underlying assumptions when working with 
charts is that the data to populate the charts will be 
provided in an external XML data file. No matter what 
type of chart you create, while you are designing, it will 
appear with random data. At preview or export time, 
the data from the data file you specify will replace the 
dummy data giving you the actual chart.

For more information on populating charts with data, 
see “Associating XML data with charts” on page 198.

The Chart tab
The Chart tab is used to customize both charts and 
legends. Its contents change depending on what is 
selected.

When a chart is selected, the Chart tab is used to 
choose the type of chart as well as edit those parameters 
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that are specific to that chart type. When a legend is 
selected, the Chart tab is used to customize the look of 
the legend.

Chart types

Charts come in three different genres:

• Single value charts such as speedometers are used 
to display single data points in a graphical format.

• Single series charts such as pie charts are used to 
display the relationship between elements in a 
single series.

• Multiple series charts such as bar charts are used to 
display multiple series of data in a graphical format. 

You select which genre of chart you are using when you 
choose your charting tools in the Toolbox. Once you 
have drawn a chart of a given genre, you cannot convert 
it to a different genre of chart. You can, however, 
switch between different types of charts in a given 
genre at any time.

The table that follows shows the available genres and 
chart types within those genres. Each is explained in 
greater detail below.

Speedometer charts

The speedometer chart is a single value chart that 
displays information on an analog dial reminiscent of a 
car speedometer. It is composed of three parts: the dial 
(arrow), the base, and the background area.

The Chart tab is used to set the colors for the dial and 
its base, the size and shape of the dial, and the area 
covered by the speedometer (i.e. is it a complete circle.

To set the stroke and fill color for the dial and its base:

1. Select the chart object.

2. Do one of the following:

• Click on the Arrow Stroke color sample or the 
small triangle adjacent to it to open the Color 
dialog where you can select a new stroke color for 
the dial. 

• Click on the Arrow Fill color sample or the small 
triangle adjacent to it to open the Color dialog 
where you can select a new fill color for the dial. 

• Click on the Base Stroke color sample or the small 
triangle adjacent to it to open the Color dialog 
where you can select a new stroke color for the base. 

Genre Chart Type
Single value chart Speedometer
Single value chart Linear meter
Single series chart Pie
Single series chart 3D pie
Single series chart Bar valuator
Multiple series chart Line
Multiple series chart Area
Multiple series chart Bar
Multiple series chart 3D Bar
Multiple series chart Radar
Multiple series chart Aligned 3D
Multiple series chart Line 3D 
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• Click on the Base Fill color sample or the small 
triangle adjacent to it to open the Color dialog 
where you can select a new fill color for the base. 

To set the size (length) of the dial:

1. Select the chart object.

2. Enter a new number in the Size value field.

The size is the length of the dial as measured from the 
center of the speedometer to its outer edge. It is a 
percent value. Sizes greater than 100 result in dials that 
extend outside the speedometer. Sizes less than 100 
result in dials that do not reach the edge of the 
speedometer.

To set the offset of the dial from the center of the base:

1. Select the chart object.

2. Enter a new number in the Offset value field.

The offset is the distance between the center of the 
speedometer and where the dial is drawn. It is a percent 
value. A value of 0 results in a dial that is drawn starting 
at the center of the speedometer. Values greater than 0 
results in the drawing starting some distance away from 
the center.

To set the shape of the dial where it meets the base:

Do one of the following:

• For a square shaped end, select Square in the Type 
menu.

• For a diamond shaped end, select Diamond in the 
Type menu.

• For a round shaped end, select Round in the Type 
menu.

To set the size of the hole at the center of the base:

1. Select the chart object.

2. Do one of the following:

• Enter a new number in the Hole value field.

• Click the Hole slider and drag its thumb to the 
desired setting.

Hole values greater than 0 create a doughnut effect for 
the background of the chart. The hole is measured in 
pixels.

To set the starting and ending positions of the 
speedometer background:

Done one of the following:

• To set the starting angle, enter a new number in the 
Start value field.

• To set the ending angle, enter a new number in the 
End value field.

The angles are measured in degrees. The 0 degree point 
corresponds to 3 o’clock, 90 degrees corresponds to 12 
o’clock, 180 degrees corresponds to 9 o’clock, 270 
degrees corresponds to 6 o’clock.

Linear meter charts

The linear meter chart is a single value chart that 
displays information through a single bar reminiscent 
of a thermometer. 

The Chart tab is used to set the width and color of the 
meter.

To set the width of the line:

1. Select the chart object.

2. Enter a new number in the Width value field.
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A meter width of 25 exactly covers the background of 
the linear meter. Widths smaller than 25 reveal the 
background. Widths greater than 25 overflow the 
background.

To set the color of the line:

1. Select the chart object.

• Click on the Color sample or the small triangle 
adjacent to it to open the Color dialog where you 
can select a new color for the meter. 

Pie charts

The pie chart is a single series chart that displays 
information using a familiar pie or doughnut shape. 

The Chart tab is used to set the separation between pie 
wedges and the size of the hole in the center of the 
chart.

To set the distance between pie wedges:

1. Select the chart object.

2. Do one of the following:

• Enter a new number in the Separation value field.

• Click the Separation slider and drag its thumb to 
the desired setting.

The Separation is the distance between the different 
wedges in the pie chart. A separation of 0 results in a 
solid looking chart. Separation values greater than 0 
add increasing amounts of space between each wedge.

To set the size of the center hole:

1. Select the chart object.

2. Do one of the following:

• Enter a new number in the Hole value field.

• Click the Hole slider and drag its thumb to the 
desired setting.

The Hole is the distance from the center of the object 
until the pie chart first appears. A value of 0 produces 
a no hole. A value greater than 0 results in a doughnut 
effect for the pie chart.

3D pie charts

The 3D pie chart is a single series chart that displays 
information using a familiar pie or doughnut shape. 
Unlike the standard pie chart, it also has a 3D depth. 

The Chart tab is used to set the separation between pie 
wedges, the size of the hole in the center of the chart, 
and the depth of the chart.

To set the distance between pie wedges:

1. Select the chart object.

2. Do one of the following:

• Enter a new number in the Separation value field.

• Click the Separation slider and drag its thumb to 
the desired setting.

The Separation is the distance between the different 
wedges in the pie chart. A separation of 0 results in a 
solid looking chart. Separation values greater than 0 
add increasing amounts of space between each wedge.
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To set the depth of the chart:

1. Select the chart object.

2. Do one of the following:

• Enter a new number in the Depth value field.

• Click the Depth slider and drag its thumb to the 
desired setting.

The Depth determines how 3D the object looks. A 
value of 1 indicates no depth (a standard pie chart). 
Values greater than 1 increase the apparent depth of the 
object. 

The impact of changing the Depth may not be 
apparent unless the chart has been rotated in 3D. For 
more information on rotating 3D objects, see “3D 
Attributes” on page 87.

To set the size of the center hole:

1. Select the chart object.

2. Do one of the following:

• Enter a new number in the Hole value field.

• Click the Hole slider and drag its thumb to the 
desired setting.

The Hole is the distance from the center of the object 
until the 3D pie chart first appears. A value of 0 
produces a no hole. A value greater than 0 results in a 
doughnut effect for the 3D pie chart.

Simple bar charts

The simple bar chart is a single series, 3D chart that 
displays information using one or more bars.

The Chart tab is used to set the format of the chart, the 
spacing between bars, and the depth of the chart.

To set the format of the chart:

1. Select the chart object.

2. Do one of the following:

• For a chart containing bars that appear next to each 
other, choose Side by Side in the Format menu.

• For a chart with bars that are stacked one on top of 
another with their sizes proportional to their 
values, choose Stacked in the Format menu.

• For a chart with bars stacked one on top of another 
with their sizes shown as a percentage of the total, 
choose 100% Stacked in the Format menu.

3. Check the Horizontal Layout box to show the bars 
with a horizontal orientation.

To set the depth of the chart:

1. Select the chart object.

2. Do one of the following:

• Enter a new number in the Depth value field.

• Click the Depth slider and drag its thumb to the 
desired setting.

The Depth determines how 3D the object looks. A 
value of 1 indicates no depth (a standard pie chart). 
Values greater than 1 increase the apparent depth of the 
object. 
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The impact of changing the Depth may not be 
apparent unless the chart has been rotated in 3D. For 
more information on rotating 3D objects, see “3D 
Attributes” on page 87.

To set the space between bars in the chart:

1. Select the chart object.

2. Do one of the following:

• Enter a new number in the Spacing value field.

• Click the Spacing slider and drag its thumb to the 
desired setting.

The Spacing determines the distance between each bar. 
Because the total width of the chart is fixed, increasing 
the spacing effectively reduces the width of each bar. A 
spacing value of 0 indicates that each bars is touching 
the adjacent bars.

Spacing is only used by charts with a Side by Side 
format.

Line charts

The line chart is a multiple series chart that displays 
information on a standard graph. Each line in a line 
chart displays information on one series of data.

The Chart tab is used to specify which elements of the 
graph are displayed and which are hidden, and whether 
the plotted lines appear with background shadows.

To set the visibility of the chart elements:

1. Select the chart object.

2. Do one of the following:

• To view all of the elements that make up the chart 
(axes, axis labels and plotted data), choose Axes, 
Data and Labels in the Visibility menu.

• To view the axes but hide the axis labels and plotted 
data, choose Axes in the Visibility menu.

• To view the plotted data but hide the axes and axis 
labels, choose Data in the Visibility menu.

• To view the axis labels but hide the axes and plotted 
data, choose Labels in the Visibility menu.

• To view the axes and axis labels but hide the plotted 
data, choose Axes and Labels in the Visibility 
menu.

• To view the axes and plotted data but hide the axis 
labels, choose Axes and Data in the Visibility 
menu.

• To view the plotted data and axis labels but hide the 
axes, choose Data and Labels in the Visibility 
menu.

To display a background shadow for each plotted line:

Check the Shadow box.

Area charts

The area chart is a multiple series chart that displays 
information by filling the area under each curve on a 
standard graph. Each area in an area chart displays 
information on one series of data.
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The Chart tab is used to specify which elements of the 
chart are displayed and which are hidden, and how the 
area data is presented.

To set the visibility of the chart elements:

1. Select the chart object.

2. Do one of the following:

• To view all of the elements that make up the chart 
(axes, axis labels and plotted data), choose Axes, 
Data and Labels in the Visibility menu.

• To view the axes but hide the axis labels and plotted 
data, choose Axes in the Visibility menu.

• To view the plotted data but hide the axes and axis 
labels, choose Data in the Visibility menu.

• To view the axis labels but hide the axes and plotted 
data, choose Labels in the Visibility menu.

• To view the axes and axis labels but hide the plotted 
data, choose Axes and Labels in the Visibility 
menu.

• To view the axes and plotted data but hide the axis 
labels, choose Axes and Data in the Visibility 
menu.

• To view the plotted data and axis labels but hide the 
axes, choose Data and Labels in the Visibility 
menu.

To set the appearance of the chart:

1. Select the chart object.

2. Do one of the following:

• For a chart containing ares that are plotted one in 
front of another, choose Side by Side in the Stack 
menu.

• For a chart with areas that are stacked one on top of 
another with their sizes proportional to their 
values, choose Stacked in the Stack menu.

• For a chart with areas stacked one on top of another 
with their sizes shown as a percentage of the total, 
choose Stacked 100% in the Stack menu.

Bar charts

The bar chart is a multiple series chart that displays 
data using different sized bars. Each series of data in a 
bar chart is given a different color to distinguish it from 
other series in the chart.

The Chart tab is used to specify which elements of the 
chart are displayed and which are hidden, how the data 
is presented, and the spacing between bars.

To set the visibility of the chart elements:

1. Select the chart object.

2. Do one of the following:

• To view all of the elements that make up the chart 
(axes, axis labels and plotted data), choose Axes, 
Data and Labels in the Visibility menu.
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• To view the axes but hide the axis labels and plotted 
data, choose Axes in the Visibility menu.

• To view the plotted data but hide the axes and axis 
labels, choose Data in the Visibility menu.

• To view the axis labels but hide the axes and plotted 
data, choose Labels in the Visibility menu.

• To view the axes and axis labels but hide the plotted 
data, choose Axes and Labels in the Visibility 
menu.

• To view the axes and plotted data but hide the axis 
labels, choose Axes and Data in the Visibility 
menu.

To set the appearance of the chart:

1. Select the chart object.

2. Do one of the following:

• For a chart containing bars that appear next to each 
other, choose Side by Side in the Stack menu.

• For a chart with bars that are stacked one on top of 
another with their sizes proportional to their 
values, choose Stacked in the Stack menu.

• For a chart with bars stacked one on top of another 
with their sizes shown as a percentage of the total, 
choose Stacked 100% in the Stack menu.

3. Check the Horizontal Layout box to show the bars 
with a horizontal orientation.

To set the space between bars in the chart:

1. Select the chart object.

2. Do one of the following:

• Enter a new number in the Spacing value field.

• Click the Spacing slider and drag its thumb to the 
desired setting.

The Spacing determines the distance between each bar. 
Because the total width of the chart is fixed, increasing 
the spacing effectively reduces the width of each bar. A 
spacing value of 0 indicates that each bars is touching 
the adjacent bars.

3D bar charts

The 3D bar chart is a multiple series 3D chart that 
displays data using different sized bars. Unlike the 
standard bar chart, it also has a 3D depth. Each series 
of data in a 3D bar chart is given a different color to 
distinguish it from other series’ in the chart. 

The Chart tab is used to specify which elements of the 
chart are displayed and which are hidden, the width 
and depth of the bars, and the overall depth of the 
chart.

To set the visibility of the chart elements:

1. Select the chart object.

2. Do one of the following:

• To view all of the elements that make up the chart 
(axes, axis labels and plotted data), choose Axes, 
Data and Labels in the Visibility menu.

• To view the axes but hide the axis labels and plotted 
data, choose Axes in the Visibility menu.
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• To view the plotted data but hide the axes and axis 
labels, choose Data in the Visibility menu.

• To view the axis labels but hide the axes and plotted 
data, choose Labels in the Visibility menu.

• To view the axes and axis labels but hide the plotted 
data, choose Axes and Labels in the Visibility 
menu.

• To view the axes and plotted data but hide the axis 
labels, choose Axes and Data in the Visibility 
menu.

To display the 3D bar chart with a horizontal 
orientation:

Check the Horizontal Layout box.

To set the width of the bars in the chart:

1. Select the chart object.

2. Do one of the following:

• Enter a new number in the Width value field.

• Click the Width slider and drag its thumb to the 
desired setting.

Increasing the width reduces the space between bars in 
the same series (i.e. adjacent bars) and vice versa.

To set the depth of the bars in the chart:

1. Select the chart object.

2. Do one of the following:

• Enter a new number in the Depth value field.

• Click the Depth slider and drag its thumb to the 
desired setting.

Increasing the depth reduces the space between each 
series of bars (i.e. bars drawn one in front of another) 
and vice versa.

The impact of changing the Depth may not be 
apparent unless the chart has been rotated in 3D. For 
more information on rotating 3D objects, see “3D 
Attributes” on page 87.

To set the depth of the chart itself:

1. Select the chart object.

2. Do one of the following:

• Enter a new number in the Z Length value field.

• Click the Z Length slider and drag its thumb to the 
desired setting.

The Z Length sets the length of the z-plane. The 
smaller the value, the less deep the chart and vice versa.

The impact of changing the Z Length may not be 
apparent unless the chart has been rotated in 3D. For 
more information on rotating 3D objects, see “3D 
Attributes” on page 87.\

To allow the chart to be rotated in 3D:

Check the Real 3D Projection box.

Real 3D Projection, when checked, results in a chart 
that can be rotated in all 3 dimensions. When not 
checked, the chart has a 3D appearance, but true 3D 
rotation is not possible.

Radar charts

The Radar Chart is a multiple series chart that maps 
data using different areas starting from a central point. 
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The radar chart inspector is used to specify which 
elements of the chart are displayed and which are 
hidden.

To set the visibility of the chart elements:

1. Select the chart object.

2. Do one of the following:

• To view all of the elements that make up the chart 
(axes, axis labels and plotted data), choose Axes, 
Data and Labels in the Visibility menu.

• To view the axes but hide the axis labels and plotted 
data, choose Axes in the Visibility menu.

• To view the plotted data but hide the axes and axis 
labels, choose Data in the Visibility menu.

• To view the axis labels but hide the axes and plotted 
data, choose Labels in the Visibility menu.

• To view the axes and axis labels but hide the plotted 
data, choose Axes and Labels in the Visibility 
menu.

• To view the axes and plotted data but hide the axis 
labels, choose Axes and Data in the Visibility 
menu.

Aligned 3D charts

The Aligned 3D Chart is a multiple series chart that 
looks 3D but all of the bars in the chart are in a 2 
dimensional plane. Each series of data in an aligned 3D 

chart is given a different color to distinguish it from 
other series’ in the chart. 

The Chart tab is used to specify which elements of the 
chart are displayed and which are hidden, the width 
and depth of the bars, and whether the chart can be 
rotated in 3D or not.

To set the visibility of the chart elements:

1. Select the chart object.

2. Do one of the following:

• To view all of the elements that make up the chart 
(axes, axis labels and plotted data), choose Axes, 
Data and Labels in the Visibility menu.

• To view the axes but hide the axis labels and plotted 
data, choose Axes in the Visibility menu.

• To view the plotted data but hide the axes and axis 
labels, choose Data in the Visibility menu.

• To view the axis labels but hide the axes and plotted 
data, choose Labels in the Visibility menu.

• To view the axes and axis labels but hide the plotted 
data, choose Axes and Labels in the Visibility 
menu.
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• To view the axes and plotted data but hide the axis 
labels, choose Axes and Data in the Visibility 
menu.

To set the appearance of the chart:

1. Select the chart object.

2. Do one of the following:

• For a chart containing bars that appear next to each 
other, choose Side by Side in the Format menu.

• For a chart with bars that are stacked one on top of 
another with their sizes proportional to their 
values, choose Stacked in the Format menu.

• For a chart with bars stacked one on top of another 
with their sizes shown as a percentage of the total, 
choose Stacked 100% in the Format menu.

3. Check the Horizontal Layout box to show the bars 
with a horizontal orientation.

To set the width of the bars in the chart:

1. Select the chart object.

2. Do one of the following:

• Enter a new number in the Width value field.

• Click the Width slider and drag its thumb to the 
desired setting.

Increasing the width reduces the space between bars in 
the same series (i.e. adjacent bars) and vice versa.

To set the depth of the bars in the chart:

1. Select the chart object.

2. Do one of the following:

• Enter a new number in the Depth value field.

• Click the Depth slider and drag its thumb to the 
desired setting.

The impact of changing the Depth may not be 
apparent unless the chart has been rotated in 3D. For 
more information on rotating 3D objects, see “3D 
Attributes” on page 87.

To allow the chart to be rotated in 3D:

Check the Real 3D Projection box.

Real 3D Projection, when checked, results in a chart 
that can be rotated in all 3 dimensions. When not 
checked, the chart has a 3D appearance, but true 3D 
rotation is not possible.

Line 3D charts

The Line 3D Chart is a multiple series, 3D chart that 
is in essence an area chart where each area includes an 
added depth factor resulting in a 3D appearance.

The Chart tab is used to specify which elements of the 
chart are displayed and which are hidden, the depth of 
the curves, and the overall depth of the chart.

To set the visibility of the chart elements:

1. Select the chart object.

2. Do one of the following:

• To view all of the elements that make up the chart 
(axes, axis labels and plotted data), choose Axes, 
Data and Labels in the Visibility menu.
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• To view the axes but hide the axis labels and plotted 
data, choose Axes in the Visibility menu.

• To view the plotted data but hide the axes and axis 
labels, choose Data in the Visibility menu.

• To view the axis labels but hide the axes and plotted 
data, choose Labels in the Visibility menu.

• To view the axes and axis labels but hide the plotted 
data, choose Axes and Labels in the Visibility 
menu.

• To view the axes and plotted data but hide the axis 
labels, choose Axes and Data in the Visibility 
menu.

To set the depth of the bars in the chart:

1. Select the chart object.

2. Do one of the following:

• Enter a new number in the Depth value field.

• Click the Depth slider and drag its thumb to the 
desired setting.

Increasing the depth reduces the space between each 
area (drawn one in front of another) and vice versa.

The impact of changing the Depth may not be 
apparent unless the chart has been rotated in 3D. For 
more information on rotating 3D objects, see “3D 
Attributes” on page 87.

To set the depth of the chart itself:

1. Select the chart object.

2. Do one of the following:

• Enter a new number in the Z Length value field.

• Click the Z Length slider and drag its thumb to the 
desired setting.

The Z Length sets the length of the z-plane. The 
smaller the value, the less deep the chart and vice versa.

The impact of changing the Z Length may not be 
apparent unless the chart has been rotated in 3D. For 
more information on rotating 3D objects, see “3D 
Attributes” on page 87.

To allow the chart to be rotated in 3D:

Check the Real 3D Projection box.

Real 3D Projection, when checked, results in a chart 
that can be rotated in all 3 dimensions. When not 
checked, the chart has a 3D appearance, but true 3D 
rotation is not possible.

Legends

A Legend is an object that associates the colors used in 
a chart with their labels. Objects created with the 
Legend tool and the three different Chart tools all 
make use of the Chart tab.

The Chart tab is used to specify which chart a legend is 
associated with, the dimensions of the color sample 
associated with each series in the chart, and the format 
of the legend.

Note: until you have associated a legend with a chart using the 
Connected Chart menu (see below), the legend object will be 
blank.

To set the dimensions of the color samples:

Do one of the following:
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• To set the width of the color sample, enter a new 
number in the Width value field.

• To set the height of the color sample, enter a new 
number in the Height value field.

The colors shown in the sample correspond to the 
colors shown in the associated chart. These colors are 
specified in the Curves tab. For more information on 
using the Curves tab, see “The Curves tab” on 
page 105.

To change the font and font attributes for text 
displayed in a legend:

Use the Text tab. For more information on the Text tab, 
see “The Text tab” on page 82.

To set the layout of the legend:

Do one of the following:

• To display the items in the legend in a horizontal 
format that is left justified in the legend bounding 
box, choose Horizontal / Left in the Position 
menu.

• To display the items in the legend in a horizontal 
format that is centered in the legend bounding box, 
choose Horizontal / Center in the Position menu.

• To display the items in the legend in a horizontal 
format that is right justified in the legend bounding 
box, choose Horizontal / Right in the Position 
menu.

• To display the items in the legend in a vertical 
format that is aligned to the top of the legend 
bounding box, choose Vertical / Top in the Position 
menu.

• To display the items in the legend in a vertical 
format that is centered in the legend bounding box, 
choose Vertical / Center in the Position menu.

• To display the items in the legend in a vertical 
format that is aligned to the bottom of the legend 
bounding box, choose Vertical / Bottom in the 
Position menu.

To set the spacing of the items in the legend:

1. Select the chart object.

2. Do one of the following:

• Enter a new number in the Spacing value field.

• Click the Spacing slider and drag its thumb to the 
desired setting.

Spacing is shown in pixels.

To associate the legend with a chart:

Click the Connected Chart menu and select a chart 
from the popup menu.

The Axis tab
The Axis tab is used to specify various aspects of the 
axes shown for certain charts, including the axis colors, 
value ranges and number of ticks.

Several values set in the Axis tab including the number 
of ticks and the value ranges are used by the Labels tab 
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to determine how many and what labels to display. For 
more information on the specifying labels, see “The 
Labels tab” on page 103.

Not all charts require the same axis information, but 
many similarities exist in the types of axis information 
displayed. The information below is grouped by chart 
type. Charts within each group may contain only a 
subset of the information listed.

Single value charts

Single value charts can be customized in the Axis tab 
by setting the range of values displayed and the number 
of ticks shown in the chart.

To set the minimum or base value shown for a chart:

1. Select the chart object.

2. Do one of the following:

• Enter a new number in the Min value field.

• Click the Min slider and drag its thumb to the 
desired setting.

To set the maximum or ceiling value shown for a chart:

1. Select the chart object.

2. Do one of the following:

• Enter a new number in the Max value field.

• Click the Max slider and drag its thumb to the 
desired setting.

To set the number of tick marks displayed on a chart:

1. Select the chart object.

2. Do one of the following:

• Enter a new number in the Number of Ticks value 
field.

• Click the Number of Ticks slider and drag its 
thumb to the desired setting.

Single series charts

Of the single series charts, only the simple bar chart has 
any axis information that can be set (pie charts to not 
have an axis).

To change the minimum value used for a chart:

1. Check the X Min box.

2. Enter a new number in the X Min value field.

To change the maximum value used for a chart:

1. Check the X Max box.

2. Enter a new number in the X Max value field.

Multiple series charts

Multiple series charts, having either 2 or 3 dimensions, 
all have a plethora of axis information that can be set. 
This information includes axis color settings, axis value 
ranges, and tick specifications.

Not all multiple series charts share exactly the same 
information, so not all descriptions provided below 
apply to every chart.

To set the X axis and Y axis colors:

1. Select the chart object.

2. Do one of the following:

• To set the color of the X axis, click on the X Color 
sample or the small triangle adjacent to it to open 
the Color dialog and choose a new color. 

• To set the color of the Y axis, click on the Y Color 
sample or the small triangle adjacent to it to open 
the Color dialog and choose a new color. 

For more information on using the Color dialog, see 
“Using the Color dialog” on page 68.

To display the X axis or Y axis on both sides of the 
chart:
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1. Select the chart object.

2. Do one of the following:

• To display a second X axis on the opposite side of 
the chart, check the Dual X Axis box.

• To display a second Y axis on the opposite side of 
the chart, check the Dual Y Axis box.

To set custom minimum and maximum X and Y axis 
values:

1. Select the chart object.

2. Do one of the following:

• To set a custom X axis minimum value, check the X 
Min box and enter a number in the X Min value 
field.

• To set a custom X axis maximum value, check the X 
Max box and enter a number in the X Max value 
field.

• To set a custom Y axis minimum value, check the Y 
Min box and enter a number in the Y Min value 
field.

• To set a custom Y axis maximum value, check the Y 
Max box and enter a number in the Y Max value 
field.

Note: when the above boxes are not checked, the minimum and 
maximum values are calculated based on the data used to create 
the chart.

To set the point on each axis where it intersects the 
other axes:

1. Select the chart object.

2. Do one of the following:

• To set the point to be used as the origin for the X 
axis, check the X Pos box and enter the value in the 
adjacent X Pos value field.

• To set the point to be used as the origin for the Y 
axis, check the Y Pos box and enter the value in the 
adjacent Y Pos value field.

• To set the point to be used as the origin for the Z 
axis, check the Z Pos box and enter the value in the 
adjacent Z Pos value field.

To specify the number of ticks on the X and Y axes:

1. Select the chart object.

2. Do one of the following:

• To set the number of ticks on the X axis, enter a 
number in the # X Tics value field.

• To set the number of ticks on the Y axis, enter a 
number in the # Y Tics value field.

To set the color of the ticks on the X and Y axes:

1. Select the chart object.

2. Do one of the following:

• To set the color of the ticks on the X axis, click on 
the Color sample below the # X Ticks value field or 
the small triangle adjacent to it to open the Color 
dialog and choose a new color. 

• To set the color of the ticks on the Y axis, click on 
the Color sample below the # Y Ticks value field or 
the small triangle adjacent to it to open the Color 
dialog and choose a new color. 

For more information on using the Color dialog, see 
“Using the Color dialog” on page 68.
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The Labels tab
The Labels tab is used to set the labels that appear 
along each axis or adjacent to the curves in a chart. 

The contents of the Labels tab vary slightly depending 
on the type of chart selected. In general, the more 
complex the chart, the more label options there are 
available. 

The location and function of the labels themselves also 
differ by chart type:

• For single value charts, the labels are associated 
with the background of the speedometer or linear 
meter.

• For single series charts, a label is associated with 
each item in the series.

• For multiple series charts, the labels are associated 
with one of the variables such as the x-coordinate 
or y-coordinate.

The Labels tab works very closely with the Axis tab and 
the Curves tab. In particular, the Number of Ticks 
specified in the Axis tab determines the number of 
labels shown, and the Name specified in the Curves tab 
is shown when the label type is set to Labels. For more 
information on setting the number of ticks, see “The 

Axis tab” on page 100. For more information on setting 
curve names, see “The Curves tab” on page 105.

Similarly, the font and related information displayed by 
the labels is set in the Text tab. For more information 
on setting font information, see “The Text tab” on 
page 82.

All of the possible Labels tab options are described 
below, though not all apply in every situation.

To set the type of label shown for a chart:

1. Select the chart object.

2. In the Type menu, select one of the following:

• To hide all labels, select None.

• To display the name of each curve as specified in 
the Curves tab, select Labels.

• To display the values used in plotting the curves, 
select Values.

To prepend one or more characters to a value label:

1. Select the chart object.

2. Enter the characters into the Prepended Characters 
text field (i.e. “$”).

The Prepended Characters field is only enabled when 
the label Type is set to Values.

To set the number of digits that appear in every value 
label:

1. Select the chart object.

2. Enter a number into the Digits After Decimal 
value field.

The Digits After Decimal field is only enabled when 
the label Type is set to Values.

To Append one or more characters to a label:

1. Select the chart object.
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2. Enter the characters into the Appended Characters 
text field (i.e. “kg”).

The Appended Characters field is only enabled when 
the label Type is set to Values.

To specify where the labels should appear in a simple 
bar chart:

1. Select the chart object.

2. In the Layout menu, select one of the following:

• For labels that appear above the bars in the chart, 
select Top in the Layout menu.

• For labels that appear inside the bars in the chart, 
select Inside in the Layout menu.

• For labels that appear below the bars in the chart, 
select Bottom in the Layout menu.

The Layout menu is only enabled when Type is set to 
Values.

The Walls tab
The Walls tab is used to set the look of the planes 
extending along each axis for multiple series charts 
(single value and single series charts have no walls). 

Walls can be used to clarify the values displayed in a 
chart or even jazz up the look of a chart by 
incorporating interesting gradients and patterns into 
the chart. By default, no walls are displayed.

The contents of the Walls tab vary slightly depending 
on the type of chart selected. All of the possible options 
are described below, though not all apply in every 
situation.

To display the horizontal and vertical background 
lines for a chart:

1. Select the chart object.

2. Do one of the following:

• To show the horizontal background lines, check 
the Horiz box.

• To show the vertical background lines, check the 
Vert box.

The number of horizontal and vertical background 
lines is determined by the number of ticks as specified 
in the Axis tab. For more information on setting the 
number of ticks, see “The Axis tab” on page 100.

To set the color of the horizontal and vertical 
background lines for a chart:

1. Select the chart object.

2. Do one of the following:

• To set the color of the horizontal background lines, 
click on the Horiz color sample or the small 
triangle adjacent to it to open the Color dialog and 
choose a new color. 

• To set the color of the vertical background lines, 
click on the Vert color sample or the small triangle 
adjacent to it to open the Color dialog and choose 
a new color. 



105Beatware Mobile Designer
User Guide
The color of the background lines can only be changed 
when their adjacent boxes have been checked.

To set the dash pattern for the horizontal and vertical 
background lines for a chart:

1. Select the chart object.

2. Do one of the following:

• To set the dash pattern for horizontal background 
lines, choose a pattern from the Horiz menu.

• To set the dash pattern for vertical background 
lines, choose a pattern from the Vert menu.

The pattern of the background lines can only be 
changed when their associated boxes have been 
checked.

To display background planes for a chart:

1. Select the chart object.

2. Do one of the following:

• To show the background planes, check the Primary 
box.

• To show the rear background plane with an 
alternating pattern, check the Alt box.

To set the color of the primary and alternating 
background planes for a chart:

1. Select the chart object.

2. Do one of the following:

• To set the color of the primary background planes, 
click on the Primary color sample or the small 
triangle adjacent to it to open the Color dialog and 
choose a new color. 

• To set the color of the alternating background 
plane, click on the Alt color sample or the small 
triangle adjacent to it to open the Color dialog and 
choose a new color. 

The color of the background planes can only be 
changed when their adjacent boxes have been checked. 
Besides solid colors, you can also assign gradients and 
patterns to the background in the color dialog.

To set the rear background plane to have a vertical 
orientation:

1. Select the chart object.

2. Check the Vertical box below the Alt box.

The orientation of the alternating background plane 
can only be changed when the Alt box is checked.

To set the depth of the background planes on a chart:

1. Select the chart object.

2. Do one of the following:

• Enter a new number in the Thickness value field.

• Click the Thickness slider and drag its thumb to 
the desired setting.

To set the color of the bottom plane of a chart:

1. Select the chart object.

2. Do one of the following:

• Click on the Base Color sample to it to open the 
Color dialog and choose a new color. 

• Click on the small triangle adjacent to the Base 
Color sample to it to open the Color dialog and 
choose a new color.

The Curves tab
The Curves tab is used to set the look of the lines, 
curves, bars and areas used to display chart data. Using 
the Curves tab, you can change the colors and 
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appearance of the data in your charts, and in certain 
cases, highlight particular information.

The word “curve” has a different meaning for each type 
of chart. 

• For single value charts, a “curve” is a single 
background wedge or bar. 

• For single series charts, a curve is a single wedge in 
the pie or a bar in the chart. 

• For multiple series charts, a curve is one data series.

The contents of the Curves tab varies slightly 
depending on the type of chart selected. All of the 
possible options are described below, though not all 
apply in every situation.

To add a curve to a chart:

1. Select the chart object.

2. Click the Add Curve button.

To delete a curve from a chart:

1. Select the chart object.

2. Select the curve in the Curves list.

3. Click the Delete Curve button.

To rename a curve in a chart:

1. Select the chart object.

2. Select the curve in the Curves list.

3. Do one of the following:

• Click the Rename Curve button and type a new 
curve name into the text edit field that appears.

• Click on the curve name and type a new curve 
name into the text edit field that appears.

The name associated with a curve is shown when the 
Type field in the Labels tab is set to Labels. For more 
information on setting label types, see “The Labels tab” 
on page 103.

To change the stroke or fill color for a curve in a chart:

1. Select the chart object.

2. Select the curve in the Curves list.

3. Do one of the following:

• To change the stroke color, click the Stroke color 
sample or the small triangle adjacent to it to open 
the Color dialog and choose a new color.

• To change the fill color, click the Fill color sample 
or the small triangle adjacent to it to open the 
Color dialog and choose a new color.

To change the size of a curve in a single value chart:

1. Select the chart object.

2. Select the curve in the Curves list.

3. Do one of the following:

• Enter a new number in the Value field.

• Click the Value slider and drag its thumb to the 
desired setting.

The relative size of each curve is determined by 
dividing each value into the total of all values.

To separate a wedge in a pie chart from the other 
wedges:
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1. Select the chart object.

2. Select the curve in the Curves list.

3. Do one of the following:

• Enter a new number in the Breakup field.

• Click the Breakup slider and drag its thumb to the 
desired setting.

The breakup field is used to position a single pie wedge 
away from the others. To add a uniform amount of 
space between all wedges, use the Separation field in 
the Chart tab. For more information on setting the 
separation between wedges, see “Pie charts” on 
page 91.

To change the shape of a curve in any bar chart:

1. Select the chart object.

2. Select the curve in the Curves list.

3. Select a shape from the Shape menu. 

To change the width of a curve in a line chart:

1. Select the chart object.

2. Select the curve in the Curves list.

3. Do one of the following:

• Enter a new number in the Width field.

• Click the Width slider and drag its thumb to the 
desired setting.

To change the shape and size of the markers in a line 
chart:

1. Select the chart object.

2. Select the curve in the Curves list.

3. Select a marker type in the Markers menu. The 
default is not to show any markers.

4. Set the market size by doing one of the following:

• Enter a new number in the Marker value field.

• Click the Marker value slider and drag its thumb to 
the desired setting.

Components and XML
Two subsystems in Mobile Designer, components and 
XML data mapping, have tabs in the inspector panels 
but are so powerful that they merit their separate 
chapters in this reference guide.

Components - buttons, menu buttons, animation clips, 
navigation bars and books - are controlled primarily 
through the Component tab, with related memory and 
time saving features available through the Catalog and 
Sharing tabs. Components are described in 
“Components” on page 140.

XML data mapping, that is the mapping of external 
XML data to objects in Mobile Designer, is 
orchestrated through the XML tab. XML data 
mapping is described in “Associating XML data with 
objects” on page 177.
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Creating clean looking content is made easier using 
tools that allow you to precisely align and format the 
objects in your movie. These tools, which include the 
Alignment tab, rulers, grid and guides, provide 
formatting control over everything from a couple of 
objects to your entire movie.

Aligning objects with each 
other
The Alignment tab provides numerous options for 
aligning and formatting objects relative to each other or 
to the canvas itself. 

Each group of alignment options is described below.

Note: the bounding box for each object is actually what is used 
when aligning objects. Some objects such as paragraph text 
don’t always occupy their entire bounding box and may there-
fore appear not to align properly.

Aligning object edges

The buttons in the Align group position the selected 
objects along their left, right, top and bottom edges, 
respectively. 

If you visualize an imaginary rectangle encompassing 
all of the selected objects, the effect of clicking one of 
the align buttons is to align all of the objects on the 
indicated edge of this rectangle. The one exception to 
this is when the To Canvas box is checked. In this case, 
the objects are aligned on the indicated edge of the 
canvas.

Aligning object centers

The buttons in the Center group position the selected 
objects such that their vertical, horizontal, and both 
vertical and horizontal centers are aligned, respectively.

If you visualize an imaginary rectangle encompassing 
all of the selected objects, the effect of clicking one of 
the center buttons is to center all of the objects as 
indicated within the rectangle. The one exception to 
this is when the To Canvas box is checked. In this case, 
the objects are centered as indicated on the canvas.

Enlarging objects

The buttons in the Enlarge group resize the selected 
objects such that each has the same width, height or 
dimensions, respectively.

If you visualize an imaginary rectangle encompassing 
all of the selected objects, the effect of clicking one of 
the enlarge buttons is to resize all of the objects in the 
Chapter 7: Aligning Objects
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indicated dimension to match that of the imaginary 
rectangle. The one exception to this is when the To 
Canvas box is checked. In this case, the objects are 
resized to match the indicated dimension of the canvas.

Packing objects together

The buttons in the Pack group position the selected 
objects such that the objects are placed as close together 
as possible without overlapping each other in the 
horizontal and vertical directions, respectively.

When using the pack buttons, only one dimension is 
modified at a time. For example, when packing objects 
horizontally, their vertical spacing remains unchanged.

The To Canvas box has no effect when using the pack 
buttons.

Distributing objects evenly

The buttons in the Spread group position the selected 
objects such that the horizontal or vertical center (not 
the rotation center) of each object is equidistant from 
the other selected objects. 

The topmost and bottommost (vertical distribution) or 
leftmost and rightmost (horizontal distribution) 
objects determine the end points and are not moved. 
Thus, for the spread buttons to have any effect, three or 
more objects must be selected.

The To Canvas box has no effect when using the spread 
buttons.

Using the Alignment tab

The steps for aligning and formatting objects using the 
Alignment tab are identical no matter which alignment 
option you choose.

To align objects:

1. Select the objects you wish to align or format.

2. (Optional) Check the To Canvas box if you want 
the canvas to be treated like an object in the 
alignment process.

3. Click one of the alignment buttons.

Using Rulers
Rulers provide you with feedback regarding distances, 
in pixels, in the document window. When shown, they 
are displayed along the left and top edges of the 
window.

Usually, rulers are used in conjunction with either the 
grid or guides. See “Using the Grid” on page 113 for 
more information on the grid, and “Using Guides” on 
page 113 for more information on guides. 

By default, the (0,0) point on the ruler corresponds to 
the upper left hand corner of the canvas. The grid is 
drawn starting at this origin point.

To show or hide the rulers:

Choose View > Show Rulers.

To change the origin of the ruler:

1. Position the mouse pointer over the rulers where 
they intersect in the upper left corner of the 
document window.

2. Do one of the following:
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• Click and drag the mouse pointer to the position 
where you want the new origin to be.

• Click and release to restore the origin to the top left 
corner of the canvas.

Using the Grid
The grid is an evenly spaced series of horizontal and 
vertical lines that overlay the canvas. It can be used to 
evenly space and align objects, or when drawing it can 
be used to add a greater degree of precision to your 
shapes. When turned on, it is visible for all scenes in 
the movie.

You have numerous options when using the grid, 
including showing and hiding the grid, separately 
defining the distance between the horizontal and 
vertical grid lines, setting the color of the grid, 
specifying that objects should snap to the grid, and 
setting the origin of the grid.

To show or hide the grid:

Choose View > Show Grid.

To set the distance between grid lines and the color of 
the grid lines:

1. Choose View > Set Grid Options.

2. Set the grid options:

• To set the distance between the horizontal grid 
lines, change the number in the Horizontal text 
field.

• To set the distance between the vertical grid lines, 
change the number in the Vertical text field.

• To set the color of the grid lines, click on the color 
sample and choose a new color in the Color dialog. 
For more information on using the Color dialog, 
see “Selecting and storing solid colors” on page 68.

To snap objects to the grid:

Choose View > Snap to Grid. A check mark appears 
next to the Snap to Grid menu item when snap to grid 
is active.

To change the location of the origin of the grid:

Drag the mouse pointer from the intersection of the 
two rulers to establish a new grid origin. See “Using 
Rulers” on page 112 for more information.

Using Guides
Guides are horizontal or vertical lines that you 
manually position on your canvas. They are valuable for 
positioning objects in exactly the same location across 
multiple scenes and book pages as well as within a given 
scene.
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You have several options when using guides, including 
creating and deleting guides, showing and hiding 
guides, specifying that objects should snap to the 
guides, and locking the guides. You can use as many 
guides as you wish in your movie.

To create a guide:

1. Choose View > Show Rulers (if the rulers are not 
already visible).

2. Do one of the following:

• Position the mouse over the vertical ruler, click and 
drag into the document window to create a vertical 
guide.

• Position the mouse over the horizontal ruler, click 
and drag into the document window to create a 
horizontal guide.

∗The Info tab provides information on the 
current (x,y) mouse coordinates. You can use this 
information to precisely position a guide at a 
specific pixel location.

To lock the guides in place:

Choose View > Lock Guides. A check mark appears 
next to the Lock Guides menu item when guides are 
locked.

To move or delete a guide:

1. Choose View > Lock Guides (if the guides are 
locked).

2. Do one of the following:

• To move a guide, click and drag it to a new location 
in the document window.

• To delete a guide, click and drag it outside the 
bounds of the document window.

To show or hide the guides:

Choose View > Show Guides.

To snap objects to the guides:

Choose View > Snap to Guides. A check mark appears 
next to the Snap to Guides menu item when snap to 
guides is active.
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Mobile Designer provides tremendous flexibility when 
it comes to animation. Virtually every attribute of an 
object can be animated, often in multiple ways. This 
chapter provides an overview of the animation methods 
and techniques available to you in Mobile Designer.

General principles
Animation is simply a change in an object over time. 
Often this means movement (translation) from one 
spot on your canvas to another, but not always. 
Animation can also involve color changes, opacity 
changes, size changes, and so on.

You can animate virtually any object in Mobile 
Designer. For example, primitives, components and 
groups can be animated in scenes. Similarly, animation 
clips and buttons can be built using animated 
primitives. In fact, because primitives can be animated 
in components and components can be animated it 
scenes, it is easy to get multiple levels of animation 
going, each of which might be operating on a different 
timeline.

The Animation panel
The Animation panel is the centralized control area for 
animation. The contents of the Animation panel vary 
depending on what you are working on. When 
working on a scene, the Animation panel displays all of 
the objects in that scene, but not objects in other 

scenes. When working in a component designer, the 
Animation panel displays only those objects that make 
up the current component.

A complete description of the Animation panel is 
provided in “The Animation panel” on page 28. 
However, the most commonly used portions of the 
panel are reviewed here.

The Navigation bar

The Navigation bar is used to select the different scenes 
and components in your movie. When you select a 
scene in the nav bar, the objects in that scene are 
displayed on the canvas and in the objects list (see 
below).

The play controls

The play controls are used to preview the current 
animation. The play controls work just like the controls 
on a VCR.

The frame controls

The frame controls provide you with feedback on 
where you are in the current animation both frame-

Navigation Bar Play Controls Frame Controls

Objects List Frames
Chapter 8: Animation Methods and 
Techniques
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wise and time-wise. The Total field is used to change 
the number of frames in the current animation.

The objects list

The objects list displays all of the objects in the current 
scene or component. You can reorder the objects in the 
list by dragging them. You can also show and hide the 
properties that make up each object.

The frames

The grid that occupies the majority of the Animation 
panel displays all of the frames in your animation. You 
select a particular frame by clicking on its frame 
number. The current frame is highlighted and a bar 
appears above the frame number.

Animating Objects
The process by which you create an animation is the 
same no matter what you are animating. The basic 
steps are as follows:

1. Select the frame number in the Animation panel 
where you want the animation to begin.

2. Establish the look of the object you wish to 
animate. Mobile Designer records the position, 
colors, size and other attributes of your object in 
the starting frame.

3. Select the frame number in the Animation panel 
where you want the animation to end.

4. Change the attributes of your object until the 
object appears as you want it to at the end of the 
animation. Mobile Designer records those 
attributes that have changed in the ending frame.

The frames in which you change the attributes of an 
object are called “key frames.” Visually, a small key icon 

appears in the animation for every object and object 
property that has been changed.

Because Mobile Designer only records properties 
where you set them, you are free to modify the 
attributes in the first or last frames without any concern 
for changing your animation in the in-between frames. 
When you play your animation, these in between 
frames will be computed to produce as smooth an 
animation as possible. This process is called 
“tweening.” 

The real time computation of in between frames is the 
reason that animations played from the Animation 
panel may not run as fast as in the final exported movie.

Animating between points
The most common form of animation takes place 
between two points. In most cases, this simply means 
that an object is moving from one point on (or off) your 
canvas to another. However, it can also mean that, for 
instance, the color or opacity of the object is changing 
over time. Whether there is physical movement or not, 
animating between points is the simplest application of 
the general animation process described above.

Common attributes that are frequently animated 
between points include:

• Position or Translation

• Opacity 

• Size or Scaling

• Stroke Color

• Fill Color

For example, to animate a text object to translate across 
the canvas between frames 1 and 10, you would do the 
following:
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1. Select frame 1 in the Animation panel.

2. Type in some text.

3. Position the text on one side of your canvas.

4. Select frame 10.

5. Reposition the text on the other side of the canvas.

That all there is to it. Click the Play button in the 
Animation panel to view the 10 frame animation (you 
may need to rewind the animation before playing it).

You could further animate the text to translate to the 
top of the canvas between frames 10 and 20 by 
selecting frame 20 and repositioning the text again. If 
you did this, the text would move across the canvas for 
the first half of the animation, then up to the top of the 
canvas in the second half of the animation. By stringing 
together multiple animations between points as 
described here, objects can take on more complex 
paths.

Of course, you are not restricted to animating just one 
attribute of an object at a time. If you wish, you could 
also have the text change color and size as it animates, 
too.

Animating curves
Both Bezier curves and polylines can have their points 
individually animated. When used alone, this 
technique makes the object appear to change or 
“morph” its shape over time. When used in 
combination with other techniques (see “Animating 
text to move along a curve” on page 121 for one 
example), the results can be even more impressive.

To animate one or more points on a curve, first create 
the curve in the starting frame. Then select the ending 
frame, double-click on the curve to enter edit mode (or 
press Enter), and click and drag any of the points. 

Those points that you move between the starting and 
ending frames will be animated.

For example, to create a sad face that morphs into a 
happy face between frames 1 and 25, do the following:

1. Select frame 1.

2. Create a sad face. Be sure to use the Bezier tool 
when drawing the frown.

3. Select frame 25.

4. Double-click on the Bezier (mouth) object to enter 
edit mode.

5. Drag one or more of the points to change the frown 
to a smile.

6. Deselect the Bezier object and press Play.

Because multiple points can be animated in any Bezier 
or polyline object, much more complex changes can be 
created with just a few clicks of your mouse.

Animating text to move along a curve
Text not only can be placed on a curve, it can also be 
animated to slide along a curve. The impact of this can 
be far more eye catching that simply having text move 

Frame 1 Frame 25
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along a straight line or fade in by gradually changing its 
opacity from 0 to 100.

For example, to have a product tag line slide in over a 
company name or logo between frames 15 and 30 in an 
animation as shown above, you would do the following:

1. Select frame 15.

2. Import and position your company logo.

3. Draw an ellipse around the logo. This will become 
the path the text follows.

4. Type text on the ellipse. This is done by clicking on 
the ellipse with the Text on Curve tool and typing 
in the tag line.

5. Double-click on the text to enter text edit mode, 
then press the Alt key and drag the text to its 
starting position.

6. Select frame 30.

7. Repeat step 5 above, this time dragging the text to 
its ending position.

8. Deselect the text and click Play.

Text can be placed upon and slide along the following 
objects:

• Beziers

• Lines

• Polylines

• Rectangles

• Rounded rectangles

• Ellipses

Animating filters and effects
Filters and special effects are treated like any other 
property when it comes to animation. You can have one 
or more filters that animate during an animation, 
creating virtually endless combinations of looks that 
become clear or drift away throughout the course of an 
animation. Likewise, special effects can be animated to 
create growing shadows or shrinking glows.

For example, to have the sun pass over a text object and 
cast a shadow that animates in coordination with the 
movement of the sun, do the following:

1. Create and animate an orange ellipse (the sun) that 
follows a path across the top of your movie. For a 
primer on how to do this, see “Animating between 
points” on page 120.

2. Add and position some text beneath the sun.

3. In the first frame of the animation, add an Outer 
Shadow to the text that appears opposite the ellipse 
using the Offset X and Offset Y values in the Outer 
Shadow dialog. For more information on working 
with effects, see “The Effects tab” on page 80.

4. In the middle frame of the animation when the 
ellipse is directly above the text, edit the outer 
shadow created in the previous step by changing 
the Offset X and Offset Y values so the shadow 
goes straight down.
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5. In the last frame of the animation, edit the outer 
shadow again such that the shadow is cast away 
from the ellipse. When you play the animation, the 
shadow will change in each frame as the sun passes 
overhead. 

Filters are animated in exactly the same way. For 
example, you can animate the amplitude, phase, and 
orientation properties of a wave filter that has been 
applied to an object.

Certain filters produce more striking results than 
others when animated. Some of the most popular 
filters to animate include blur, rotate zoom, vortex, and 
wave. For more information on working with Filters, 
see “The Filters tab” on page 80.

Animating 3D objects
When rotating 3D objects, you may get unexpected 
results if you rotate different axes in different frames. 
The following example illustrates the potential 
problem. (There is no need to repeat these steps 
yourself).

1. Create a 7 frame animation.

2. In frame 1, use the 3D Text tool and type “3D.” By 
default, its Rx, Ry and Rz rotation values are all set 
to 0 in the 3D tab. For more information on using 
the 3D tab, see “3D Attributes” on page 87.

3. In frame 4, set the Rz value to 90. The text now 
appears rotated 90 degrees counterclockwise.

4. In frame 7, set the Ry value to 90. The text is now 
head on and barely visible.

5. Return to frame 4. Notice that the text now appears 
at an entirely different angle than it did in step 3.

Why did this happen? The Rz value is being animated 
between frames 1 and 4, while the Ry value is being 
animated between frames 1 and 7. Thus, after the last 
step, frame 4 has the Ry rotation as 45, halfway to its 
final value of 90.

If you wanted the text to rotate to the position seen in 
step 3, then to the position in step 4, you would need to 
manually add a key for the Ry property in frame 4. 
Manually adding keys is discussed in “Property 
manipulation” on page 127.

The different levels of 
animation
One of the strengths of Mobile Designer is the very 
fine level of control that you have when creating and 
manipulating objects. While most creative and even 
detailed work usually takes place on the canvas at the 
object level as described in the previous section, there 
may be times when it becomes necessary to make more 
refined changes or more global changes to your 
animation.

Step 2 Step 3

Step 4 Step 5
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Through the Animation panel and the Animation 
menu, you have control at the frame level (i.e. multiple 
frames are manipulated at once), the object level, and 
the property level. At all of these levels, the basic 
premise is the same. You are adding, deleting or 
moving keys to change the behavior of your animation.

Each level of manipulation has specific uses, as 
explained below.

Frame level manipulation
Frame or animation level manipulation is generally 
used to increase or decrease the overall length of a 
portion or all of an animation. For example, if part of 
your animation is a little too “jumpy,” one possible 
solution is to add frames between the two key frames 
that define the jumpy region. Similarly, you may find 
that the export size of your animation is too large. In 
this case, the best alternative may be to delete frames 
from your animation.

Manually adding and deleting frames

Besides modifying the Total frames field which adds or 
removes frames from the end of an animation, you can 
also manually add frames and delete frames from the 
middle of an animation.

To manually insert a frame into an animation:

1. Select the frame where you want to add a frame to 
your animation.

2. Choose Animation > Insert Frame from the main 
menu.

The frame you add is placed before the selected frame.

To manually delete one or more frames from an 
animation:

1. Do one of the following:

• To select one frame, click on it.

• To select multiple frames, click on the first frame, 
then press Shift and click on the last frame in the 
range you want to delete.

2. Choose Animation > Delete Frames in the main 
menu.

Using the Animation Wizard

For more extensive changes to part or all of an 
animation, the easiest solution is to use the Animation 
Wizard. The Animation Wizard is a powerful built-in 
tool for adding and deleting frames as well as resizing 
the overall length of an animation.

To resize the overall length of an animation:

1. Click on the Animation Wizard button to open the 
Animation Wizard.

2. Select the Resize Animation Length radio button.

3. Click the Next button.

4. Type the number of frames you wish to have in 
your animation in the To section (the From section 
shows your current animation length).

5. Select one of the following radio buttons to 
determine how overlapping keys are handled 
(applies to animations that are reduced in length):

• Compute average length determines the averages 
for properties (i.e. fill color) that must be merged 
due to resizing the animation.
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• Use minimum value uses the smallest value for 
properties that must be merged due to resizing the 
animation.

• Use maximum value uses the largest value for 
properties that must be merged due to resizing the 
animation.

6. Press the Finish button.

To insert frames into an animation:

1. Click on the Animation Wizard button to open the 
Animation Wizard.

2. Select the Insert Frames radio button.

3. Click the Next button.

4. In the Parameters section, do the following:

• Type in the number frames that you wish to insert 
in the first value field.

• Select where you wish to insert the frames in the 
drop down menu.

• Type in the number of where you want to insert the 
new frames in the second value field.

5. Press the Finish button.

To delete frames from an animation:

1. Click on the Animation Wizard button to open the 
Animation Wizard.

2. Select the Delete Frames radio button.

3. Click the Next button.

4. In the Parameters section, type in the frames that 
you wish to delete.

5. Press the Finish button.

Adding keys to a frame

The last frame manipulation option available is to add 
keys to every property in every object in the selected 

frame. This is useful if you needed to guarantee that 
every element in your animation looks exactly as it does 
at that moment no matter what other changes you 
make in other frames.

To add keys to all of the objects in one or more frames:

1. Do one of the following:

• To select one frame, click on it.

• To select multiple frames, click on the first frame, 
then press Shift and click on the last frame in the 
range.

2. Choose Animation > Add Keys to Frames in the 
main menu.

Object level manipulation
Object level manipulation allows you to operate on 
individual objects in ways that parallel how you use 
frame level manipulation to operation on an entire 
animation. Using object level manipulation you can 
resize and move the animation of an object, add keys to 
every property of an object, and move all of the keys for 
an object from one frame to another.

Resizing the animation of an object

Animation is a change in an object’s appearance over 
time. In the Animation panel, animated objects have 
keys on each of their keyframes, and animation range 
handles before the first object key and after the last 
object key. The animation range handles provide not 
only a visual indicator of the total length or range of the 
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animation, but also a way to resize the animation for 
the object. 

To resize an object’s animation:

Do one of the following:

• To resize an object’s animation starting from the 
first animated frame, click on the left range handle 
and drag it to a new frame.

• To resize an object’s animation starting from the 
last animated frame, click on the right range handle 
and drag it to a new frame.

Mobile Designer automatically adjusts any keys to 
keep the animation events proportional to the original 
animation.

For example, if you have an object whose opacity 
changes from 0 to 100 and back to 0 in frames 1, 5 and 
9, respectively, and you realize that the object would 
look better animating over 15 frames, you can drag the 
right animation range handle from frame 9 to frame 
15. The intermediate key in frame 5 is automatically 
moved to frame 8 in order to keep the animation even.

Moving the animation of an object

You can change the frame at which an animation starts 
without impacting the running time for the animation 
or the relative key placement. This is valuable when you 
realize that one object’s animation doesn’t look right in 
relation to other animated objects.

To shift an object so its animations starts in a different 
frame:

Click between any of the keys (but not on a key) for the 
object in the Animation panel and drag the animation 
to a new starting frame.

Adding keys to an object

An alternative to adding keys to every object in a 
particular frame is to only record the properties of a 
single object. This limits the impact of adding keys to 
only the specified object and therefore does not risk 
locking in the look of other tweened objects that you 
may want to change later.

To add keys to an object in a particular frame:

Right-click at the intersection of the object and frame 
number where you want to add the keys and choose Fix 
Object Properties from the popup menu.

Moving all of the keys for an object

At some point, you may realize that the object 
properties you carefully set in one frame would be 
much better in a different frame. Instead of deleting 
the keys in the current frame and recreating everything 
in a different frame, it is much easier to simply move 
the frames.

To move all of an object’s keys from one frame to 
another:

Click at the intersection of the object name and the 
current keyframe and drag the key to the desired frame.

When you click on the object key, it turns red to 
indicate that it is selected (as will all of the property 
keys for the object if they are visible.

Left Range Handle
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Property manipulation
Property manipulation provides the finest level of 
control over objects in your animation. By 
manipulating individual object properties you can 
change how individual aspects of a given object appear 
and animate.

Every object has a specific set of properties - those 
attributes that when taken together determine the look 
of the object. Some common properties include 
translation, rotation angle, scaling, opacity, stroke color 
and fill color. 

Property manipulation is primarily used to fine tune 
the look and feel of an animation. This is usually 
accomplished by moving individual property keys from 
one frame to another or adding and deleting individual 
property keys.

Displaying property keys

Because every object has numerous property keys, in 
the interest of saving space they are hidden by default 
in the Animation panel. They are always available if 
you need them though.

To display the property keys for an object:

Click the Show/Hide Properties button in the 
Animation panel object list. 

Moving property keys

You can move individual property keys just like you can 
move object keys. However, when you move individual 
property keys, only the indicated property is changed; 
the other properties in the object are not impacted.

For example, you may have an existing animation 
consisting of some text which moves (the translation 
property) from the top of the canvas to the bottom over 
the first 10 frames, then fades away (the opacity 

property) from frame 10 to frame 20. If you want to 
overlap the fade with the movement, you can simply 
drag the opacity key from frame 10 to an earlier frame.

The same principle applies for any property that you 
want to manipulate.

To move a property key:

1. Select an object in the Animation panel and display 
its property keys.

2. Click on the key at the intersection of the property 
name and the frame you wish to move and drag the 
key to the desired frame.

When you click on a property key, it will turn red to 
indicate that it is selected

Creating and deleting property keys

You can both add and delete individual property keys to 
either record the state of a property in the current frame 
or remove a property that was previously recorded 
either manually or automatically.

Original animation

Animation with shifted opacity key (in red)
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For example, during the design of an animation you 
might decide you want to lock in a particular fill color 
for an object in frame 10. To do this you add a key to 
the fill color property of the object in frame 10. Later, 
you decide that the tweening doesn’t look right with 
this property key in place and you decide to eliminate 
it. To do this, you delete the fill color property key in 
frame 10.

To add a property key:

1. Select an object in the Animation panel and display 
its property keys.

2. Click the Add Key button in the Animation panel.

3. Do one of the following:

• To add a single property key, click at the 
intersection of the property and frame number in 
the Animation panel.

• To add multiple property keys, press the Shift key 
and click at the intersection of the property and 
frame number in the Animation panel for every 
property you wish to enter.

To delete a property key:

1. Select an object in the Animation panel and display 
its property keys.

2. Click on the property you wish to delete.

3. Press the Delete button in the animation panel.

Note: because every property for every object must have at least 
one key, attempting to delete the last remaining key for a given 
property will fail with an error message.

Non-linear animation
Translated objects, when selected, display a blue line 
showing the path of the object. On that blue line, little 

dots (the reference points) show where the object will 
be drawn in each frame. 

By default, when Mobile Designer tweens an attribute, 
the attribute changes are computed to produce an even 
(linear) change across those frames. This is most 
evident when viewing translations. 

There are times, however, when a non-linear change is 
desired. A classic example of this is when you are trying 
to include an acceleration such as gravity in your 
animation. Because such calculations can be complex 
when done by hand, Mobile Designer includes a built-
in Tweening Wizard to automate this and other similar 
effects.

The Tweening Wizard

The Tweening Wizard is a powerful computational 
engine that makes it easy to add complex motion to 
your animated objects. Using the Tweening Wizard, 
you can change both the motion (i.e. linear vs. 
acceleration) and the path (i.e. straight line vs. curve) 
that the object follows. 

To open the Tweening Wizard:

Click the Tweening Wizard button or the adjacent 
property name for any animated property in the 
Animation panel.

The Tweening Wizard dialog

The Tweening Wizard dialog includes mechanisms for 
selecting different animation segments, and for each 
segment, changing the animation settings, the motion 
and the path of the selected property.
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To change the current animation segment of a 
property in the Tweening Wizard:

1. Open the Tweening Wizard for the property.

2. Do one of the following:

• To switch to the previous animation segment, click 
the Previous Selection button.

• To switch to the next animation segment, click the 
Next Selection button.

A property with N keys will have N-1 animation 
segments. For example, if a rectangle translates to the 
top of the canvas in frames 1-5 (one animation 
segment), then translates to the bottom of the canvas in 
frames 5-12 (another animation segment), there will be 
keys in frames 1, 5 and 12.

To change the animation settings for an object 
property:

1. Open the Tweening Wizard for the property and 
select the desired animation segment.

2. Edit the contents of the Animated Settings section.

The animation settings vary by property type. If you are 
animating fill color, for example, the animation settings 
section will contain editable color samples for the 
beginning and ending colors for the current animation 
segment. If you are animating translation, the 
animation settings section contains the starting and 
ending coordinates for the current animation segment.

To change the motion of an object property:

1. Open the Tweening Wizard for the property and 
select the desired animation segment.

Previous Selection Next Selection
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2. Choose one of the following from the Motion 
menu:

• Constant, the default, results in a linear motion (i.e. 
equidistant spacing) between the beginning and 
ending points in the animation segment. 

• Accelerating results in either an increasing or 
decreasing motion between frames in the 
animation segment. The precise acceleration is 
controlled through the Acceleration value field. 
Positive values produce accelerations and negative 
values decelerations.

• Oscillating results in a motion that “bounces” back 
and forth between the beginning and ending points 
in the animation segment. The precise oscillation is 
controlled by setting the Period count, Attenuation 
and Amplitude value fields.

• Overshoot results in a motion that “bounces” 
around the ending point in the animation segment. 
The precise overshoot is controlled by setting the 
Period count, Attenuation, Amplitude and Speed 
value fields.

To change the path of an object property:

1. Open the Tweening Wizard for the property and 
select the desired animation segment.

2. Choose one of the following from the Path menu:

• Linear, the default, results in a linear path (i.e. 
straight line) between the beginning and ending 
points in the animation segment. 

• Curving results in a path that takes on a rotation in 
a spiral shape. The precise path is determined by 
the Curve value and whether you designate the 
starting or ending key frame as the rotation center.

• Wave results in a path that follows a sine wave 
pattern. The precise path is determined by the 
Period count, Attenuation and Amplitude, and 
whether you start the path in an upward or 
downward direction.

• Circle results in a path that traces half (180 
degrees) of a circle. The clockwise vs. 
counterclockwise rotation is determined by the 
Invert setting.

Not all properties have Motion and Path options. 
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Movies, scenes and components are all higher level 
constructs in Mobile Designer. As such, they are much 
more powerful and versatile than simple primitives. 
Using the various properties of movies, scenes and 
components, you can control everything from the 
frame rate of your movie to what action or actions take 
place when an animation ends or a button is clicked.

In this chapter, you learn how to work with movies, 
scenes and all of the components.

Overview
Mobile Designer documents are called movies. A 
movie is what you create through the Movie Creator 
dialog and what you save at the end of your design 
session. 

In general, when you see the term “movie” it refers to a 
Mobile Designer movie (i.e. the file you create in 
Mobile Designer). This is different from the file 
exported by Mobile Designer, the SVG movie.

Movies contain one or more scenes. A scene is akin to 
a web page. When you export and view your SVG 
Movie, you view it one scene at a time.

Scenes can contain both primitives and components; 
everything you need to create rich, interactive mobile 
content. Primitives (basic shapes) are described 
extensively in the early chapters of this reference guide. 
Components are described later in this chapter.

A sample hierarchy is shown below.

Movies
Those Mobile Designer actions and properties that 
apply across all scenes are controlled at the movie level. 
Many of these, including the frame rate, the canvas 
dimensions and the canvas background color, impact 
both the design and exported version of your movie. 
Other settings, such as to the magnification level with 
which you view the canvas, only influence what you see 
at design time.

All movie level actions and properties are discussed in 
this section.

Setting and changing movie properties
Besides choosing a file name, the very first thing you do 
when creating a new movie is to establish your initial 
movie properties. This is done in the Movie Creator 
dialog. 

The choices you make in the Movie Creator dialog 
determine the initial look of each and every scene you 
create. While this information can be changed later, it 
Chapter 9: Movies, Scenes and 
Components
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is often easier to invest a few seconds up front getting 
everything set up correctly rather than making the 
changes after you create your movie.

The Movie Creator dialog

The Movie Creator dialog is used to establish the 
initial file name, canvas dimensions, background color 
and profile. All of these items can be edit to meet your 
design needs.

The Movie Creator dialog is opened when you first 
launch Mobile Designer or when you choose File > 
New.

To name your new movie:

Type a new name into the Name field.

To set the canvas (movie) dimensions:

Do one of the following:

• To use an existing device template, choose a 
template from the Canvas Size menu. A list of 
popular templates is provided. Each template 
definition include both the dimensions of the 
canvas and its background color.

• To set a specific canvas width or height, type a 
number into the Width and Height value fields.

To set the background color for the movie:

Click on the Background Color sample or the small 
triangle adjacent to it to open the Color dialog where 
you can select a new background color.

To choose a target profile:

Choose a profile from the Profile menu. For more 
information on profiles and how to use them, see 
“About Profiles” on page 55.

To create a new movie template:

1. Click the New Template button.

2. In the New Template dialog, do the following:

• Type a name for the template in the Name field.

• Enter the width and height of the template by 
typing a number into the Width and Height value 
fields or by clicking on the associated spin controls.

• Click on the Background color sample or the small 
triangle adjacent to it to open the Color dialog 
where you can select a new background color.

3. In the New Template dialog, click Create.

Your new template is appended to the Canvas Size 
menu and selected automatically.

To edit an existing movie template:

1. Select a template in the Canvas Size menu.

2. Click the Edit Template button.

3. In the Edit Template dialog, do the following:

• Edit the name of the template in the Name field.

• Enter the new width or height for the template by 
typing a number into the Width or Height value 
field or by clicking on the associated spin controls.

• Click on the Background color sample or the small 
triangle adjacent to it to open the Color dialog 
where you can select a new background color.

4. In the Edit Template dialog, click Change.

To delete an existing movie template:

1. Select a template in the Canvas Size menu.

2. Click the Delete Template button.

To restore the list of templates to its default state:

Click the Default Settings button.
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This button removes all custom templates and restores 
modified templates to their original states.

The Movie Properties dialog

The Movie Properties dialog is used to change the 
properties of an existing movie as well as to enable 
certain movie level JavaScript functions. JavaScript 
support is described in the next section.

Changes you make in the Movie Properties dialog are 
applied when you click OK to close the dialog.

To open the Movie Properties dialog:

Choose Movie > Movie Properties.

To change the dimensions of the canvas:

1. Do the following:

• To change the width of the canvas, enter a new 
number in the Width value field.

• To change the height of the canvas, enter a new 
number in the Height value field.

2. Select how you want the changes to the canvas size 
to be applied, as follows:

• To have the changes applied symmetrically to the 
canvas, click the Center button. This is the default.

• To have the changes applied at one of the four 
corners of the canvas, click the appropriate corner 
button.

• To have changes applied at one edge of the canvas, 
click the appropriate edge button.

In the canvas preview, the new canvas is shown in blue 
and the current canvas is shown as a black rectangle 
with a white fill.

To change the frame rate used throughout the movie:

Do one of the following:

• Enter a new number into the Frame Rate value 
field.

• Click on the Frame Rate slider and drag it to a new 
position.

The frame rate is given in frames per second (fps). The 
default frame rate is 20 fps.

To change the movie background color:

Click on the Default Background Color sample or the 
small triangle adjacent to it to open the Color dialog 
where you can select a new background color.

To override any scene background colors with the 
movie background color:
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Check the Reset All Scenes box.

About JavaScript

Mobile Designer allows you to call JavaScript functions 
at the movie level as well as at the component action 
level. For more information on using JavaScript at the 
component action level, see “Component Level” on 
page 206.

At the movie level, you can define functions to handle 
Onload and Onkeypress events. You create and specify 
these through the Movie Properties dialog.

To create or edit Onload and Onkeypress JavaScript 
functions:

1. Click the Edit button in the Movie Properties 
dialog to open the JavaScript function editor 
(Notepad).

2. Add or edit the JavaScript functions.

3. Save your changes and close the editor.

4. Click the Reload button in the Movie Properties 
dialog.

The JavaScript functions that you define are stored 
inside your Mobile Designer save file. Thus, if you 
transfer your file to a different machine, you do not 
need to worry about separately moving the JavaScript 
file. 

If you wish to use existing JavaScript functions or your 
own JavaScript editor, you will have to copy and paste 
the JavaScript code into the editor opened by Mobile 
Designer.

To select the Onload function to use:

Choose the function from the Onload Function menu.

Note: when you edit a function, you must press the Reload but-
ton before your changes are available.

To specify parameters to pass to the Onload function:

Type the parameters into the Onload Parameters field.

For an in depth discussion of how to pass parameters to 
JavaScript functions, see “Component Level” on 
page 206.

To select the Onkeypress function to use:

Choose the function from the Onkeypress Function 
menu.

Note: when you edit a function, you must press the Reload but-
ton before your changes are available.

To specify any parameters to pass to the Onkeypress 
function:

Type the parameters into the Onload Parameters field.

For an in depth discussion of how to pass parameters to 
JavaScript functions, see “Component Level” on 
page 206.

Changing the size of the canvas
In addition to setting the canvas size at movie creation 
time and through the Movie Properties dialog, you can 
also change it to match the size of objects and 
selections as well as by adjusting the limits. As with the 
other methods, any changes you make to the canvas 
size using these methods are applied across all scenes in 
the movie.

Cropping to objects

Objects themselves can be used to define a new canvas 
size. This is especially valuable when, for example, you 
draw a shape or import an image and want to create a 
canvas of that size.
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To change the canvas size to match a rectangle that 
encompasses the selected objects:

1. Select one or more objects.

2. Select Movie > Crop Movie to Object Selection.

Cropping to selections

Selection areas can be used to define a new canvas size. 
This is useful when you want resize the canvas to a 
particular area you define by clicking and dragging with 
one of the area selection tools.

To change the canvas size to match a rectangle that 
encompasses the selection area:

1. Create a selection area using one of the area 
selection tools. For more information on the 
selection tools, see “Selection tools” on page 24.

2. Select Movie > Crop Movie to Selection.

Changing Limits

The limits define the boundaries of the canvas and 
provide a visual cue for aligning objects along a 
particular canvas edge when working in the overscan 
area. 

Limits also can be dragged offering an interactive way 
of resizing the canvas.

To resize the canvas by dragging the limits:

1. Unlock the limits (if locked) by choosing View > 
Lock Limits.

2. Click on one of the limits and drag it to resize the 
canvas.

It is recommended that you repeat the first step above 
to lock the limits after adjusting them. When the limits 
are unlocked, it is easy to drag them by mistake.

To show or hide the limits:

Choose View > Show Limits.

Changing the view of the canvas
Changes in the way that you view the canvas such as 
magnifying and scrolling do not appear in the exported 
SVG file, but do get applied across the entire movie.

Magnifying

By default, the canvas and overscan area are displayed 
at 100%, or normal, magnification. At times, you may 
want to increase the magnification to focus on a 
particular object, or decrease the magnification to see 
more of your movie.

Mobile Designer comes with 10 preset magnification 
levels to choose from. Levels greater than 100% zoom 
in on the canvas. Levels less than 100% zoom out. The 
preset levels are:

• 25%
• 33%
• 50%
• 75%
• 100% (default)
• 150%
• 200%
• 400%
• 800%
• 1600%

To increase the magnification to the next higher level:

Do one of the following:

• Click on the Zoom tool in the Toolbox then click 
on the canvas.

• Click the Zoom In tool at the bottom of the 
document window.
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• Choose View > Zoom In from the main menu.

To decrease the magnification to the next lower level:

Do one of the following:

• Click on the Zoom tool in the Toolbox then hold 
down the Alt key and click on the canvas.

• Click the Zoom Out tool at the bottom of the 
document window.

• Choose View > Zoom Out in the main menu.

To select a particular magnification level:

Do one of the following:

• Choose a new magnification level in the Zoom 
menu at the bottom of the document window.

• Choose View > Zoom in the main menu and 
choose a new magnification level in the Zoom 
submenu.

Panning

In addition to scrolling the document window, you can 
also position it using the Pan tool.

To use the Pan tool to position the canvas:

1. Click on the Pan tool in the Toolbox.

2. Click and drag in the document window.

Showing and hiding objects in the overscan area

The overscan area, that part of the document window 
that falls outside of the canvas, is a perfectly valid 
drawing area. Its best use though is probably as a 
staging area for objects about to move onto or off of the 
canvas.

By default, objects on both the canvas and the overscan 
area are visible. You can hide the contents of the 
overscan area at any time and just view objects on the 
canvas.

To show and hide objects in the overscan area:

Click the Show/Hide Objects in the Overscan Area 
button at the bottom of the document window.

Rulers, Guides and the Grid

The built in alignment features in Mobile Designer are 
turned on and off at the movie level. Specifically, rulers, 
guides and the grid are movie level controls used to 
precisely position objects on the canvas.

Rulers, guides and the grid are described in “Aligning 
Objects” on page 111.

Scenes
A movie is composed of one or more scenes, only one 
of which is visible at any given time. All of the work 
that you do in Mobile Designer takes place in a scene or 
one of the objects in it.

A scene is roughly equivalent to a web page on the 
internet. It is within your scenes that you add 
primitives and components to create a unique and 
engaging user experience.

Setting and changing scene properties
A scene is essentially a container for all of the 
primitives and components that make up your movie. 

Most of the time, you may think of a scene as a place to 
draw, but a scene does have several unique 
characteristics that you can leverage in your designs. 

For example, you can animate objects on a scene, not 
just within components. In addition, changing scenes 
provides one of the most important means of switching 
the content displayed on the screen.
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To create a new scene:

Do one of the following:

• Choose Scene > Insert Scene from the main menu.

• Right-click on the document window and choose 
Insert > Scene.

To delete a scene:

Choose Scene > Remove Scene from the main menu.

Every movie must have at least one scene, hence you 
cannot delete the last scene in your movie.

To change the name of a scene:

1. Do one of the following:

• Choose Scene > Scene Properties from the main 
menu.

• Right-click on the document window and choose 
Scene Properties.

2. In the Scene Properties dialog, type a new name 
into the Scene Name text field and click OK.

As with components, the scene name appears in the 
Navigation menu and the Locator bar.

To change the background color of a scene:

1. Do one of the following:

• Choose Scene > Scene Properties from the main 
menu.

• Right-click on the document window and choose 
Scene Properties.

2. In the Scene Properties dialog, click on the 
Background Color sample or the triangle adjacent 
to it and choose a new color in the Color dialog. 
For more information on choosing colors, see 
“Using the Color dialog” on page 68.

The scene background color overrides the movie 
background color. Changing the scene background 
color only affects the current scene.

To stop all sounds when you first enter a scene:

1. Do one of the following:

• Choose Scene > Scene Properties from the main 
menu.

• Right-click on the document window and choose 
Scene Properties.

2. In the Scene Properties dialog, check the Stop 
sounds at the beginning of the scene box and click 
OK.

By default, any sounds that you play continue until they 
finish (if not looped), you manually stop them, or the 
user leaves the SVG movie.

To set the current scene as the first scene:

Choose Scene > Set the current scene as the first scene.

The first scene is the one that is played when you first 
start an SVG movie. 

Creating an animating objects on scenes
With the exception of books (which can contain other 
components), you draw all of the primitives and 
components in your movie on the current scene. In fact, 
unless you enter one of the component designers (see 
“Components” on page 140 for more information), you 
are always working directly on a scene (or at the “scene 
level”). 

You can draw or create any type of object supported in 
Mobile Designer on a scene. This includes not only 
primitives, but also every type of component. You can 
also drop sounds onto a scene and play them there.
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In addition, you can animate any object you draw on 
the scene. However, you cannot loop any scene level 
animations you create. Thus, when you first enter a 
scene, it will play the scene level animation once and 
when it reaches the final frame it will wait for the user 
to take action.

To create an object on a scene:

Draw it! For more information on drawing primitives 
and components, see “Working with Objects” on 
page 37.

To add a sound to a scene:

Drag and drop the sound onto the canvas.

The sound will appear at the top of the list of objects in 
the Animation panel. The frame where it starts playing 
can by changed by dragging the sound wave left or 
right in the Animation panel.

To animate an object on a scene:

1. If necessary, add frames to the scene in the 
Animation panel by changing the Total field and 
pressing Enter. By default, every scene starts with 1 
frame.

2. Select a frame and establish the attributes for the 
object in that frame.

3. Select a different frame and modify the attributes 
for the object in that frame.

Animation principles are the same whether you are 
animating at the scene level or within a component. For 
more information on the different ways you can 
animate objects and their attributes, see “Animation 
Methods and Techniques” on page 119.

Navigating between scenes
Scene navigation is important both when working 
within Mobile Designer and in the exported SVG file. 
The latter is accomplished using components and is 
discussed in more detail in “The Event Options dialog” 
on page 143. The former is discussed here.

To determine the current scene:

Do one of the following:

• Look at the left most entry in the Locator bar 
above the document window. This entry is always 
the current scene.

• Look at the Navigation menu. When at the scene 
level, the item displayed in the Navigation menu is 
the current scene. When in one of the component 
designers, the object tree for the current scene is 
displayed with the scene at the top of the tree.

To edit a different scene in Mobile Designer:

Do one of the following:

• Choose Scene > Go to scene in the main menu and 
choose a new scene in the Go to scene submenu.

• Click on the Navigation menu and choose a new 
scene. The scenes in your movie are listed after the 
separator at the bottom of this menu.

Components
Components (buttons, menu buttons, navigation bars, 
animation clips and books) are the key to producing 
rich, interactive movies in Mobile Designer. Without 
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them, you can produce simple animations within a 
scene, but not a lot more.

Components are different from primitives in three 
important respects:

• They are designed using primitives, but outside of 
the component designer they are treated as a single 
entity. 

• They include a behavior that allows them to be 
interactive, animated or both.

• They each have their own timeline (i.e. they 
operate independently from other primitives and 
components in your movie).

The component designers

Components are manipulated both at the scene level 
and through the component designers.

When working with a component at the scene level, 
you have access to the component as a unified whole, 
but not to the individual elements (primitives) that 
make up the component. You can create, delete, 
position, align, order and rotate components. In 
addition, you assign actions to components at the scene 
level. Assigning actions to take in response to events 
are discussed in the next section.

In order to manipulate the graphics that make up a 
component, you use the component designer. The 
component designer is essentially a special editing 
mode in which you can only draw, format and animate 
the elements that comprise your component. 

For simplicity, when referring to the component 
designer for a particular component type, the 
component name is included (i.e. buttons are edited in 
the “button designer”).

All components share many common attributes:

• To edit any component (i.e. enter the component 
designer) when you are at the scene level:

• Double-click on the component.

• Choose the component in the Navigation menu.

• Right-click on the component and choose Edit 
Component in the popup menu.

• Right-click on the component name in the 
Animation panel and choose Edit Component in 
the popup menu.

• At the scene level, all components display a green 
bounding box when selected. Primitives have a red 
bounding box.

• To exit the component designer for any 
component, click the Up One Level button 
adjacent to the Navigation menu.

• Whenever a component is selected at the scene 
level, the Component tab contains options specific 
to that component type.

• All components trigger events upon which you can 
take action.

Events and Actions
All components trigger events. Events are simply 
notifications. Events are generated automatically (i.e. 
they are an inherent part of a component). 

For example, when the user clicks on a button, this 
automatically triggers a “mouse click” event. 

In the course of creating your Mobile Designer movie, 
you decide which events you want to respond to and 
which you wish to ignore. 

You respond to an event by assigning an action to it. An 
action is simply what you do as a result of a particular 
event. By default, no actions are assigned for you; you 
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add them manually. You can assign more than one 
action to a given event.

For example, when a user clicks on a button (the event), 
you may play a sound and display a new scene (the 
actions). 

The types of events differ between the various 
components. They are described in the specific 
component sections below. The actions you can take in 
response to any event are the same for all components.

The general process for assigning an action to an event 
is:

1. Select a component on the scene.

2. Select the event in the Component tab (details in 
the specific component sections below).

3. In the Event Options dialog, select one or more 
actions and when applicable, customize the settings 
for those actions.
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The Event Options dialog

The Event Options dialog is where you specify the 
actions to take in response to a particular event.

The first column of the Event Options dialog shows 
the List of Available Actions. This is an exhaustive list 
of all of the actions you can take in response to an 
event.

The middle column of the Event Options dialog shows 
the List of Current Actions. These are the actions that 

you have chosen to take when the event you selected in 
the Component tab is triggered.

The last column of the Event Options dialog is used to 
specify any settings associated with the action selected 
in the List of Current Actions.
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To add an action to the List of Current Actions from 
the List of Available Actions:

Do one of the following:

• Double-click on an item in the List of Available 
Actions.

• Select an item in the List of Available Actions and 
press the “+” button.

To remove an item from the List of Current Actions:

Press the “-” button.

Available Actions

The first column of the Event Options dialog contains 
the complete list of available actions. 

While generally self-explanatory, a brief description of 
each action including its specific settings is provided 
below.

• Jump to Specific Scene replaces the current scene 
with the scene you specify in the Scene menu.

• Go to Next Page of Book displays the next page of 
the book you specify in the Book menu. When the 
Wrap box is checked, you return to the first page in 
the book after the last page is reached.

• Go to Previous Page of Book displays the previous 
page of the book you specify in the Book menu. 
When the Wrap box is checked, you skip to the last 
page in the book after the first page is reached. 

• Jump to First Page of Book displays the first page 
of the book you specify in the Book menu.

• Jump to Last Page of Book displays the last page of 
the book you specify in the Book menu.

• Jump to Specific Page of Book displays the specific 
page in the specific book that you choose.

• Play Sound plays the sound you select in the Sound 
menu. To load a new sound, click the Add button.

• Stop All Sounds stops all sounds currently playing 
in your movie.

• Jump to URL displays the Web page at the URL 
you specify. To display this content in a new 
window, check the Open in new window box. 
Otherwise, the indicated Web page will replace the 
current movie content.

• Send e-mail launches the default e-mail editor in a 
separate window and fills in the To address with the 
e-mail address you specify.

• Play Animation starts the animation you specify in 
the Animation menu from its beginning. Play 
Animation has no effect on animations that are 
already playing.

• Stop Animation stops the animation you specify in 
the Animation menu. Stop Animation has no 
effect on animations that are already stopped.

• Show Component displays the component you 
specify in the Component menu. Show 
Component has no effect on components that are 
already visible.

• Hide Component hides the component you specify 
in the Component menu. Hide Component has no 
effect on components that are already hidden.

• Call JavaScript Function calls the JavaScript 
function you specify in the Function menu passing 
it the parameters specified in the Parameters menu. 
To create or edit a function, press the Edit button. 
You must press Reload before your changes take 
effect.

Buttons
Buttons are the simplest interactive components 
(animations are arguably simpler than buttons, but they 
are not interactive). Buttons are also the building 
blocks for navigation bars and menus.
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The button creation process, including creating 
buttons from scratch, sharing and the catalog, is 
described in detail in “Drawing Components” on 
page 43. 

When you create a new button or edit the contents of 
an existing button, you do so in the button designer. 
You enter the button designer by double-clicking on an 
existing button at the scene level. The button designer 
is also automatically opened for you whenever you 
create a new button using the button tool. When you 
have finished editing the primitives in your button, 
click the Up One Level button to leave the button 
designer.

Button states

Buttons have 3 different graphical states (appearances) 
you can customize while in the button designer. The 
state that is displayed in the SVG movie depends on 
what the user is doing with the mouse. The button 
states are:

• Up State. The Up state is displayed whenever the 
focus is not on the button or the mouse pointer is 
outside the bounds of the button.

• Over State. The Over state is displayed whenever 
the focus is on the button or the mouse pointer is 
inside the bounds of the button but the button is 
not pressed/clicked.

• Down State. The Down state is displayed 
whenever the focus is on the button or the mouse 
pointer is inside the bounds of the button and the 
button is pressed/clicked.

By default, each button state starts with one frame, but 
each state can be independently animated. Thus, you 
can specify any number of frames by clicking on a 

button state and typing a new value into the Total field 
in the Animation panel.

Within each button state, you follow the same 
animation rules you do when working elsewhere in 
Mobile Designer. You animate by selecting one frame 
and setting an object’s attributes, then you select 
another frame and change that object’s attributes. For a 
complete description of how to animate, see “General 
principles” on page 119.

In general, each button state is treated as a separate 
animation; there is no tweening across the different 
button states. The one exception to this is when a 
button state does not contain any property settings (i.e. 
no keys). In this case, the nearest previous key for each 
object property will be used even if it was set in the 
previous button state. If no previous object properties 
exist, then the property settings in the next button state 
are used.

For example, the color of a rectangle is animated as 
follows:

• The Up State is animated to change from blue to 
red.

• Over State contains no color information.

• The Down State is animated to change from green 
to purple.

In this case, the Up and Down states contain keys for 
the color properties, so you know exactly what they will 
do. The Over State, with no keys, will look to the Up 

Up Over Down

Loop State
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State and “adopt” the most recent color it can find 
there, which in this example is red.

The Component tab for buttons

While you design the look of your button in the button 
designer, you specify the feel, or interactivity, for your 
button at the scene level.

The Component tab for buttons is used to change the 
button label, assign actions to the various button 
events, and to set a button’s initial visibility. You can 
also specify that a button is to be used as the top button 
in a popup menu (i.e. a menu button). Menu buttons 
are described in the next section.

To change the text used as the button label:

1. Select the button. 

2. In the Component tab, type a new label into the 
Button Label text field.

If a button has more than one label, the characters in 
the topmost text object will be replaced by the text you 
type. The new text will use the same font information 
as the original text.

To set a button to be hidden when its scene is first 
displayed:

1. Select the button.

2. In the Component tab, uncheck the Visible box.

By default, all components are visible (checked).

To assign actions to a button’s events:

1. Select the button.

2. In the Component tab, do one or more of the 
following:

• To assign actions to the Mouse Over (has focus) 
event, either double-click on the event in the 
Button Events list or select this event and click the 
Edit button.

• To assign actions to the Mouse Click (button 
pressed) event, either double-click on the event in 
the Button Events list or select this event and click 
the Edit button.

• To assign actions to the Mouse Release (button 
released) event, either double-click on the event in 
the Button Events list or select this event and click 
the Edit button.

• To assign actions to the Mouse Leave (loses focus) 
event, either double-click on the event in the 
Button Events list or select this event and click the 
Edit button.

3. In the Event Options dialog, choose those actions 
you wish to execute for this event. For more 
information on events and actions, see “Events and 
Actions” on page 141.

To remove actions assigned to a button’s events:

1. Select the button.

2. In the Component tab, do one of the following:

• To remove all actions assigned to a given event, 
select the event in the Button Events list and click 
the Reset button.
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• To remove a particular action assigned to a given 
event, select the event and click the Edit button, 
then in the Event Options dialog, select the 
assigned action you wish to remove and click the “-
” button.

Menu Buttons
Menu buttons are a derivative of the standard buttons 
described above. Both are created in the button 
designer in exactly the same way, complete with 
identical up, over and clicked states. In fact, in an SVG 
movie you have no way of discerning whether you are 
looking at a button or a menu button until you use it.

Unlike standard buttons that take action when 
activated, when you activate a menu button in an SVG 
movie, a previously hidden menu appears (hence the 
name “menu button”). This “popup menu” is itself 
composed of buttons.

You use menu buttons whenever you work in Mobile 
Designer. The File menu is a menu button, and the 
menu that appears when you click it is a popup menu.

The menu button and the buttons used in the popup 
menu are not required to be identical. However, all of 
the buttons in the popup menu are the same except for 
their button text and associated actions.

For a complete description of the different button 
states and how to create buttons, see “Buttons” on 
page 144.

The Component tab for menu buttons

The decision to turn a button into a menu button and 
vice versa is made at the scene level after creating the 
button in the button designer. In the Component tab, 
the first item is the Button Type. The Button and 
Menu Button radios switch between the two button 
types. The remaining contents of the Component tab 
adjust accordingly when you do this.

When the Menu Button radio is selected, the 
Component tab is used to both set the attributes for the 
menu button and its accompanying popup menu. 
Specifically, the Button Label and Initial Visibility at 

Menu Button (inactive) Menu Button and
Popup Menu
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Export items apply to menu buttons, with the 
remaining items applying to the popup menu. 

To change the text used as the menu button label:

1. Select the menu button. 

2. In the Component tab, type a new label into the 
Button Label text field.

If a menu button has more than one text object, the 
characters in the topmost text object will be replaced by 
the text you type. The new text will use the same font 
information as the original text.

To set a menu button to be hidden when its scene is 
first displayed:

1. Select the menu button.

2. In the Component tab, Uncheck the Visible box.

By default, all components are visible (checked).

To add menu items to the popup menu:

1. Select the menu button.

2. In the Component tab, click the New button.

3. In the New Menu Item dialog, type in the text for 
your new popup menu item and click OK.

Note: the text that you enter in the New Menu Item dialog is 
displayed both in the Menu Items list in the Component tab 
and as the popup menu button text in your SVG movie.

To rename a popup menu item:

1. Select the menu button.

2. In the Component tab, select the item in the Menu 
Items list.

3. Click the Rename button and type a new name.

4. Press Enter to finish the new name.

The text displayed in the Menu Items list is also used 
for the popup menu button text in your SVG movie.

To delete an item from a popup menu:

1. Select the menu button.

2. In the Component tab, select the popup menu item 
in the Menu Items list.

3. Click the Delete button.

To reorder the items in a popup menu:

1. Select the menu button.

2. In the Component tab, select the popup menu item 
you wish to reorder in the Menu Items list.

3. Do one of the following:

• Click the Up button to move the selected popup 
menu item up in the list.

• Click the Down button to move the selected popup 
menu item down in the list.

The order the popup menu items appear in the Menu 
Items list is the order that they will appear in your SVG 
movie.

To assign an action to a popup menu item:

1. Select the menu button.

2. In the Component tab, select the popup menu item 
in the Menu Items list.

3. Click the Edit button.

4. Assign the desired actions in the Mouse Click 
Event Options dialog.

Popup menu items only trigger events when they are 
clicked. For more information on assigning actions, see 
“Available Actions” on page 144.

To remove actions assigned to a popup menu item:

1. Select the menu button.
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2. In the Component tab, select the popup menu item 
in the Menu Items list.

3. Click the Edit button.

4. In the Event Options dialog, select the assigned 
action you wish to remove and click the “-” button.

To change the template used for the popup menu 
buttons:

1. Select the menu button.

2. In the Component tab, click the Change button.

3. In the Customize Menu Item dialog, do one of the 
following:

• To select a new button from the Catalog, choose 
the Create Popup Menu Buttons from the Catalog 
radio and select a new template from the list.

• To select a new button template (look) from 
Sharing, choose the Create Popup Menu Buttons 
from Sharing radio and select a new template from 
the list.

The selected template is used for all buttons in the 
popup menu.

To set which event displays the popup menu:

1. Select the menu button.

2. In the Component tab, do one of the following:

• To display the popup menu when the mouse is over 
the menu button, choose Mouse Over from the 
Menu Display Action menu.

• To display the popup menu when the menu button 
is clicked, choose Mouse Click from the Menu 
Display Action menu.

To set the spacing between the popup menu items:

1. Select the menu button.

2. In the Component tab, do one of the following:

• Enter a new number in the Spacing value field.

• Drag the Spacing value slider to a new setting.

By default, the buttons in the popup menu are set to 
have their bounding boxes touching. Because the 
popup menu disappears whenever the mouse is not 
over any of its buttons, non-rectangular buttons may 
produce gaps in the popup menu. To compensate for 
this, the Spacing field can be used to set the buttons in 
the popup menu to overlap.

To set the orientation of the buttons in the popup 
menu:

1. Select the menu button.

2. In the Component tab, do one of the following:

• To display the buttons in the popup menu stacked 
one on top of another, choose Vertical from the 
Menu Orientation menu.

• To display the buttons in the popup menu adjacent 
to one another, choose Horizontal from the Menu 
Orientation menu.

The Menu Orientation determines whether the popup 
menu buttons are displayed vertically or horizontally, 
not where the popup menu itself appears. This is 
determined by the Menu Position.

To set where the popup menu appears in relation to the 
menu button:

1. Select the menu button.

2. In the Component tab, do one of the following:

• To display the popup menu below the menu 
button, choose Bottom from the Menu Position 
menu.

• To display the popup menu above the menu button, 
choose Top from the Menu Position menu.
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• To display the popup menu to the left of the menu 
button, choose Left from the Menu Position menu.

• To display the popup menu to the right of the 
menu button, choose Right from the Menu 
Position menu.

Navigation Bars
Navigation bars, or “nav bars,” provide a quick and easy 
shortcut for creating a set of buttons that are evenly 
spaced.

Drawing navigation bars

Nav bars are drawn using buttons from either the 
Catalog or from Sharing. That is, when you click on 
the Navigation Bar tool, you must select the button you 
wish to use from the Catalog or from Sharing before 
you can draw the nav bar itself. You can change the 
template used for the nav bar buttons at any time.

Once you have selected the button template to use in 
your nav bar, you create the nav bar by clicking and 
dragging on the canvas. You see the outline of each 
button appear as you increase your drag area. By 
dragging down, you create a vertical nav bar. By 
dragging across, you create a horizontal nav bar. The 
orientation and the number of buttons in a nav bar can 
be changed at any time.

The Component tab for navigation bars

The Component tab for navigation bars is used to set 
the number, order and actions associated with the 

buttons in the nav bar, the template used for the nav bar 
buttons, the spacing between the buttons in the nav 
bar, and the nav bar orientation.

To add buttons to a nav bar:

1. Select the nav bar.

2. In the Component tab, click the New button.

3. In the New Menu Item dialog, type in the text for 
your new nav bar button.

Note: the text that you enter in the New Menu Item dialog is 
displayed both in the Nav Bar Items list in the Component tab 
and as the nav bar button text in your SVG movie.

To rename a nav bar button:

1. Select the nav bar.

2. In the Component tab, select the button in the Nav 
Bar Items list.

3. Click the Rename button and type a new name.

4. Press Enter to finish the new name.
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The text displayed in the Nab Bar Items list is also used 
as the nav bar button text in your SVG movie.

To delete a button from a nav bar:

1. Select the nav bar.

2. In the Component tab, select the button item in the 
Nav Bar Items list.

3. Click the Delete button.

To reorder the buttons in a nav bar:

1. Select the nav bar.

2. In the Component tab, select the button you wish 
to reorder in the Nav Bar Items list.

3. Do one of the following:

• Click the Up button to move the selected button up 
in the list.

• Click the Down button to move the selected button 
down in the list.

The order the buttons appear in the Nav Bar Items list 
is the order that they will appear in your SVG movie.

To assign an action to a nav bar button:

1. Select the nav bar.

2. In the Component tab, select the button in the Nav 
Bar Items list.

3. Click the Edit button.

4. Assign the desired actions in the Mouse Click 
Event Options dialog.

Nav bar buttons only trigger events when they are 
clicked. For more information on assigning actions, see 
“Available Actions” on page 144.

To remove actions assigned to a nav bar button:

1. Select the nav bar.

2. In the Component tab, select the button in the Nav 
Bar Items list.

3. Click the Edit button.

4. In the Event Options dialog, select the assigned 
action you wish to remove and click the “-” button.

To change the template used for the nav bar buttons:

1. Select the nav bar.

2. In the Component tab, click the Change button.

3. In the Customize Menu Item dialog, do one of the 
following:

• To select a new button from the Catalog, choose 
the Create Nav Bar Buttons from the Catalog radio 
and select a new template from the list.

• To select a new button template (look) from 
Sharing, choose the Create Nav Bar Buttons from 
Sharing radio and select a new template from the 
list.

The selected template is used for all buttons in the nav 
bar.

To set the spacing between the nav bar buttons:

1. Select the nav bar.

2. In the Component tab, do one of the following:

• Enter a new number in the Spacing value field.

• Drag the Spacing value slider to a new setting.

By default, buttons in a nav bar are set to have their 
bounding boxes touching. Using the Spacing field, you 
can set the buttons to overlap or have as much as one 
button width/height between buttons in your nav bar.

To set the orientation of the buttons in the nav bar:

1. Select the nav bar.

2. In the Component tab, do one of the following:
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• To display the buttons in the nav bar stacked one on 
top of another, choose Vertical from the Nav Bar 
Orientation menu.

• To display the buttons in the nav bar adjacent to 
one another, choose Horizontal from the Nav Bar 
Orientation menu.

Animation Clips
Animation clips are the only non-interactive 
components in Mobile Designer. As the name implies, 
the animation clip is an animation that operates 
independent from the other objects in your movie.

The animation clip creation process, including creating 
animation clips from scratch, sharing and the catalog, 
is described in detail in “Drawing Components” on 
page 43. 

Briefly, when you create a new animation clip or edit 
the contents of an existing animation clip, you do so in 
the animation designer. You enter the animation 
designer by double-clicking on an existing animation 
clip at the scene level. The animation designer is also 
automatically opened for you whenever you create a 
new animation using the animation clip tool. When 
you have finished editing the primitives in your 
animation clip, click the Up One Level button to leave 
the animation designer.

The Component tab for animation clips

While you design the look of your animation clip in the 
animation designer, you specify the characteristics for 
your animation clip at the scene level.

The Component tab for an animation clip includes 
controls for specifying its initial visibility and playing/
stopped status at export, and what action, if any, should 
be taken when the animation clip finishes playing.

To set the visibility of an animation clip at the start of 
a scene:

1. Select the animation clip.

2. In the Component tab, do one of the following:

• To set an animation clip to be visible, check the 
Initially Visible at Export box. This is the default.

• To set an animation clip to be hidden, uncheck the 
Initially Visible at Export box.

Animation clips can also be shown and hidden via 
button and animation clip events and actions. For more 
information see “Events and Actions” on page 141.

To specify whether an animation clip is playing or not 
at the start of an SVG movie:

1. Select the animation clip.

2. In the Component tab, do one of the following:

• To play an animation clip at the start of a scene, 
check the Initially Playing at Export box. This is 
the default.
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• To pause an animation clip until it is triggered to 
play by another event, uncheck the Initially Playing 
at Export box.

Animation clips can also be stopped and played via 
button and animation clip events and actions. For more 
information see “Events and Actions” on page 141.

To specify any action to take when an animation clip 
finishes playing:

1. Select the animation clip.

2. In the Component tab, check the Animation Stops 
box.

3. Click the Edit button and choose the action to take 
in the Event Options dialog. For more information 
on the available actions, see “The Event Options 
dialog” on page 143

Animation clips that are set to loop a fixed number of 
times will only trigger the specified action after that 
number of iterations. Animation clips that are set to 
loop infinitely will never trigger any events.

Books
Books are the most powerful and flexible of all 
components. In fact, they share many of the same 
characteristics as scenes. For instance, you can include 
buttons and animations in books, easily vary what is 
displayed in them, and jump to specific parts of them 
just as you can jump to specific scenes.

Books are composed of three different elements: a 
foreground, one or more pages, and a background.

You place any objects you always want to appear in 
either the foreground or the background; these are 
always visible. As their names imply, objects in the 
foreground will appear on top of everything else, and 

objects in the background will appear behind 
everything else.

Sandwiched in between the foreground and 
background of a book are its pages. A book can have 
any number of pages, only one of which is ever visible 
at a time. 

When you view a book, you do so one page at a time. 
What you see is actually a composite image formed by 
drawing the background, overlaying this with the page, 
then overlaying that with the foreground.

In the image above, the rounded rectangle is in the 
background, the news blurb sits on the page, and the 
buttons for switching pages are in the foreground. 
Clicking on the “Page 2” button displays a new page 
which is composited with the same foreground and 
background.

Typically, you add a page to your book whenever you 
have new content to display. The foreground and 
background are used to display those objects you want 
to display (i.e. background decorations or buttons used 
to navigate between the pages) regardless of which 
page you are on.

Creating and working with books

Books are created using the Book tool in the Toolbox. 
You can either create a new book from scratch or select 
a book from the Catalog. As with other tools, you 



Chapter 9:154
actually create the book by clicking and dragging on 
the canvas.

When you create a new book, it contains 3 elements: 
the foreground, one page and the background. 

By default, you remain at the scene level when you 
create a book. This makes it very convenient to 
immediately add pages to your book. Just remember 
that in order to start adding content to your book, you 
must first enter the component designer for the 
foreground, background or page you wish to work on.

Adding content to books is done in the same way as 
with other components - you draw it directly or pull it 
from the Catalog or from Sharing. The only difference 
is that unlike with other components, with books you 
can include buttons and animation clips as well as 
primitives.

This ability to add components to your book implies 
that you can also edit those components. Since editing 
a component means opening the component designer 
for that component, when working with books you can 
have multiple component designers open at once (one 
for the book and one for the component you are 
editing).

This could get confusing. Fortunately there are visual 
cues and shortcuts to help you get to where you want to 
go and always know where you are.

The Locator Bar always shows the level at which you 
are working starting with the current scene. Thus, 
when you are working in the foreground of a book, it 
shows you exactly where you are:

Likewise, if you are editing the primitives inside a 
button in your book, it will show that:

The Up One Level button in the Navigation Bar exits 
the current component designer are places you up one 
level. If you are editing a button within a book, clicking 
once results in your being placed in the book designer, 
and clicking twice returns you back to the scene level.

The Component tab for books

The Component tab for books is used to manage the 
pages in your book and to set the visibility of 
everything in a book when you first open the scene 
containing the book.

To add a page to a book:

1. Select the book.

2. In the Component tab, click the New Page button

New pages are added after the last page in the book but 
before the Background.

To open the book designer for the foreground, 
background or page in a book:

1. Select the book.

2. In the Component tab, do one of the following:

• Select the page in the Book Pages list and click the 
Edit button.

• Double-click on the page in the Book Pages list.

You can also open the book designer for a page by 
selecting it in the Navigation menu.
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To delete a page from a book:

1. Select the book.

2. In the Component tab, select the page in the Book 
Pages list.

3. Click the Delete button.

To reorder the pages in a book:

1. Select the book.

2. In the Component tab, select the page you wish to 
reorder in the Book Pages list.

3. Do one of the following:

• Click the Up button to move the selected page up 
in the list.

• Click the Down button to move the selected page 
down in the list.

The order the pages appear in the Book Pages list is the 
order that they will appear if you cycle through them 
sequentially in your SVG movie.

To set the visibility of a book at the start of a scene:

1. Select the book.

2. In the Component tab, do one of the following:

• To set a book to be visible, check the Visible box. 
This is the default.

• To set an book to be hidden, uncheck the Visible 
box.

Books can also be shown and hidden via button and 
animation clip events and actions. For more 
information see “Events and Actions” on page 141.
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Mobile Designer is capable of opening or importing a 
wide variety of graphics and sound files. In addition to 
all of the file formats it can either export or save, several 
3D file formats are supported as well as Adobe 
Illustrator, Windows Meta Files and sound files. 

In this chapter, you learn the various supported open 
and import file formats and how to open and start 
working with them.

Opening and Importing
Mobile Designer offers two different methods of 
loading files: 

• File > Open is used to open a document in a 
separate Mobile Designer session. The file that is 
opened does not become part of an existing movie; 
it stands alone. You can open any supported 
graphics file using File > Open. For a list of these 
graphics formats, see “Supported file formats” on 
page 166.

• File > Import is used to load a file into the current 
movie. The loaded file becomes part of the movie. 
You can import both image and sound files, but you 
cannot import one Mobile Designer file into 
another.

To open a supported graphics file:

Do one of the following:

1. Choose File > Open from the main menu and 
select the file in the Windows Open dialog.

2. Drag and drop the file onto Mobile Designer when 
no movies are currently open.

When you drag and drop a file onto Mobile Designer, 
how that file is handled depends on whether a movie is 
currently open or not. If no movie is currently open, 
then the drop is treated as a file open and a new movie 
is created. If a movie is currently open, then the drop is 
treated as a file import and the contents of the file 
become part of the existing movie.

To import a supported graphics file into the current 
movie:

Do one of the following:

1. Choose File > Import > Graphics from the main 
menu and select the graphics file in the Windows 
Open dialog.

2. Drag and drop the graphics file onto the canvas of 
the current movie.

To import a supported sound file into the current 
movie:

Do one of the following:

1. Choose File > Import > Sound from the main 
menu and select the sound file in the Windows 
Open dialog.

2. Drag and drop the sound file onto the canvas of the 
current movie.

To import multiple images as an animated sequence:
Chapter 10: Loading and Importing 
Files
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1. Choose File > Import > Created Animated 
Sequence from the main menu.

2. In the Windows Open dialog, select all of the 
images that you wish to import.

The imported files form an animated sequence. That 
is, all the image are imported as a single object, with 
one image shown per frame. Additional frames are 
created in the animation panel as necessary.

When importing images as an animated sequence, the 
dimensions of the first image determine the 
dimensions of the entire imported object.

If you have a series of images that you want to display 
as a slide show, importing them as an animated 
sequence is one way of achieving this result.

Supported file formats
Mobile Designer is capable of loading a wide variety of 
vector, bitmap, 3D and sound file formats in addition 
to the native Mobile Designer file format. 

While many of these formats have a very specific file 
structure that makes them easy to load, others such as 
SVG are broad, flexible formats that may include 
elements not supported by Mobile Designer (or most 
other graphics applications for that matter). Any 
special considerations associated with a particular file 
format are included when that format is discussed.

Mobile Designer files
Mobile Designer saves its files in an internal file format 
that uses a “.md” file extension. Mobile Designer files 
contain all of the information needed to reload your 
movie in exactly the state you last saved it.

Generally speaking, a Mobile Designer file should load 
without issue on the machine in which you created it. 
However, because Mobile Designer files can contain 
computer specific information (such as uncommon 
fonts), when transferred to a different machine, these 
files may report one or more errors.

When Mobile Designer encounters an error when 
trying to load a saved file, it records the error in an 
online error log. This log file is displayed at the end of 
the load process.

Vector file formats
Mobile Designer supports the most widely used vector 
file formats. Of these, SVG offers capabilities most 
similar to those found in Mobile Designer.

The following vector file formats are supported:

• SVG
• Adobe Illustrator (up to Version 8.0)
• Windows MetaFile (WMF)

In general, none of the vector file formats provides a 
perfect mapping to the features in Mobile Designer. In 
fact, all of these formats can include elements that have 
no counterpart. For Illustrator and WMF files, when 
such elements are encountered, they are ignored. 
Therefore, you are advised to visually inspect any 
Illustrator or WMF files you load into Mobile 
Designer.

SVG is a special case. As the primary export target of 
Mobile Designer, SVG does have a very close 
relationship with Mobile Designer. However, many of 
the conceptual features that make Mobile Designer 
easy to use (such as books and pages) have no 
equivalent in SVG. The result is that any SVG file you 
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open or import will likely not match the original 
Mobile Designer file.

Not surprisingly, hand coded SVG files, files generated 
in other applications, and Mobile Designer generated 
SVG files from a different machine may contain 
unsupported features or unavailable items such as 
fonts. Plus, not all SVG files are even structured in the 
same way.

For all of these reasons, Mobile Designer maintains an 
online error log of any issues that are encountered. This 
log file is displayed at the end of the load process.

Bitmap file formats
Mobile Designer supports all of the popular bitmap file 
formats. Mobile Designer should always import these 
file formats completely and without incident.

The following bitmap file formats are supported:

• Animated GIF
• GIF
• JPEG
• PNG
• BMP
• TIFF
• Targa
• Adobe Photoshop (up to Version 7.0; support for 

text layers is limited)

Note: Adobe Photoshop is a proprietary file format that goes 
well beyond the other bitmap formats listed above in capability 
and function. Photoshop files can include elements that are not 
supported by Mobile Designer. If any of these are encountered, 
they are ignored. You are advised to visually inspect any Pho-
toshop files you load into Mobile Designer.

3D file formats
Mobile Designer can load many of the most popular 
static 3D model file formats. Once loaded these can be 
rotated and animated in full 3D just as you can do with 
3D text.

The following 3D formats are supported:

• 3D Studio Max
• Lightwave 3D
• DXF

Sound file formats
Mobile Designer can read a wide array of sound file 
formats and include links to them inside SVG movies. 
Due to file size and licensing constraints, sound files 
are never embedded inside of SVG movies upon 
export.

The following sound file formats are supported:

• MP3
• WAV (uncompressed, ADPCM, MP3, DivX)
• AIFF
• WMV (audio track only)
• WMA
• AVI (audio track only)
• MPEG (audio track only)

Mobile Designer uses DirectX to import sounds. If you 
encounter difficulties loading an audio track, it may be 
because you are missing the proper codec required by 
DirectX.

When loading a sound from a movie, only the first 
sound track is used.
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An important feature for delivering dynamic content to 
SVG powered devices is the ability to include up to the 
minute information. For example, title and paragraph 
fields can be populated from a News data feed (i.e. 
RSS). Another example is in a real-time traffic 
application where information from road sensor 
measurements is used to alter the color of a road 
segment on a map (red if congested and green if not).

This chapter explains how Mobile Designer allows you 
to develop such applications and deploy them on Live 
Assets server for rendering and distribution.

Introduction to XML
XML is the acronym for eXtensible Markup 
Language, the universal format for structured 
documents and data on the Web. XML is an industry-
standard protocol administered by the World Wide 
Web Consortium (W3C) and is becoming the 
preferred way of extracting data from one application 
and making it available to other applications. Various 
industry sectors are adopting common XML models to 
exchange data and software platform vendors have 
released middleware that makes the exchange of XML 
data very easy. 

The following example shows how weather data is 
represented in XML:

The association between XML data and charts, shapes 
and other objects are discussed below.

Associating XML data with 
objects
The following objects can be associated with XML 
data:

• Rectangles
• Rounded rectangles
• Ellipses
• Polylines
• Lines
• Beziers
• Text 
• Paragraph text
• Text on curve 
• 3D Text
Chapter 11: Working with External 
Data Files
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• Buttons 
• Animation clips
• Books 
• Image URLs

When one of these objects is selected, the XML tab 
becomes active.

The XML tab has three different sections: 

• The XML Association section is used to associate 
object properties and their parameters with the 
XML data.

• The XML Data File section is used to specify 
where the XML data file is located. XML data files 
can be local or remote and are accessible via HTTP 
and FTP addressing.

• The XML Data Mapping section is used to open 
the Mapping Parameters dialog where object 
properties are mapped to individual data records.

Each of the XML tab sections play an integral part in 
creating a link between the XML data and the object 
properties to be altered. Each section is described 
below.

XML Associations
The first step in the XML association process consists 
of selecting the properties of an object that you want to 
alter using XML data. 

The XML Association menu displays those properties 
that are currently available for alteration. Included in 
this list are any properties you have added manually and 
those specific properties that are automatically 
included based on object type (i.e. text objects 
automatically receive a text association in this menu).

To add an XML Association for the current object:

1. Click the Add XML Association button.

2. Select the desired association and customize it in 
the Add XML Association dialog.

The XML associations are described below.

To edit an XML Association for the current object:

1. Select an association in the XML Association 
menu.

1. Click the Edit XML Association button.

2. Customize the association in the Edit XML 
Association dialog.

To delete an XML Association for the current object:

1. Select the association in the XML Associations 
menu.

2. Click the Delete XML Association button.

Add Association Delete Association

Edit Association
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Complete list of XML Associations

The list that follows shows all of the possible XML 
associations. Not every association is supported for 
every type of object (i.e. rectangles do not support the 
text association). 

• Fill color
• Stroke color
• Horizontal translation
• Vertical translation
• Horizontal scaling
• Vertical scaling
• Rotation
• Opacity
• Visibility
• Replication
• Text
• Button label
• Button Link
• Script parameters
• Bitmap

Fill color
The Fill Color association enables an object’s fill color 
to be modified based on XML data.

Applicable objects: Rectangle, rounded rectangle, 
ellipse, polyline, Bezier, text, paragraph text, text on 
curve, 3D text.

Pre-populated: Never

This XML association has three modes:

• Continuous
• Threshold
• String Based

Continuous mode

Continuous mode is used to map XML data to colors. 
When using Continuous mode, you specify an 
expected range of data values as well as a range of colors 
to display. XML data that falls into the specified range 
is assigned the equivalent color in the specified color 
range.

This mode is selected by clicking the Continuous radio 
button. 

To specify the color range:

Do one of the following:

• To set the minimum color in the range, click on the 
Min color sample and select a color in the Color 
dialog.

• To set the maximum color in the range, click on the 
Max color sample and select a color in the Color 
dialog.

To set the range of expected XML data values:

Do one of the following:

• To set the minimum XML data value in the range, 
enter a new number in the Min value field.
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• To set the maximum XML data value in the range, 
enter a new number in the Max value field.

Depending on the XML data, an interpolated color is 
assigned as illustrated in the graph below (assuming a 
data range of 0 to 100)

If the XML data is out of the specified range, the color 
is assigned by extrapolation. It is recommended that 
you properly indicate the range of XML data values.

Threshold mode

Threshold mode is used to map continuous XML data 
values into discrete values. When the XML data 
crosses a certain threshold value, the next color in the 
sequence is used. For example, you could color-code an 
alert level based on a real time measurements using 
threshold mode.

This mode is selected by clicking the Threshold radio 
button. By default, two colors are created. The second 
color accepts a threshold value. XML data greater than 
this value receives this color. XML data below this 
value receives the first color.

To add a new color/threshold pair:

Press the Add Color button. 

This creates a third line in threshold table as shown 
below:

As above you can specify a different threshold value in 
the Threshold text box.

To delete a threshold value:

Press the Delete Color button. 

To rearrange the colors in the list:

Do one of the following:

• Press the Move Color Up button to move the 
selected color/threshold pair up in the list.

• Press the Move Color Down button to move the 
selected color/threshold pair down in the list.

The example below is a rendering of four equal 
thresholds between 0 and 100:
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String Based mode

String Based mode is used to set the fill of an object 
when the XML data matches the value specified in the 
XML Association dialog. The data is not required to 
be numerical.

The result for the test on the string value Stage 5 is 
illustrated below:

Note: the string comparison is case-sensitive.

Stroke color
The Stroke Color association enables an object’s stroke 
color to be modified based on XML data.

Applicable objects: Rectangle, rounded rectangle, 
ellipse, line, polyline, Bezier, text, paragraph text, text 
on curve, 3D text.

Pre-populated: Never

This XML association has three modes:

• Continuous

• Threshold
• String Based

Continuous mode

Continuous mode is used to map XML data to colors. 
When using Continuous mode, you specify an 
expected range of data values as well as a range of colors 
to display. XML data that falls into the specified range 
is assigned the equivalent color in the specified color 
range.

This mode is selected by clicking the Continuous radio 
button. 

To specify the color range:

Do one of the following:

• To set the minimum color in the range, click on the 
Min color sample and select a color in the Color 
dialog.

• To set the maximum color in the range, click on the 
Max color sample and select a color in the Color 
dialog.

To set the range of expected XML data values:

Do one of the following:
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• To set the minimum XML data value in the range, 
enter a new number in the Min value field.

• To set the maximum XML data value in the range, 
enter a new number in the Max value field.

Depending on the XML data, an interpolated color is 
assigned as illustrated in the image below (assuming a 
data range of 0 to 100)

If the XML data is out of the specified range, the color 
is assigned by extrapolation. It is recommended that 
you properly indicate the range of XML data values.

Threshold mode

Threshold mode is used to map continuous XML data 
values into discrete values. When the XML data 
crosses a certain threshold value, the next color in the 
sequence is used. For example, you could color-code an 
alert level based on a real time measurements using 
threshold mode.

This mode is selected by clicking the Threshold radio 
button. By default, two colors are created. The second 

color accepts a threshold value. XML data greater than 
this value receives this color. XML data below this 
value receives the first color.

To add a new color/threshold pair:

Press the Add Color button. 

This creates additional lines in threshold table as 
shown below:

As above you can specify a different threshold value in 
the Threshold text box.

To delete a threshold value:

Press the Delete Color button. 

To rearrange the colors in the list:

Do one of the following:

• Press the Move Color Up button to move the 
selected color/threshold pair up in the list.

• Press the Move Color Down button to move the 
selected color/threshold pair down in the list.
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The example below is a rendering of four equal 
thresholds between 0 and 100:

String Based mode

String Based mode is used to set the stroke of an object 
when the XML data matches the value specified in the 
XML Association dialog. The data is not required to 
be numerical.

The result for the test on the string value Stage 5 is 
illustrated below:

Note: the string comparison is case-sensitive.

Horizontal/Vertical Translation
The Horizontal and Vertical Translation associations 
enable an object’s position to be modified based on 
XML data.

Applicable objects: Rectangle, rounded rectangle, 
ellipse, line, polyline, Bezier, text, paragraph text, text 
on curve, 3D text, button, animation, book, bitmap.

Pre-populated: Never

Using horizontal and vertical translation associations, 
for example, you could display an object on a 
geographical map and adjust its location based on 
longitude and latitude information contained in a 
XML data feed. 

In the image below, the yellow dots represent cities. 
The dots were created with (0,0) coordinates and 
translated horizontally based on the latitude XML data 
and vertically on longitude data (both ranging between 
-180 and 180). 

Note: the horizontal translation starts on the left and 
grows to the right. The vertical translation starts at the 
top grows down.
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In the this example, the XML Data has 11 values 
ranging from 0 to 100 with increments of 10. Mobile 
Designer has 11 identical rectangles that are translated 
using each of the XML data values (using the 
Replication XML association described below).:

When the Translation range is from 0 to 200 the same 
XML data is represented as follows:

Note: while the ranges are defined by the Min and Max 
values, nothing prevents you from having a Min value 
greater than the Max Swapping the values will simply 
change the direction of the translation. 

Vertical/Horizontal scaling
The Horizontal and Vertical Scaling associations 
enable an object’s size to be modified based on XML 
data.

Applicable objects: Rectangle, rounded rectangle, 
ellipse, line, polyline, Bezier, text, paragraph text, text 
on curve, 3D text, button, animation, bitmap.

Pre-populated: Never

For instance, in the map example, the dots could be 
scaled (both horizontally and vertically) to represent 
the city population.

When you select Vertical or Horizontal scaling from 
the menu, you're presented with three sections:

• Scaling Range
• Scaling Direction
• XML Data range

The Scaling Range sets to the factor by which the 
objects will be stretched. A factor of zero will not affect 
the size.
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The Scaling Direction indicates which way the object 
will grow or shrink. The following images illustrate the 
three possibilities for vertical and horizontal scaling:

The XML data range represents the span of values for 
the variable that will be attached to this 
transformation. Ensure that you calibrate this range 
properly. If the XML data falls outside of the range, the 
object will be scaled linearly beyond the Scaling Range.

In order to preserve the size ratio of an object when 
applying scaling, you will have to apply both horizontal 
scaling and vertical scaling with the exact same Scaling 
and Data ranges.

Rotation
The Rotation association enables an object’s rotation to 
be modified based on XML data.

Applicable objects: Rectangle, rounded rectangle, 
ellipse, line, polyline, Bezier, text, paragraph text, text 
on curve, 3D text, button, animation, book, bitmap.

Pre-populated: Never

This is very useful when building a Speedometer. for 
example:

The Rotation dialog contains fields for you to specify a 
Rotation Range and an XML Data Range.

The Rotation Range is expressed in degrees and runs 
counter-clockwise. In the Example shown above, the 
Min value is 0 and the Max is set to -360 in order to 
obtain a clockwise rotation. 

As with other XML associations, when the XML data 
values are out of range, an extrapolation occurs. In the 

Vertical Scaling

Horizontal Scaling
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example above, an XML data value of 200 will be 
translated into two full rotations.

Opacity
The Opacity association enables an object’s opacity to 
be modified based on XML data.

Applicable objects: Rectangle, rounded rectangle, 
ellipse, line, polyline, Bezier, text, paragraph text, text 
on curve, 3D text, button, animation, book, bitmap.

Pre-populated: Never

The Opacity dialog contains fields for you to specify a 
Opacity Range and an XML Data Range

The Opacity Range is expressed is expressed 
numerically. This range acts as a multiplier for the 
original object’s opacity. An opacity of 0 results in a 
transparent object. An opacity of 100 results in an 
opaque object.

As with other XML association, when the XML data 
is out of the specified XML Data Range, the value is 
extrapolated. For example if the original object's 
opacity is 50, the XML Data Range Max is 50 and the 
Min value in the Opacity Range is 100, if the XML 
data value turns out to be 100, the object will have an 
opacity of 100. 

Visibility
The Visibility association enables an object’s visibility 
to be modified based on XML data.

Applicable objects: Rectangle, rounded rectangle, 
ellipse, line, polyline, Bezier, text, paragraph text, text 
on curve, 3D text, button, animation, book, bitmap.

Pre-populated: Never

In the image below, the occupancy of a plane is 
determined based on XML data values. The XML data 
file contains one node per seat and an associated 
attribute Occupied with the possible values Yes and 
No.

The Visibility dialog offers two modes: Keyword Based 
and Value Based.
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Keyword Based

Keyword mode tests for the presence of the specified 
Keyword. Depending on the selection in the drop-
down list of the interface, the presence of the Keyword 
will make the object visible or invisible.

Value Based

Value mode will compare, in many possible ways, a 
numeric variable to a value and make the object visible 
or not.

Note: an object marked as invisible in the original 
design will not be made visible by the XML association 
no matter what the value is in the XML data.

Replication
The Replication association creates duplicates of an 
existing object but does not otherwise modify those 
objects. The number of duplicates is determined by the 
data in the linked XML data file. These duplicates can 
subsequently be modified using other associations.

Applicable objects: Rectangle, rounded rectangle, 
ellipse, line, polyline, Bezier, text, paragraph text, text 
on curve, 3D text, button, animation, book, bitmap.

Pre-populated: Never

The Replication dialog provides maximum flexibility 
regarding the location of the replicated objects. They 
can be all stacked at the same location, using Duplicate 
object in place, to be moved later (using translation 
and/or rotation XML associations), or can be 
automatically positioned, using Duplicate object and 
move copies.

Duplicate object and move copies offers several options 
that define how the copies are positioned.

The Direction menu is used to specify which direction 
the copies are moved. You can move replicated objects 
Up, Down, Left and Right. You can also specify the 
number of pixels between each replicated object using 
the adjacent Spacing value field or slider.
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The Columns field (which becomes Rows when 
Direction is set to Left or Right) is used to specify how 
many rows/columns of replicated objects are created. 
The adjacent menu is used to specify on which side of 
the original object the rows/columns are created. The 
last field is used to specify the spacing between the 
rows/columns.

The image that follows illustrates replication using the 
following parameters:

• Direction: Right. Spacing: 0.
• Rows: 3; Down; Spacing: 20.

Replication and Books

Books can only be replicated in place (i.e. the Replicate 
and move copies radio button is disabled).

With books, the book itself is not replicated. Instead, 
the first page of the book (page 1; the foreground and 
background pages remain and are not replicated) is 
replicated and added to the book as a normal page. Any 
other pages in the book are ignored.

Replication and Scripting

The final option in the replication dialog, Make 
replication Count Available For Scripting is used if 
you are writing scripts to manipulate your SVG file and 
need to access the objects that are replicated.

When this scripting box is checked, the replicated 
objects are renamed to include a replication index. This 
index will have a range from 0 to the replication count 
minus 1.

For example, if the object “Rectangle” is replicated 
twice, the replicated object names are “Rectangle__0” 
and “Rectangle__1”. 

Two underscore characters always precede the 
replication index.

Note: in order to export the object names effectively making 
them accessible to JavaScript, the Export ID box for each of 
these objects must be checked in the Object tab. For more infor-
mation on the Object tab, see “The Object tab” on page 77.

When a component are replicated, the objects inside 
the replicated component are renamed using the 
pattern described above. This ensures that all objects 
have unique names.

If you have written a script to be used by buttons and 
have checked the option to have the replication count 
available in scripting, a global script variable is added 
automatically. The variable name for this is based on 
the replicated object name with the suffix “__count” 
(two underscore characters followed by the word 
“count”).

For example:

var Rectangle__count = 11;

This allows you to dynamically generate names to 
access replicated objects in scripts.

Replicating objects inside of components and 
groups

You can also replicate objects inside components and 
groups that are themselves replicated. In this case you 
may have objects with several replication indices. 
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For example, you could have a replicated component 
named “button” that contains a replicated object 
named “rectangle”. In this case, you may generate 
objects with the following Export IDs:

• button__0
• rectangle__0__0
• rectangle__0__1
• rectangle__0__2
• button__1
• rectangle__1__0
• button__2
• rectangle__2__0
• rectangle__2__1
• rectangle__2__2

The global scripting variable however is not going to be 
“rectangle__2__count” as it would be impossible to 
access the variable by dynamically generating its name 
(“rectangle” + “__” + first_index + “__count”).

Instead, you will have only one variable 
“Rectangle__x__count”. This is an array, whose size is 
determined by the “count” of the top replication, 
containing all the count.

For example:

var button_count = 3;

var rectangle__x__count = new

Array(3, 1, 3);

Text
The Text association enables an object’s text to be 
modified based on XML data.

Applicable objects: text, paragraph text, text on curve, 
3D text.

Pre-populated: When applicable.

The example below shows how a subset of a weather 
XML data stream is translated into a weather 
visualization application.

The data:

The visualization:

The Text field properties are be preserved including the 
font, font size, proportions and alignment in the 
bounding box. 

The image below shows how dynamic content can 
outgrow the original bounding box of a Text field 
depending on the alignment settings.
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The case of the text in the XML data file will be 
preserved and may override the case setting of the 
original place holder text.

Button Label
The Button Label association allows you to change the 
label on a button based on XML data.

Applicable objects: buttons.

Pre-populated: on buttons that contain at least one 
text, paragraph text or text on curve object.

For example, a viewer for the syndicated news XML 
format RSS will have a button with the News Channel 
as a label, as shown below:

This XML association has no parameters.

If a button has multiple eligible fields, Mobile 
Designer will inspect the button’s contents starting 
with the frontmost object and replace the first qualified 
field it encounters. If this field is also the subject of a 
Text association, the Button Label association will 
override it.

Button Link
The Button Label association allows you to change a 
button action (specifically the Jump to URL link) 
based on XML data.

Applicable objects: buttons.

Pre-populated: for buttons with a “Jump to URL” 
action associated with a particular event (i.e. mouse 
click); the action must be populated with a valid URL 
in Mobile Designer.

In many XML data feeds such as RSS files, some of the 
variables hold HTTP URLs that point to other web 
pages. Mobile Designer allows you to design buttons 
with actions that will open a new web page. Using this 
XML association you can dynamically alter the URL 
with one from the XML data feed.

When the Button Link association is pre-populated, 
no additional parameters are required except for the 
common XML mappings described in following 
sections of this chapter. It is, however, for the URL 
included in the XML to be explicit and include the 
protocol prefix (HTTP://, HTTPS://, FTP://, C:/, 
etc.).

Dynamic Script Parameters
The Dynamic Script Parameters association allows you 
to provide parameters to a script function using XML 
data. This association is unique in that you can add as 
many dynamic script parameters to a given object as 
you want or need.

Applicable objects: buttons.

Pre-populated: never.

When dynamic script parameters are added to a 
button, the parameter name in the XML Association 
menu changes to reflect its index. This index is also the 
placeholder name it will replace). 

For example, if you add three dynamic script 
parameters, they will be named as follows:
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Dynamic Script Parameter (%1)

Dynamic Script Parameter (%2)

Dynamic Script Parameter (%3)

To use dynamic script parameters, you must add the 
Call JavaScript Function to your button. In the 
parameters of the function to be called you can specify 
dynamic parameters by using the placeholders %1, %2, 
%3, etc.

Depending on the type of parameter you may need to 
quote the parameter (if it's a string).

For example, you could have the following function 
parameters and parameters:

ShowAlert('Warning', '%1');

Once the association is linked to an XML value, the 
script call inside the SVG will actually contain the 
value from the XML file.

ShowAlert('Warning', 'string from
XML!');

Since the placeholder nomenclature uses the '%' sign, 
using that particular character will require special 
handling: you will need to write '%%'. 

For example:

DisplayValue(%1, 'Unit: %%');

When exported to SVG, the call will be converted to:

DisplayValue(27.5, 'Unit: %');

Note: you can add more dynamic parameter 
associations than you really need, however adding 
fewer than you really need will result in script/parsing 
errors.

Image URL
The Image URL association allows you to replace an 
image by another one based on XML data.

Applicable objects: images.

Pre-populated: available for selection from a list when 
an image is selected.

For example, in the Weather application, the weather 
condition image changes to reflect the current 
conditions.

The Image URL association window has two different 
modes: Use XML Data as URL and Use XML Data as 
Keyword for URL List:
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Use XML Data as URL

Use XML Data as URL allows you to get the URL for 
the image directly from the XML data feed. 

For example the RSS format offers a URL that can be 
used directly:

Use XML Data as Keyword for URL List

Use XML Data as Keyword for URL List allows you to 
map values in an XML file to image representations. In 
this mode, you create a list of keyword/URL pairs. 
These are edited by selecting a pair in the list and 
changing their respective fields below.

XML Data files
Once you have defined at least one XML association, it 
is possible to attach XML data feeds to your Mobile 
Designer documents. Each XML data feed can be used 
by more than one XML association.

The XML associations are considered to be object 
parameters (i.e. they are associated with a particular 
object or object attribute), however XML Data feeds 
are document parameters (i.e. they are available to the 
entire document).

From the XML tab, you can add, edit and remove 
XML Data feeds. Because XML Data feeds can be 
associated with multiple objects, doing this can affect 
not only the current object, but other object 
associations.

Once a data file has been added to the document, it is 
listed in the XML Data File menu and available for all 
objects in your document. Adding the same file twice 
does not add a second entry in the list; it does 
automatically select the first file though.

When deleting an XML Data feed, every association 
linked to this loses its association. 

When editing the location of an XML Data feed, every 
association linked to it is updated with the new 
location.

The XML Data feed files can be specified using a local 
file or a file on the internet.

To use a local file, click on the File Open button and 
select a .xml or .txt file in the standard Windows Open 
dialog.

To use a file o the internet, click on the Open XML 
File via URL button. This opens the Data URL box 
where you can enter a valid URL. This URL must 
include a valid prefix such as HTTP:// or FTP://.

When you click the OK button, the URL is added as 
the current selection to the list of available XML data 
files with an index prefix.

To edit the location of the selected XML Data feed
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To delete the selected XML Data feed from the list of 
available files, click the Delete button. Upon doing 
this, all existing links to this file will be lost.

To disconnect a previously established XML Data feed 
for the current association without removing the feed 
from the XML Data File list or impacting any other 
associations, click the Unlink button.

Note: the validity of the XML Data file is not checked when 
the file is added to the list. It is only checked when there's an 
attempt to edit the XML parameters (see below). 

It is your responsibility to ensure that the XML Data 
files used conform to the XML standard as defined and 

maintained by the W3C (available online at http://
www.w3.org/XML/).

XML Data Mapping
Once the XML Association has been created and an 
XML Data file has been loaded and selected, you can 
define the XML data mapping. 

Click the Edit Mapping Parameters button to open 
the XML Data Association Mapping Parameters 
dialog.
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This dialog has five sections.

Area 1 is a copy of the XML tab and allows you to 
easily add/edit/remove XML associations and data files 
without having to close and re-open the dialog to 
access the tab.

Area 2 displays the XML Data feed you selected. 
Through this tree view, you select the node you want to 
map to your association.

Area 3 displays the nodes of the XPath you selected in 
the Area 2. You apply filters to the nodes in this area.

Area 4 is used to fine tune your mapping when you use 
replication.

Area 5 is used to select more than one node to do the 
data mapping when working with charts. This area 
allows you to select nodes for chart curves, labels, etc.

Mapping data

XML data mapping is done by selecting a node, the 
content of a node, or the content of a node attribute, 
and then choosing parameters for this node and its 
parent nodes.

The selection of the node content is done in the tree 
view (Area 2) by double-clicking on the data elements. 
Valid nodes have a grey check mark next to them.

Not all associations accept the same kinds of data.

For instance, opacity, scaling and translation require 
numerical values. Only nodes and attributes with 
numerical content will be selectable for these.

Similarly, Text and Image URLs require string values. 
Only nodes and attributes with string content will be 
selectable for these (in this case, any non-empty node 
or attribute qualifies).

Other associations like visibility and fill/stroke color 
have different needs depending on their parameters. 
The tree view always reflects which nodes are selectable 
and which are not for the current association.

Replication is a special kind of association. It does not 
require node or attribute content, but rather a node 
itself. It is the presence (and number) of this node in 
the XML feed that drives the replication of the object.

Selecting a node content, attribute content, or node in 
the tree view changes the check mark color to green 
and fills in the node list (Area 3).

The image above contains the following nodes:

• Doc
• Store
• Sales
• text()

The last entry indicates the content of the node Sales. 
If an attribute of the node Sales is chosen, the name of 
the attribute, preceded by the “@” character is 
displayed.

For all of the nodes in the list except “text()” and 
“@<attribute>”, you can set filters to specify one 
particular node in the XML feed if that node is present 
several times.

For example, the node Store appears multiple times in 
the tree view above. Therefore, it has an index number 
associated with it. 
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The filter can also be defined by attribute, as shown 
below. 

Present attributes include value. After selecting the 
node in the list, you can select the type of filter from the 
menu directly under the node list. Selecting attribute 
node, the attribute “value” and entering a value 
automatically moves the green check mark to the 
content that matches the filters.

The possible node filters are:

• Attribute Is. This node filter displays the list of 
attributes found for the node in the XML feed. 
Once an attribute is chosen, enter the value for this 
attribute. Only nodes with this attribute (there can 
be more than one) are valid.

• Index Is. This node filter displays an edit field. 
Enter an index in this field. Only nodes with this 
attribute (there can be more than one) are valid.

• All. All of that particular node are valid.

When selecting node or attribute content, the default 
filters are set using the following rules:

• If a node is present multiple times, the filter is 
automatically set to Index and the filter value is set 
to match whichever node was selected in the tree 
view.

• If the node is present only once, the filter is 
automatically set to All.

In the example above, selecting the content of the node 
Sales of the first store results in the following:

• Doc. There is only one node called Doc so the filter 
is set to All

• Store. Multiple nodes called Store exist, therefore 
the filter is set to Index and the value to 1 (or 
whatever value matches where you double-clicked).

• Sales. There are multiple nodes Sales in the feed, 
but only one falls under “Doc -> Store (index 1)”. 
Therefore this node has no filter (i.e. the filter is set 
to All).

Except for the replication, all associations require only 
one value. If the node filters result in several valid nodes 
(in which case they will all be shown as green), only the 
first node content or the first attribute content will be 
used to modify the object.

Setting up parameters for replication

As discussed earlier in the XML Association section, 
the replication association allows you to replicate a 
shape, image, button, animation clip or book page 
depending on the number of XML nodes in an XML 
Data file.
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When this association is selected, the tree view shows 
grey check marks directly in front of nodes, instead of 
node contents or node attribute contents.

When selecting a node, the last node is automatically 
set to All since this is most likely the node you want to 
use.

Notice that the node list does not include any “text()” 
or “@<attribute>” items since a node is selected.

One of the important features of replication is to set 
other parameters to display data depending on the 
replicated node.

In the example above, if the replication is applied to a 
book, elements in the replicated pages can have values 
set to reflect each Store node.

To do this, each association of objects inside the pages 
needs to synchronize with the replication of the book.

When editing the associations of an object containing 
a replication association or of an object inside a 
replicated component, the Synchronization menu is 
active in the Mapping Value section.

The image above shows Text association for an object 
inside the replicated page.

Possible values for the Synchronization menu are:
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• Replication of Parent Component. This option is 
available only if the object is inside a button, 
animation clip or book that is replicated. This is the 
case here where we want to display the sales value in 
each page for each store.

• Replication of object. This option is available if the 
object also has a Replication association.

• None. Even though the object is replicated 
somehow (replicated itself or inside a replicated 
component), you do not want to synchronize this 
association with the replication association(s).

With these parameters, the text in the first page will be 
“85”, the text in the second page will be “90” and so 
forth, for as many nodes as are present in the XML feed 
(and therefore for as many pages present in the book).

Note: selecting None in the Synchronization menu and select-
ing the content of the node Sales with no filter on any nodes 
(especially Store) will show all Sales nodes as selected (as indi-
cated by a green check mark). But the result will be entirely dif-
ferent. As explained earlier, associations that need only one 
value will always take the first value when presented with 
several possible nodes. In this case, the text objects in each rep-
licated page will show the sales number of the first store.

An object inside a replication component can also be 
replicated. In this case, the replication association of 
the object will be synchronized with the replication of 
the component, while the other associations of the 
object will most likely be synchronized with the 
replication of the object itself. Synchronizing the other 
associations of the object on the component replication 
will result in all replicated objects inside the same 
component being identical.

Two other replication parameters, Use Value and Index 
Offset, allow you to display special values.

The Use Value options are:

• Regular XML Node
• Replication Index
• Replication Count

Regular XML Node lets you simply use the value of a 
node, synchronized on the replication. This is the 
default option and is used in the example above.

Replication Index does not use the XML, but simply 
uses the index of the replication as a numerical or string 
value. This is very useful for displaying page number in 
a replicated book, for instance.

Replication Count is similar to Replication Index 
except it uses the total count of the replication as its 
value. 

The Index Offset values are -1, 0 and 1. The default is 
0.

Index Offset allows you to access the content of the 
previous or next node from a replicated node.

For example, in the case of a replicated book, you could 
use it to customize the next page or previous page 
buttons to display some information about the next or 
previous pages.

Finally, notice that the node filter list does not allow 
you to set filters for the nodes that are part of the 
replication path. Changing their filters would break the 
synchronization.

The filter menu is replaced by a warning: “This node is 
part of the replication path.”

However, changing the filters in the replication path 
nodes does update the filters for the nodes of all the 
associations that synchronized with it. If one of those 
associations is a replication that has other associations 
synchronized with it, they are also be updated.
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Associating XML data with 
charts
In Mobile Designer, user data is associated with charts 
only at Preview and Export. Until you preview or 
export, the data used to populate a chart or graph is 
generated dynamically to help you visualize how your 
chart will look.

XML files are used to provide data and labels to charts. 
The other formatting information is set in Mobile 
Designer.

Every time you create a chart, a chart XML association 
is created for you in the XML tab. Each kind of chart 
(i.e. single value, single series or multiples series) 
requires a different format of data. These are detailed in 
the sections that follow.

Single value charts
Applicable objects: single value charts.

Pre-populated: No options available.

Single value charts require only one (and only one) 
value to be fully functional. For example, for a 
speedometer chart, this value would be used to set the 
speedometer dial.
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For example, the following image shows an XML file 
in the Data Association dialog with one Amount 
selected.

This mapping produces the following single value chart 
upon export:
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Single series charts
Applicable objects: single series charts.

Pre-populated: No options available.

Single series charts are populated using a set of values. 
You can also optionally include a set of labels in the 
XML data file.

Once an XML data file has been loaded, the first step 
is to map the data values to the chart. Because it is 
likely that more than one value will be used to create 

the chart, the XML Node Filter must be modified to 
indicate a range of values. The path definition will also 
need to be modified to reflect this choice.

If necessary, Mobile Designer can add several values 
located under the same node level through a process 
called “aggregation” (see image below)

If the node selected for an aggregation level supports 
attributes, then these attributes can be selected as labels 
for the chart values. It is then possible to access these 
values from the Labels tab.
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Using the settings and associations in the XML Data 
Association dialog shown above, the following chart is 
generated at export:

Multiple series charts
Applicable objects: multiple series charts.

Pre-populated: No options available.

A multiple series chart requires two additional pieces of 
information when compared to single series charts: a 
node level to define the curves, and the label for the 
curves.

After selecting an XML file, the following steps are 
used map the XML data with the chart elements (see 
image below):

1. Select the data used to create the chart by selecting 
a field in the XML tree and adjusting the XML 
Node Filter parameters.

2. Select the aggregation level and the field used for 
the labels in the Chart Parameters section.
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3. Select a node level for the curves and the field used 
for the curves labels.
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Beatware Mobile Designer includes support for calling 
JavaScript functions contained in external JavaScript 
files. There are two levels at which these external files 
can be integrated within Mobile Designer:

• At the SVG Tag Level via the Onload or 
Onkeypress events. 

• At the Component Level, via the Onmouseover, 
Onclick, Onmouseup, Onmouseout and Onend 
events. 

General Behavior
No matter what level you wish to access your external 
JavaScript files, access to all of your JavaScript 
functions is provided through the use of drop down 
menus within Mobile Designer. As indicated in the 
image below, you both select a specific function as well 
as provide parameters for that function all from within 
Mobile Designer's easy to use dialog system.

You can even create or edit your JavaScript files on the 
fly by using the built-in Edit button, or if you prefer, 
you can edit the files outside of Mobile Designer using 
your editor of choice and Reload them when finished. 
Either way, the list of available functions is 
automatically updated, and the parameters field is 
available for any changes to your parameters list. 

SVG Tag Level
You use SVG Tag Level JavaScript calls when you want 
to take a specific action when your SVG file is loaded or 
when a particular key on the keyboard is pressed. For 
example, you may wish to use SVG Tag Level 
JavaScript to initialize your parameters or trigger an 
animation when the user presses the space bar. 

SVG Tag Level calls are specified in the Movie 
Properties dialog. The Movie Properties are accessible 
by choosing Image > Movie Properties or by right-
clicking on the canvas and selecting Movie Properties. 
Chapter 12: Working with 
JavaScript
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Within the Movie Properties dialog, you can create or 
load a function and specify its parameters for the 
onload and Onkeypress events.

By default, if you’re exporting JavaScript functions in 
SVG, a bwInit(evt) function will be called with the 
Onload event in order to set a global variable svgdoc to 
the SVGDocument node. This variable is necessary to 
access the elements of your SVG DOM.

Component Level
Two components in Mobile Designer are capable of 
generating or handling events that in turn can call 
JavaScript functions. These are:

• Buttons 

• Animation Clips 

Buttons

There are four events associated with buttons: mouse 
over, mouse click, mouse release, and mouse leave. Any 
or all of these events can be set to trigger a call to one 
or more JavaScript functions. 

For example, if you have a movie called MyButton.md 
with a button in it, and you want to call the function 
AlertMe(WarningMessage) located in an external 
JavaScript file, you would do the following (see 
“Buttons” on page 144 for more information on 
creating buttons):

1. Select the button in your scene. 

2. Click on the Component tab in the Inspector 
panel. 

3. Double-click on the Mouse Click event (shown 
below).



207Beatware Mobile Designer
User Guide
4. In the Event Options dialog, double-click on the 
Call JavaScript Function item in the first column to 
select it.
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5. Assuming the JavaScript file does not yet exist, you 
would then click on the Edit button and create the 
AlertMe() function in the editor provided 
(probably NotePad). 
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6. When finished in the in the editor, you would then 
save the file, close the editor, and press the Reload 
button in Mobile Designer to make this function 
available. 

7. Lastly, select AlertMe in the function menu and 
add the text, 'Warning Message' (note the single 
quotes) or any other text you want to display. 

All that is left to do is Save MyButton.md and Export 
it to SVG (the saved file is used later in this document). 
That's all there is to calling a JavaScript function in 
response to a button event.

Animation

Animation events are much more limited than button 
events in that there is only one event that an animation 
clip can trigger: Animation Stops. The Component tab 
for animation clips is correspondingly simpler, with 
only a single check box to indicate that an action is to 
be taken as a result of this event.

In order to set the desired response to the Animation 
Stops event, press the adjacent Edit button. This opens 
the Event Options dialog. The remainder of the 
process for calling a JavaScript function is identical to 
that used for buttons, described above.

Remember to disable the loop button for the 
animation, otherwise your animation will never stop 
and your JavaScript function will never be called!

Connecting to XML
It is also possible to tie parameters to data values stored 
in an separate XML file. For example, instead of 
entering 'Warning Message' as the parameter that is 
displayed by the JavaScript above, you could display a 
message that is stored in an external XML file.

In order to accomplish this, do the following:

1. Open any text editor (i.e. NotePad) and type the 
following line:

<message>Hello World!</message>

2. Save this file as Message.xml. 

3. Open MyButton.md in Mobile Designer. 

4. Select the button. 

5. Click on the Data tab in the Inspector panel, 
expanding it to show all of its contents, if necessary.
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6. Click on the “+” button in the Customizable Data 
section to open the New Customizable Data 
dialog.

7. In the Data menu, select Dynamic JavaScript 
Parameter.

8. Click OK create the dynamic parameter, close this 
dialog and return to the Data tab. 

9. Click on the Open Folder icon in the XML Data 
File section of the Data tab to load the XML data 
file, Message.xml, created earlier.
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10. Click the Edit Mapping Parameters button to open 
the XML Data dialog.
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11. Double-click on “Hello World!” in the XML tree 
on the right to link the JavaScript parameter to this 
text.

Note that the Customizable Data section in the screen 
shot above displays “%1”. You will see this value later 
when you change the parameter of the JavaScript 
function.

12. Click OK to close this dialog.

In order to reprogram the component to use the XML 
value in the JavaScript function, the button events must 
now be changed slightly.

13. Select the button and click on the Component tab 
to display it.
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14. Double-click on the Mouse Click event to open the 
Event Options dialog.
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15. Change the Parameters field from 'Warning 
Message' to '%1' (including the single quotes). This 
value will be replaced at export time by the “Hello 
World!” text contained in the XML file you loaded 
earlier.

16. Click OK. 

17. Save and export your document. 

That's it. You have now created an SVG document that 
dynamically reads an XML data file and displays it 
using an external JavaScript function.
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Mobile Designer saves and export your movies in a 
variety of formats depending on the desired use and 
destination for the file. It also supports numerous 
options that provide control over how the output file 
looks and behaves.

In this chapter, you learn the various file storage 
formats, their uses, and how to customize and optimize 
their various settings.

Saving files
Mobile Designer saves movies in a proprietary format 
using a “.md” file extension. This proprietary file 
format contains all of the settings, properties and 
hierarchies required to open and edit the file in Mobile 
Designer at a later date.

Mobile Designer offers two options when saving files:

• The File > Save command saves the movie using 
the current name and path information.

• The File > Save As command lets you save the 
movie under a different name and path than was 
used previously.

Generally speaking, you always save a Mobile Designer 
movie at the end of a design session (if not also during), 
and export the movie to SVG or another file format 
when you are ready to preview or distribute it.

Previewing and exporting 
files
In order to view a movie as it will appear on a target 
device or in a specific file format, you must either 
preview or export it. When you perform one of these 
actions, Mobile Designer converts the internal movie 
format into one that is compatible with other popular 
viewing devices.

Preview vs. export
Both preview and export output a movie in the file 
format you designate (i.e. SVG) using the export 
options you specify (i.e. compress the output file). The 
difference between the two is what they do with the 
generated output file.

Movie preview

When you preview a movie, Mobile Designer 
generates a movie and displays that movie in the 
browser or display device you specify. It does not open 
the standard save file dialog as part of the preview 
process, so you do not end up with an exported file as 
part of the preview process.

Preview is intended to provide you with a quick and 
easy way to view the current state of your Mobile 
Designer movie while you are creating it.

Movie preview is controlled through the Format 
toolbar. Using this toolbar you can set the output 
Chapter 13: Saving, Previewing and 
Exporting
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format, the viewer used to display the movie, and the 
preview settings. The Format toolbar also includes 
buttons to generate the preview and to export the 
movie.

To select a format for preview:

Choose a file format from the Format menu in the 
Format toolbar.

To select a viewer to display the preview:

Choose a display device from the Viewer menu in the 
Format toolbar.

To specify the settings for the selected preview format:

1. Click the Preview Settings button in the Format 
toolbar.

2. In the Export dialog, choose the settings desired 
settings for the selected preview format. The 
preview settings are described below in “File 
formats” on page 218.

3. Click OK.

To preview the movie:

Click the Preview button in the Format toolbar. The 
preview is generated in the format selected and then 
automatically shown in the viewer specified.

Movie export

When you export a movie, the export process generates 
a movie that is saved on your computer using the file 
name and path you specify. This exported file can be 
played on any compatible display device or transferred 
to another machine.

Export does not automatically play the output movie as 
part of the export process.

To export a movie:

1. Do one of the following:

• Choose File > Export from the main menu and 
select a file format in the export submenu.

• Click the Export button in the Format toolbar to 
export the movie using the format specified in this 
toolbar.

2. In the Export dialog, choose the settings desired 
settings for the selected export file format. The 
export file settings are described below in “File 
formats” on page 218.

3. Click OK in the Export dialog and save the export 
file.

File formats
Mobile Designer, though primarily designed to 
produce SVG movies, is capable of outputting portions 
of movies to a wide variety of static and animated (non-
interactive) graphics formats.

Mobile Designer can output files in:

• SVG
• Animated GIF
• GIF
• JPEG
• PNG
• Targa
• TIFF
• BMP

All of the export file formats share a few common 
settings, but the majority of the settings are specific to 
each format. The common settings are described in the 
next section. The format specific options are described 
in the named sections that follow.
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Common export dialog elements

The Information section of the Export dialog contains 
general information about the selected export file 
format. This section is common to all export dialogs.
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The Document field shows the name specified for the 
movie. If none has been specified, “Untitled” is shown.

The File Size field displays the output size of the file 
computed using the current export settings.

The Show Preview box displays the export dialog’s 
preview panel. The preview display is also affected by 
the Live Update box and Update button.

The Live Update box causes the file size to be 
recomputed whenever you change any of the export 
settings. You can always manually recompute the file 
size and refresh the preview panel by clicking the 
Preview button.

The SVG export dialog
The SVG export dialog is used to specify the settings 
for SVG Tiny, SVG Basic and full SVG output files. 

SVG Options

Format for Readability results in an SVG export file 
that is suitable for easy reading and modification by 
those familiar with the SVG file format. Use of this 
option results in a slightly larger output file due to the 
spaces included for formatting purposes. The SVG 
content itself is not changed by this option.

Use GZip Compression results in an SVG export file 
that has been compressed. Compressed SVG files are 
small in size but cannot be read without first 
uncompressing them. In order to use a compressed file 
in certain browsers, the “.svgz” file extension on the 
output file must first be changed to “.svg”.

Fit to Screen results in an SVG export file that will 
automatically be resized to be displayed on as much of 
the target output device as possible. When the canvas 
dimensions are not proportional to the dimensions of 

the output device screen, a portion of the output device 
screen will not be used.

Generate HTML produces a separate HTML file that 
loads and displays the generated SVG file. The 
HTML file includes instructions describing the 
HTML code segment needed to display the SVG 
movie in your own HTML file.

Export Current Scene Only results in an SVG export 
file that only contains the current scene (i.e. the scene 
that is active when you choose File > Export > SVG). 
Any buttons or events that connect to other scenes in 
the movie have their actions removed. The buttons 
themselves are not otherwise impacted.

Override Export IDs results in an SVG export file that 
contains all of the object IDs (object names). These 
names are helpful when trying to read or modify an 
SVG file by hand, but are not required to render the 
SVG file. They are also necessary for certain JavaScript 
calls. Export IDs can be also included on an object by 
object basis for JavaScript purposes. For information on 
how to do this, see “SVG Tag Level” on page 205. 
Checking the Override Export IDs box results in an 
increased export file size.

The Interactivity Mode radio buttons determine 
which operating mode is initially used on a mobile 
device. The device user can always switch between 
modes using the built-in controls on the mobile device:

• Zoom and Pan is appropriate for SVG files that are 
large or where viewing the file is a more likely 
course of action than accessing its interactive 
elements.

• Enable Buttons is appropriate for SVG files that fit 
on the screen of the target device or those where the 
interactive elements are of primary interest.
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Image options

The Images section is used to specify how imported 
images (i.e. digital photos) are stored and compressed 
in the SVG export file. Changing the image file format 
and adjusting the image quality can have a substantial 
impact on the exported file size.

Use JPEG radio specifies that all images are to be 
converted and stored in the JPEG file format in the 
SVG export file. You have the following options when 
storing images in JPEG:

• The Progressive box is used to generate progressive 
JPEG files in the SVG export file.

• The Quality slider determines the overall quality of 
the image. The higher the quality, the better the 
image quality and the larger the file. Depending on 
the image and the target display device, using 
higher settings may not result in any noticeable 
difference in image quality.

Use PNG radio specifies that all images are to be 
converted and stored in the PNG file format in the 
SVG export file. You have the following options when 
storing images in PNG:

• The Interlace box is used to generate interlaced 
PNG files (using Adam7) in the SVG export file.

• The Color Mode menu is used to specify how 
many bits to use when storing the colors in the 
image. RGB (32 bits per pixel) produces truer color 
but larger file size than Palette (8 bits per pixel). 

• The Filter menu sets the filter algorithm that is 
applied to the entire image before compression. 
This enhances the ability of the compression phase 
to produce the smallest possible file size. A 
complete discussion of filter options is beyond the 

scope of this document; only a general description 
of each option is provided here:

• Default uses an internally determined filter on 
the data.

• None leaves the image data unchanged by 
filtering.

• Sub uses the difference between the current and 
preceding pixels to filter the data.

• Up uses the difference between the current pixel 
and the pixel directly above it to filter the data.

• Average uses the average of the current pixel with 
those to the left and above it to filter the data.

• Paeth uses a simple formula involving the current 
pixel and those to its left, above and above left to 
filter the data.

• All uses a combination of the above filters to filter 
the data.

• The Compression menu specifies the type of 
compression to use during export; the quality of the 
resultant file is identical for each of these options. 
Unless your export file is extremely large, you will 
not notice any substantial time difference between 
these options when exporting.

• Default uses an internally determined 
compression method that balances speed with 
compression levels and generally produces good 
results.

• None results in an uncompressed PNG file.

• Best Compression produces the most highly 
compressed output file possible based on the data 
from the filter selected above. This option can be 
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somewhat slower than the other compression 
options, which may not be a factor unless using 
dynamic imaging.

• Best Speed produces a compressed file as quickly 
as possible. The compression is typically not as 
tight as when using Best Compression, but the 
results are available more quickly.

Embedded vs. linked files

Imported images can be embedded in the SVG export 
file or the export file can simply contain a link to them. 
Which option is used depends on the settings in your 
current profile. For more information on setting and 
customizing profiles, see “Working with Profiles” on 
page 58.

The Animated GIF export dialog
The Animated GIF export dialog is used to specify the 
settings for animated GIF output files. 

Generic Options

Override Background Color uses the adjacent 
background color in place of the background color 
specified in your movie. Click on the color sample to 
bring up the Color dialog. For more information on 
using the Color dialog, see “Using the Color dialog” on 
page 68.

Generate HTML produces a separate HTML file that 
loads and displays the generated animated GIF file. 
The HTML file includes instructions describing the 
HTML code segment needed to display the animated 
GIF in your own HTML file.

Use Temporary Image Cache improves performance 
when previewing different export settings or re-
exporting a document that has not been changed. With 
larger images, the cache can consume a lot of memory 

and, depending on how much RAM is available, may 
need to be turned off.

Animated GIF Options

Interlace produces an image that, when displayed, 
appears to fade in as if it were appearing slowly through 
a Venetian blind. 

Loop results in an animation that will repeat the 
number of times specified in the Count box. If checked 
with no Count is specified or the count is 0, the image 
will for all practical purposes loop endlessly. (To be 
precise, it will repeat 65,536 times.)

Override Document Speed sets a new duration for 
every frame in the document. Frame rates are in units 
of 1/100th of a second.

Color Reduction options

The Color Reduction Options section contains 
settings that determine how color is handled in the 
Animated GIF file.

The Palette menu specifies which set of 256 (or fewer) 
colors will be used in the exported animation. The 
Palette menu choices are:

• Adaptive, which automatically selects a set of 
colors that best approximate the original.

• Web-safe, which uses a standard set of 216 Web 
colors that can be displayed by virtually any browser 
on any platform.

• Windows and Mac OS, which select colors that 
will give the best results when displayed in an 8-bit 
color mode on the indicated operating system.

The Colors value field and adjacent menu specify the 
number of colors used in the exported animation. 
Depending on the kinds of objects used, setting this 
below 256 can seriously degrade image quality. On the 
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other hand, reducing the number of colors can often 
significantly reduce file size.

The Color Reduction menu specifies the method used 
to reduce the number of colors in the image during 
export. Because results vary depending on your 
animation, you should experiment with both methods 
to determine which produces the best results.

The Dithering box may produce more pleasing results 
by blending colors to approximate colors that have been 
eliminated. However, dithering can also substantially 
increase file size.

The GIF export dialog
The GIF export dialog is used to specify the settings 
for (static) GIF output files. 

Generic Options

Override Background Color uses the adjacent 
background color in place of the background color 
specified in your movie. Click on the color sample to 
bring up the Color dialog. For more information on 
using the Color dialog, see “Using the Color dialog” on 
page 68.

Generate HTML produces a separate HTML file that 
loads and displays the generated GIF file. The HTML 
file includes instructions describing the HTML code 
segment needed to display the GIF image in your own 
HTML file.

Use Temporary Image Cache improves performance 
when previewing different export settings or re-
exporting a document that has not been changed. With 
larger images, the cache can consume a lot of memory 
and, depending on how much RAM is available, may 
need to be turned off.

GIF Options

Interlace produces an image that, when displayed, 
appears to fade in as if it were appearing slowly through 
a Venetian blind. 

Color Reduction options

The Palette menu specifies which set of 256 (or fewer) 
colors will be used in the exported image. The Palette 
menu choices are:

• Adaptive, which automatically selects a set of 
colors that best approximate the original.

• Web-safe, which uses a standard set of 216 Web 
colors that can be displayed by virtually any browser 
on any platform.

• Windows and Mac OS, which select colors that 
will give the best results when displayed in an 8-bit 
color mode on the indicated operating system.

The Colors value field and adjacent menu specify the 
number of colors used in the exported file. Depending 
on the kinds of objects used, setting this below 256 can 
seriously degrade image quality. On the other hand, 
reducing the number of colors can often significantly 
reduce file size.

The Color Reduction menu specifies the method used 
to reduce the number of colors in the image during 
export. Because results vary depending on your image, 
you should experiment with both methods to 
determine which produces the best results.

The Dithering box may produce more pleasing results 
by blending colors to approximate colors that have been 
eliminated. However, dithering can also substantially 
increase file size.
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The JPEG export dialog
The JPEG export dialog is used to specify the settings 
for JPEG output files. 

Generic Options

Override Background Color uses the adjacent 
background color in place of the background color 
specified in your movie. Since the JPEG file format 
does not support background transparency, this field 
always shows a solid color and is always active. Click on 
the color sample to bring up the Color dialog. For more 
information on using the Color dialog, see “Using the 
Color dialog” on page 68.

Generate HTML produces a separate HTML file that 
loads and displays the generated JPEG file. The 
HTML file includes instructions describing the 
HTML code segment needed to display the JPEG 
image in your own HTML file.

Use Temporary Image Cache improves performance 
when previewing different export settings or re-
exporting a document that has not been changed. With 
larger images, the cache can consume a lot of memory 
and, depending on how much RAM is available, may 
need to be turned off.

JPEG Options

The Progressive box is used to generate progressive 
JPEG files in the SVG export file.

The Quality slider determines the overall quality of the 
image. The higher the quality, the better the image 
quality and the larger the file. Depending on the image 
and the target display device, using higher settings may 
not result in any noticeable difference in image quality.

The PNG export dialog
The PNG export dialog is used to specify the settings 
for PNG output files. 

Generic Options

Override Background Color uses the adjacent 
background color in place of the background color 
specified in your movie. Click on the color sample to 
bring up the Color dialog. For more information on 
using the Color dialog, see “Using the Color dialog” on 
page 68.

Generate HTML produces a separate HTML file that 
loads and displays the generated GIF file. The HTML 
file includes instructions describing the HTML code 
segment needed to display the GIF image in your own 
HTML file.

Use Temporary Image Cache improves performance 
when previewing different export settings or re-
exporting a document that has not been changed. With 
larger images, the cache can consume a lot of memory 
and, depending on how much RAM is available, may 
need to be turned off.

PNG Options

The Color Mode menu is used to specify how many 
bits to use when storing the colors in the image. RGB 
(32 bits per pixel) produces truer color but larger file 
size than Palette (8 bits per pixel). 

The Interlace box is used to generate interlaced PNG 
files (using Adam7).

The Filter menu sets the filter algorithm that is applied 
to the entire image before compression. This enhances 
the ability of the compression phase to produce the 
smallest possible file size. A complete discussion of 
filter options is beyond the scope of this document; 
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only a general description of each option is provided 
here:

• Default uses an internally determined filter on the 
data.

• None leaves the image data unchanged by filtering.
• Sub uses the difference between the current and 

preceding pixels to filter the data.
• Up uses the difference between the current pixel 

and the pixel directly above it to filter the data.
• Average uses the average of the current pixel with 

those to the left and above it to filter the data.
• Paeth uses a simple formula involving the current 

pixel and those to its left, above and above left to 
filter the data.

• All uses a combination of the above filters to filter 
the data.

The Compression menu specifies the type of 
compression to use during export; the quality of the 
resultant file is identical for each of these options. 
Unless your export file is extremely large, you will not 
notice any substantial time difference between these 
options when exporting.

• Default uses an internally determined compression 
method that balances speed with compression 
levels and generally produces good results.

• None results in an uncompressed PNG file.
• Best Compression produces the most highly 

compressed output file possible based on the data 
from the filter selected above. This option can be 
somewhat slower than the other compression 
options, which may not be a factor unless using 
dynamic imaging.

• Best Speed produces a compressed file as quickly as 
possible. The compression is typically not as tight 
as when using Best Compression, but the results 
are available more quickly.

Color Reduction options

The Palette menu specifies which set of 256 (or fewer) 
colors will be used in the exported image. The Palette 
menu choices are:

• Adaptive, which automatically selects a set of 
colors that best approximate the original.

• Web-safe, which uses a standard set of 216 Web 
colors that can be displayed by virtually any browser 
on any platform.

• Windows and Mac OS, which select colors that 
will give the best results when displayed in an 8-bit 
color mode on the indicated operating system.

The Colors value field and adjacent menu specify the 
number of colors used in the exported image. 
Depending on the kinds of objects used, setting this 
below 256 can seriously degrade image quality. On the 
other hand, reducing the number of colors can often 
significantly reduce file size.

The Color Reduction menu specifies the method used 
to reduce the number of colors in the image during 
export. Because results vary depending on your file, you 
should experiment with both methods to determine 
which produces the best results.

The Dithering box may produce more pleasing results 
by blending colors to approximate colors that have been 
eliminated. However, dithering can also substantially 
increase file size.

The Targa export dialog
The Targa export dialog is used to specify the settings 
for Targa output files. 
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Generic Options

Override Background Color uses the adjacent 
background color in place of the background color 
specified in your movie. Click on the color sample to 
bring up the Color dialog. For more information on 
using the Color dialog, see “Using the Color dialog” on 
page 68.

Use Temporary Image Cache improves performance 
when previewing different export settings or re-
exporting a document that has not been changed. With 
larger images, the cache can consume a lot of memory 
and, depending on how much RAM is available, may 
need to be turned off.

Targa Options

Save Alpha includes the 8-bit alpha channel in the 
exported file. Because not all applications handle alpha 
transparency, you have the option of including it as part 
of your export. Excluding the alpha transparency will 
result in a smaller export file size.

The TIFF export dialog
The TIFF export dialog is used to specify the settings 
for TIFF output files. 

Generic Options

Override Background Color uses the adjacent 
background color in place of the background color 
specified in your movie. Click on the color sample to 
bring up the Color dialog. For more information on 
using the Color dialog, see “Using the Color dialog” on 
page 68.

Use Temporary Image Cache improves performance 
when previewing different export settings or re-
exporting a document that has not been changed. With 
larger images, the cache can consume a lot of memory 

and, depending on how much RAM is available, may 
need to be turned off.

TIFF Options

The Compression menu is used to set which 
compression method is used in he exported TIFF 
image. The options are:

• None, which uses no compression, allocating either 
24 or 32-bits for each pixel in your image (see Save 
Alpha below) and producing very large, lossless 
files.

• LZW, which uses the LZW compression 
algorithm to produce smaller, lossless files. It is 
usually the best lossless compression choice in 
terms of file size.

• JPEG, which uses a lossy compression algorithm to 
produce smaller files. With JPEG compression, 
you have control over the quality level (see JPEG 
Quality below).

• PackBits, which is a lossless compression algorithm 
similar to LZW. It may be slightly faster but 
produce slightly larger files than LZW.

• Deflate, which uses a lossy, differential 
compression algorithm. It compares favorably with 
LZW compression though some image 
degradation is possible.

The Byte Order radios are used to select which byte 
order, Macintosh or IBM PC, is used in the exported 
TIFF image.

Save Alpha includes the 8-bit alpha channel in the 
exported file. Because not all applications handle alpha 
transparency, you have the option of including it as part 
of your export. Excluding the alpha transparency will 
result in a smaller export file size.

The JPEG Quality slider, which is only available when 
the Compression menu (see above) is set to JPEG, 
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determines the overall quality of the image. The higher 
the quality, the better the image quality and the larger 
the file. Depending on the image and the target display 
device, using higher settings may not result in any 
noticeable difference in image quality.

The BMP export dialog
The BMP export dialog is used to specify the settings 
for BMP output files (of which there is only one 
option). 

Generic Options

Use Temporary Image Cache improves performance 
when previewing different export settings or re-
exporting a document that has not been changed. With 
larger images, the cache can consume a lot of memory 
and, depending on how much RAM is available, may 
need to be turned off.
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Index

Numerics
3D

ambient light color 87
light color 87
light coordinates 87
lighting 87
perspective 88
rotation 87

3D attributes 87
3D bar charts 95
3D pie charts 91
3D text

editing 86
extrusion 86
proportions 86

3D Text tab 86
3D text tool 25

A
Actions 141
Adobe Illustrator 166
Adobe Photoshop 167
Aligned 3D charts 97
Aligning

by distributing 112
by enlarging 111
by packing 112
object centers 111
object edges 111

Alignment tab 81, 111
Animating points on curves 121
Animating text to move along a curve 121
Animation

3D objects 123
adding frames 124
Animation Wizard 124
between points 120
current frame 30, 31

defined 119
deleting frames 124
effects 122
filters 122
frame controls 30
frame level manipulation 124
frame rate 30
frame slider 30
grid 32
keys 32
moving for an object 126
non-linear 128
object level manipulation 125
object list 31
of objects 120
panel 119
panel buttons 30
playback controls 29
points on curves 121
principles 119
property manipulation 127
range handles 32
resizing for an object 125
text on curve 121
total frames 30
Tweening Wizard 31, 128

Animation clips 152
Component tab 152
defined 19
end of clip actions 153
initial play state 152
initial visibility 152

Animation grid 32
Animation panel 28
Animation range handles 32
Animation Wizard 124
Animation Wizard Button 30
Area charts 93
Arrow tool 24
Axis tab 100
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B
Bar charts 94
Beatware Mobile Designer

overview 15
web site 9

Bezier tool 25
Books 153

adding components to 154
adding pages 154
background 153
book designer 154
Component tab 154
creating 153
defined 20
deleting pages 155
foreground 153
Locator bar 154
pages 153
reordering pages 155
setting initial visibility 155

Buttons 144
animating states 145
assigning actions to events 146
changing labels 146
Component tab 146
defined 19
hiding initially 146
removing actions 146
states 145

C
Call JavaScript Function 144, 207
Canvas 26
Catalog tab 45
Chart tab 88
Charts

3D bar 95
3D pie 91
Aligned 3D 97
Area 93
associating XML data 198

Bar 94
customizing 43
drawing 43
Legend tool 25
Legends 99
Line 93
Line 3D 98
Linear meter 90
list of available 89
multiple series 89
Multiple series tool 25
Pie 91
Radar 96
Simple bar 92
single series 89
Single series tool 25
single value 89
Single value tool 25
Speedometer 89
types 42

Color
3D text 67
adding to gradients 71
applying 68
CMYK 69
customizing gradients 71
dialog 68
gradient shapes 71
gradients 70
HSB 69
no color 68
patterns 72
removing from gradients 71
RGB 68
samples 67
shapes 67
solid 68
storing custom 70
text 67
types 68
understanding 67
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using the eye dropper 70
web palette 70
wheel 69

Component designer 141
defined 21
exiting 22
opening 22

Components
actions 141
adding actions to 144
bounding box color 141
creating from scratch 44
creating from sharing 45
creating from the catalog 45
defined 18
editing 141
editing existing 46
events 141
exiting the component designer 141
introduced 17
list 18

Content
types of 17

Converting primitives into components 46
Cropping

to objects 136
to selections 137

Current frame 30
Curves tab 105
Customer support 9

D
Document window 26
Down State 145
Drawing

charts 43
in components vs. scenes 21
legends 43

E
Effects

adding 81
animating 122
deleting 81
editing 81

Effects tab 80
Ellipse tool 25
Elliptical marquee tool 24
Event Options dialog 143
Events 141

assigning actions to 142
Export

animated GIF 222
BMP 227
file formats 218
GIF 223
JPEG 224
PNG 224
SVG 220
Targa 225
TIFF 226

Export ID 188
Eye dropper 70
Eye dropper tool 25

F
File formats

Beatware Mobile Designer 166
supported 166
Vector 166

Files
importing 165
opening 165
saving 217

Filters
adding 80
animating 122
deleting 80
editing 80
ordering 80

Filters tab 80
Format toolbar 34
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Frame controls 30
Frame rate 30
Frame slider 30

G
Go to Next Page of Book 144
Go to Previous Page of Book 144
Grid 113

gridline spacing 113
hiding 113
showing 113
snapping to 113

Guides 113
creating 114
deleting 114
hiding 114
locking 114
moving 114
showing 114
snapping to 114

H
Hand tool 25
Hide Component 144

I
Importing

3D files 167
Adobe Illustrator 166
animated sequence 165
Bitmap files 167
graphics 165
multiple images 165
sound files 167
sounds 165
SVG 166
Windows MetaFile 166

Info tab 81
Inspector panel 27

adding 76
adding tabs 76

menu 75
menu icon 75
overview 75
removing tabs 76
selecting 75
splitter 75

Inspector toolbar 34
Inspectors

panel menu 27
Panel menu icon 27
splitter 27

Installation 7
Interactive books

see Books 20

J
JavaScript 205

animation 209
button events 206
Call JavaScript Function 207
component level 206
Movie Properties dialog 206
Onkeypress 136
Onload 136
parameters 136, 214
SVG tag level 205
XML data connections 209
XML Data dialog 211

Jump to First Page of Book 144
Jump to Last Page of Book 144
Jump to Specific Page of Book 144
Jump to Specific Scene 144
Jump to URL 144

K
Keys

adding to an object 126
moving 126

L
Labels tab 103
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Lasso tool 24
Legend tool 25
Legends 99

drawing 43
Limits 137

hiding 137
resizing the canvas using 137
showing 137

Line 3D charts 98
Line charts 93
Linear meter charts 90
Locator bar 21, 32

M
Magic wand tool 24
Magnifying 137
Menu bar 34
Menu buttons 147

adding items to the popup menu 148
changing the label 148
Component tab 147
defined 19
hiding initially 148

Mobile Designer
work area 23

Movie element hierarchy 19
Movies 133

exporting 218
frame rate 135
Movie Creator dialog 134
Movie Properties dialog 135
Onkeypress JavaScript 136
Onload JavaScript 136
preview vs. export 217
previewing 217
properties 133
setting canvas dimensions 134
setting the background color 134
setting the profile 134
templates 134

N
Nav bars

see Navigation bars 20
Navigation bars 150

adding buttons 150
assigning actions to buttons 151
button labels 150
changing templates 151
Component tab 150
defined 20
deleting buttons 151
drawing 150
orientation 151
removing assigned actions 151
renaming buttons 150
reordering buttons 151
spacing 151

Navigation menu 21, 29
Non-linear animation 128

O
Object

aliasing 78
composite method 78
coordinates 77
dimensions 77
exporting names to SVG 78
opacity 77
rotation 77

Object tab 77
Objects

aligning centers 111
aligning edges 111
animating 120
changing attributes 76
creating 140
defined 18
deleting 49
distributing 112
enlarging 111
grouping 49
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hiding 48
locking 50
masking 50
moving 47
opacity 50
ordering 49
packing 112
renaming 49
resizing 47
rotating 48
selecting 47
showing 48
unlocking 50

Onkeypress 136
Onload 136
Over State 145
Overscan

hiding objects 138
showing objects 138

Overscan area 26
Overscan button 26

P
Paint bucket tool 25
Pan tool 25
Panning 138
Paragraph tab 85
Paragraph text

alignment 85
indentation 85
line spacing 85

Paragraph text tool 25
Pen tool 25
Pencil tool 25
Pie charts 91
Play Animation 144
Play Sound 144
Playback controls 29
Popup menu 147

assigning actions to items 148
changing templates 149

defined 19
deleting items 148
item spacing 149
location 149
orientation 149
removing items 148
renaming items 148
reordering items 148

Preferences 8
General tab 8
Miscellaneous tab 8
Overscan tab 8
Tooltips tab 8

Primitives
converting into components 46
defined 18
drawing 37
introduced 17
list 18

Profile toolbar 33
Profiles

changing 57
compared 56
composition options 60
custom 57
customizable features 58
dialog 57
effect options 60
fill options 58
filter options 60
loading rules 58
mask options 60
normal 55
overview 55
standard 55
stroke options 59
SVG Basic 55
SVG options 61
SVG Tiny 1.1 55
SVG Tiny 1.2 55
text options 60
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Property keys
adding 127
deleting 127
displaying 127
moving 127

R
Radar charts 96
Rectangle tool 25
Rectangular marquee tool 24
Registering 8
Replication 187

books 188
objects inside components and groups 188
scripting 188

Rounded rectangle tool 25
Rulers 112

changing the origin 112
hiding 112
showing 112

S
Scenes

adding sounds to 140
animating objects in 140
background color 139
creating 139
creating objects in 140
defined 19
deleting 139
determining the current 140
navigating between 140
properties 138
setting as first 139
stopping sounds when entering 139

Send e-mail 144
Shapes

Bezier 40
color 67
drawing 39
pencil 41

polyline 39
Sharing tab 46
Show Component 144
Simple bar charts 92
Speedometer chart 89
Standard toolbar 33
Stop All Sounds 144
Stop Animation 144
Stroke

caps 79
dash pattern 79
joins 79

Stroke tab 79
SVG player

downloading 7
System requirements 7

T
Text

3D color 67
bounding box options 83
color 67
converting to Beziers 41
customizing 82
drawing 38
font size 83
fonts 83
shearing 83
style 83
tabs 82
tracking 83
types of 38

Text Effect tab 85
Text effects

adding 86
deleting 86
editing 86

Text on curve tool 25
Text tab 82
Text tool 25
Timeline 31
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current frame 31
Toolbars

format 34
inspector 34
profile 33
standard 33

Toolbox 24
Tools

changing attributes 76
selecting hidden 37
selecting visible 37

Total frames 30
Transformation tool 24
Tweening Wizard 128

changing animation segments 129
changing animation settings 129
changing the motion 129
changing the path 130
opening 128

Tweening wizard 31

U
Up State 145

W
Walls tab 104
WMF 166

X
XML 177

assocating data with objects 177
XML associations 178

adding 178
button label 190
button link 190
deleting 178
dynamic script parameters 190
editing 178
fill color 179
horizontal scaling 184
horizontal translation 183

image URL 191
list of supported 179
multiple series charts 201
opacity 186
replication 187
rotation 185
single series charts 200
single value charts 198
stroke color 181
text 189
vertical scaling 184
vertical translation 183
visibility 186

XML Data dialog 211
XML Data files 192

adding 192
deleting 192
editing the location of 192
replication 195

XML Data Mapping 193
XML tab 178

Z
Zoom

in 26
menu 26
out 26

Zoom tool 25
Zooming 137
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